Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-19276

Reset UI State does not clear ongoing wizard data

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 2.5.0
    • 2.5.0
    • None
    • None

    Description

      STR:

      1. Log into ambari-web and start "Add Service Wizard"
      2. Close the browser (simulate the scenario of browser crash)
      3. Log in from another credentials to ambari-web
      4. A message that add service wizard is ongoing will appear
      5. Got to ambari-web experimental page and reset ui state

      Expected: The label should disappear showing for all users and the user who started add service wizard should not renavigate to add service wizard on logging in back
      Actual: The labe ldoes not disappear for other users.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            aantonenko Antonenko Alexander
            jaimin Jaimin Jetly
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment