Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-15830

Atlas Upgrade Check

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.4.0
    • Component/s: ambari-server
    • Labels:
      None

      Description

      Atlas for HDP 2.5 will need to be a new install. Atlas does not support upgrade (rolling upgrade or otherwise) from prior versions. It is only from HDP 2.5 on that Atlas support express and rolling upgrades.
      Because of this, it is necessary to have a pre upgrade check in Ambari that handles this case by asking the user to uninstall Atlas prior to upgrade. After the cluster has been upgraded, Atlas can be added to the cluster using the Ambari add service mechanism. This will result in a clean/new install of Atlas that will from this point on support rolling and express upgrades.

        Attachments

        1. AMBARI-15830.patch.1
          15 kB
          Dmytro Grinenko
        2. AMBARI-15830.patch
          15 kB
          Dmytro Grinenko

          Issue Links

            Activity

              People

              • Assignee:
                dmitriusan Dmitry Lysnichenko
                Reporter:
                hapylestat Dmytro Grinenko
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: