Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-14149

Python 2.7.9 or later fails to establish connection between agent and server.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.0
    • Component/s: None
    • Labels:
      None

      Description

      Ambari-agent would not talk to ambari-server.

      INFO 2015-11-14 15:26:48,572 main.py:289 - Connecting to Ambari server at https://sandbox.hortonworks.com:8440 (10.0.2.15)
      INFO 2015-11-14 15:26:48,572 NetUtil.py:59 - Connecting to https://sandbox.hortonworks.com:8440/ca
      ERROR 2015-11-14 15:26:48,693 NetUtil.py:77 - [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)
      ERROR 2015-11-14 15:26:48,693 NetUtil.py:78 - SSLError: Failed to connect. Please check openssl library versions.
      Refer to: https://bugzilla.redhat.com/show_bug.cgi?id=1022468 for more details.
      WARNING 2015-11-14 15:26:48,695 NetUtil.py:105 - Server at https://sandbox.hortonworks.com:8440 is not reachable, sleeping for 10 seconds...

      STR might include enabling two-way ssl.

        Issue Links

          Activity

          Hide
          aonishuk Andrew Onischuk added a comment -

          Committed to trunk and branch-2.1

          Show
          aonishuk Andrew Onischuk added a comment - Committed to trunk and branch-2.1
          Hide
          hudson Hudson added a comment -

          FAILURE: Integrated in Ambari-branch-2.1 #985 (See https://builds.apache.org/job/Ambari-branch-2.1/985/)
          AMBARI-14149. Python 2.7.9 or later fails to establish connection (aonishuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=1e8d1e8b9d24b8360767274065336b0cf5a555ed)

          • ambari-agent/src/main/python/ambari_agent/NetUtil.py
          Show
          hudson Hudson added a comment - FAILURE: Integrated in Ambari-branch-2.1 #985 (See https://builds.apache.org/job/Ambari-branch-2.1/985/ ) AMBARI-14149 . Python 2.7.9 or later fails to establish connection (aonishuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=1e8d1e8b9d24b8360767274065336b0cf5a555ed ) ambari-agent/src/main/python/ambari_agent/NetUtil.py
          Hide
          hudson Hudson added a comment -

          SUCCESS: Integrated in Ambari-trunk-Commit #3952 (See https://builds.apache.org/job/Ambari-trunk-Commit/3952/)
          AMBARI-14149. Python 2.7.9 or later fails to establish connection (aonishuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=aa1eb7e492faa237bb8ad60354dce38fdf0b2a08)

          • ambari-agent/src/main/python/ambari_agent/NetUtil.py
          Show
          hudson Hudson added a comment - SUCCESS: Integrated in Ambari-trunk-Commit #3952 (See https://builds.apache.org/job/Ambari-trunk-Commit/3952/ ) AMBARI-14149 . Python 2.7.9 or later fails to establish connection (aonishuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=aa1eb7e492faa237bb8ad60354dce38fdf0b2a08 ) ambari-agent/src/main/python/ambari_agent/NetUtil.py
          Hide
          jmarron Juanjo Marron added a comment -

          Hit this same issue in a RHEL 7.4 power cluster where the python version is 2.7.5.
          Since that the context=ssl._create_unverified_context() argument would be required also in python versions leaser than 2.7.9

          Show
          jmarron Juanjo Marron added a comment - Hit this same issue in a RHEL 7.4 power cluster where the python version is 2.7.5. Since that the context=ssl._create_unverified_context() argument would be required also in python versions leaser than 2.7.9

            People

            • Assignee:
              aonishuk Andrew Onischuk
              Reporter:
              aonishuk Andrew Onischuk
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development