Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-12784

RU: HS2 fails to start with invalid maximum heap size

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.2
    • Component/s: stacks
    • Labels:
      None

      Description

      After upgrading from Ambari 1.7 to Ambari 2.1 and HDP 2.2.0 to HDP 2.3, Hive fails to start after upgrade during rolling upgrade due to hive-env.sh having HADOOP_HEAPSIZE=512*m*. The HADOOP_CLIENT_OPTS assumes it’s an int and tacts on an additional “m” so it ends up setting the -Xmx to 512mm instead of -Xmx to 512m

        Issue Links

          Activity

          Hide
          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12750784/AMBARI-12784.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in ambari-server:

          org.apache.ambari.server.controller.AmbariManagementControllerTest

          Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/3593//testReport/
          Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/3593//console

          This message is automatically generated.

          Show
          hadoopqa Hadoop QA added a comment - -1 overall . Here are the results of testing the latest attachment http://issues.apache.org/jira/secure/attachment/12750784/AMBARI-12784.patch against trunk revision . +1 @author . The patch does not contain any @author tags. -1 tests included . The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch. +1 javac . The applied patch does not increase the total number of javac compiler warnings. +1 release audit . The applied patch does not increase the total number of release audit warnings. -1 core tests . The patch failed these unit tests in ambari-server: org.apache.ambari.server.controller.AmbariManagementControllerTest Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/3593//testReport/ Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/3593//console This message is automatically generated.
          Hide
          dsen Dmytro Sen added a comment -

          Committed to trunk and branch-2.1

          Show
          dsen Dmytro Sen added a comment - Committed to trunk and branch-2.1
          Hide
          hudson Hudson added a comment -

          FAILURE: Integrated in Ambari-trunk-Commit #3281 (See https://builds.apache.org/job/Ambari-trunk-Commit/3281/)
          AMBARI-12784 RU: HS2 fails to start with invalid maximum heap size (dsen) (dsen: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=baed7e987ce5ad1628120655d6de33bf314bf08b)

          • ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog210.java
          Show
          hudson Hudson added a comment - FAILURE: Integrated in Ambari-trunk-Commit #3281 (See https://builds.apache.org/job/Ambari-trunk-Commit/3281/ ) AMBARI-12784 RU: HS2 fails to start with invalid maximum heap size (dsen) (dsen: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=baed7e987ce5ad1628120655d6de33bf314bf08b ) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog210.java
          Hide
          hudson Hudson added a comment -

          FAILURE: Integrated in Ambari-branch-2.1 #381 (See https://builds.apache.org/job/Ambari-branch-2.1/381/)
          AMBARI-12784 RU: HS2 fails to start with invalid maximum heap size (dsen) (dsen: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=b9d7ef759fbb5d506ae74879dcae3040f26e0831)

          • ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog210.java
          Show
          hudson Hudson added a comment - FAILURE: Integrated in Ambari-branch-2.1 #381 (See https://builds.apache.org/job/Ambari-branch-2.1/381/ ) AMBARI-12784 RU: HS2 fails to start with invalid maximum heap size (dsen) (dsen: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=b9d7ef759fbb5d506ae74879dcae3040f26e0831 ) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog210.java

            People

            • Assignee:
              dsen Dmytro Sen
              Reporter:
              dsen Dmytro Sen
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development