Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-12538

Attempting to access the Ambari Dashboard results in an HTTP 500 Error after changing cluster name and restarting the Ambari server

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.2
    • Component/s: None
    • Labels:
      None
    • Environment:

      SLES11 SP3

      Description

      Steps to reproduce:

      • Login to Ambari Web UI
      • Rename cluster (Admin -> Manage Ambari -> Rename Cluister -> Enter new name )
      • Restart Ambari Server via CLI (ambari-server restart)
      • Login to Ambari Web UI again
      • When attempting to access the Ambari Dashboard an HTTP 500 Error will occur:
        Error
        500 status code received on GET method for API: /api/v1/clusters/<CLUSTERNAME>/requests?to=end&page_size=10&fields=Requests 
        Error message: Server Error
        

      Excerpt from the Ambari Server log:

      24 Jul 2015 16:40:41,013 ERROR [qtp-client-25] ReadHandler:91 - Caught a runtime exception executing a query
      java.lang.RuntimeException: Failed to construct logical request during replay: org.apache.ambari.server.ClusterNotFoundException: Cluster not found, clusterName=PIRIPIRI
              at org.apache.ambari.server.topology.PersistedStateImpl.getAllRequests(PersistedStateImpl.java:167)
              at org.apache.ambari.server.topology.TopologyManager.ensureInitialized(TopologyManager.java:91)
              at org.apache.ambari.server.topology.TopologyManager.getRequests(TopologyManager.java:198)
              at org.apache.ambari.server.actionmanager.ActionManager.getRequestsByStatus(ActionManager.java:232)
              at org.apache.ambari.server.controller.internal.RequestResourceProvider.getRequestResources(RequestResourceProvider.java:414)
              at org.apache.ambari.server.controller.internal.RequestResourceProvider.getResources(RequestResourceProvider.java:200)
              at org.apache.ambari.server.controller.internal.ClusterControllerImpl$ExtendedResourceProviderWrapper.queryForResources(ClusterControllerImpl.java:945)
              at org.apache.ambari.server.controller.internal.ClusterControllerImpl.getResources(ClusterControllerImpl.java:132)
              at org.apache.ambari.server.api.query.QueryImpl.doQuery(QueryImpl.java:482)
              at org.apache.ambari.server.api.query.QueryImpl.queryForResources(QueryImpl.java:381)
              at org.apache.ambari.server.api.query.QueryImpl.execute(QueryImpl.java:217)
              at org.apache.ambari.server.api.handlers.ReadHandler.handleRequest(ReadHandler.java:68)
              at org.apache.ambari.server.api.services.BaseRequest.process(BaseRequest.java:135)
              at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:105)
              at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:74)
              at org.apache.ambari.server.api.services.RequestService.getRequests(RequestService.java:95)
              at sun.reflect.GeneratedMethodAccessor112.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:483)
              at com.sun.jersey.spi.container.JavaMethodInvokerFactory$1.invoke(JavaMethodInvokerFactory.java:60)
              at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMethodDispatchProvider$ResponseOutInvoker._dispatch(AbstractResourceMethodDispatchProvider.java:205)
              at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDispatcher.dispatch(ResourceJavaMethodDispatcher.java:75)
              at com.sun.jersey.server.impl.uri.rules.HttpMethodRule.accept(HttpMethodRule.java:302)
              at com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:137)
              at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
              at com.sun.jersey.server.impl.uri.rules.ResourceClassRule.accept(ResourceClassRule.java:108)
              at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
              at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept(RootResourceClassesRule.java:84)
              at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1542)
              at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1473)
              at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1419)
              at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1409)
              at com.sun.jersey.spi.container.servlet.WebComponent.service(WebComponent.java:409)
              at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:540)
              at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:715)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:770)
              at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1496)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
              at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:118)
              at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:84)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.access.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:113)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.session.SessionManagementFilter.doFilter(SessionManagementFilter.java:103)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.authentication.AnonymousAuthenticationFilter.doFilter(AnonymousAuthenticationFilter.java:113)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.servletapi.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:54)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.savedrequest.RequestCacheAwareFilter.doFilter(RequestCacheAwareFilter.java:45)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.apache.ambari.server.security.authorization.AmbariAuthorizationFilter.doFilter(AmbariAuthorizationFilter.java:182)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.authentication.www.BasicAuthenticationFilter.doFilter(BasicAuthenticationFilter.java:150)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.context.SecurityContextPersistenceFilter.doFilter(SecurityContextPersistenceFilter.java:87)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.FilterChainProxy.doFilterInternal(FilterChainProxy.java:192)
              at org.springframework.security.web.FilterChainProxy.doFilter(FilterChainProxy.java:160)
              at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:237)
              at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:167)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.apache.ambari.server.api.MethodOverrideFilter.doFilter(MethodOverrideFilter.java:72)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.apache.ambari.server.api.AmbariPersistFilter.doFilter(AmbariPersistFilter.java:47)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.eclipse.jetty.servlets.UserAgentFilter.doFilter(UserAgentFilter.java:82)
              at org.eclipse.jetty.servlets.GzipFilter.doFilter(GzipFilter.java:294)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:501)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
              at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)
              at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
              at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
              at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:429)
              at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
              at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
              at org.apache.ambari.server.controller.AmbariHandlerList.processHandlers(AmbariHandlerList.java:209)
              at org.apache.ambari.server.controller.AmbariHandlerList.processHandlers(AmbariHandlerList.java:198)
              at org.apache.ambari.server.controller.AmbariHandlerList.handle(AmbariHandlerList.java:132)
              at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
              at org.eclipse.jetty.server.Server.handle(Server.java:370)
              at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)
              at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:971)
              at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:1033)
              at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:644)
              at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
              at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
              at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696)
              at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53)
              at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
              at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
              at java.lang.Thread.run(Thread.java:745)
      Caused by: org.apache.ambari.server.ClusterNotFoundException: Cluster not found, clusterName=PIRIPIRI
              at org.apache.ambari.server.state.cluster.ClustersImpl.getCluster(ClustersImpl.java:265)
              at org.apache.ambari.server.topology.LogicalRequest.<init>(LogicalRequest.java:81)
              at org.apache.ambari.server.topology.LogicalRequestFactory.createRequest(LogicalRequestFactory.java:38)
              at org.apache.ambari.server.topology.PersistedStateImpl.getAllRequests(PersistedStateImpl.java:164)
              ... 94 more
      24 Jul 2015 16:40:41,014  WARN [qtp-client-25] ServletHandler:563 - /api/v1/clusters/ZARSH/requests
      java.lang.RuntimeException: Failed to construct logical request during replay: org.apache.ambari.server.ClusterNotFoundException: Cluster not found, clusterName=PIRIPIRI
              at org.apache.ambari.server.topology.PersistedStateImpl.getAllRequests(PersistedStateImpl.java:167)
              at org.apache.ambari.server.topology.TopologyManager.ensureInitialized(TopologyManager.java:91)
              at org.apache.ambari.server.topology.TopologyManager.getRequests(TopologyManager.java:198)
              at org.apache.ambari.server.actionmanager.ActionManager.getRequestsByStatus(ActionManager.java:232)
              at org.apache.ambari.server.controller.internal.RequestResourceProvider.getRequestResources(RequestResourceProvider.java:414)
              at org.apache.ambari.server.controller.internal.RequestResourceProvider.getResources(RequestResourceProvider.java:200)
              at org.apache.ambari.server.controller.internal.ClusterControllerImpl$ExtendedResourceProviderWrapper.queryForResources(ClusterControllerImpl.java:945)
              at org.apache.ambari.server.controller.internal.ClusterControllerImpl.getResources(ClusterControllerImpl.java:132)
              at org.apache.ambari.server.api.query.QueryImpl.doQuery(QueryImpl.java:482)
              at org.apache.ambari.server.api.query.QueryImpl.queryForResources(QueryImpl.java:381)
              at org.apache.ambari.server.api.query.QueryImpl.execute(QueryImpl.java:217)
              at org.apache.ambari.server.api.handlers.ReadHandler.handleRequest(ReadHandler.java:68)
              at org.apache.ambari.server.api.services.BaseRequest.process(BaseRequest.java:135)
              at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:105)
              at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:74)
              at org.apache.ambari.server.api.services.RequestService.getRequests(RequestService.java:95)
              at sun.reflect.GeneratedMethodAccessor112.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:483)
              at com.sun.jersey.spi.container.JavaMethodInvokerFactory$1.invoke(JavaMethodInvokerFactory.java:60)
              at com.sun.jersey.server.impl.model.method.dispatch.AbstractResourceMethodDispatchProvider$ResponseOutInvoker._dispatch(AbstractResourceMethodDispatchProvider.java:205)
              at com.sun.jersey.server.impl.model.method.dispatch.ResourceJavaMethodDispatcher.dispatch(ResourceJavaMethodDispatcher.java:75)
              at com.sun.jersey.server.impl.uri.rules.HttpMethodRule.accept(HttpMethodRule.java:302)
              at com.sun.jersey.server.impl.uri.rules.SubLocatorRule.accept(SubLocatorRule.java:137)
              at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
              at com.sun.jersey.server.impl.uri.rules.ResourceClassRule.accept(ResourceClassRule.java:108)
              at com.sun.jersey.server.impl.uri.rules.RightHandPathRule.accept(RightHandPathRule.java:147)
              at com.sun.jersey.server.impl.uri.rules.RootResourceClassesRule.accept(RootResourceClassesRule.java:84)
              at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1542)
              at com.sun.jersey.server.impl.application.WebApplicationImpl._handleRequest(WebApplicationImpl.java:1473)
              at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1419)
              at com.sun.jersey.server.impl.application.WebApplicationImpl.handleRequest(WebApplicationImpl.java:1409)
              at com.sun.jersey.spi.container.servlet.WebComponent.service(WebComponent.java:409)
              at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:540)
              at com.sun.jersey.spi.container.servlet.ServletContainer.service(ServletContainer.java:715)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:770)
              at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1496)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:330)
              at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:118)
              at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:84)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.access.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:113)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.session.SessionManagementFilter.doFilter(SessionManagementFilter.java:103)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.authentication.AnonymousAuthenticationFilter.doFilter(AnonymousAuthenticationFilter.java:113)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.servletapi.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:54)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.savedrequest.RequestCacheAwareFilter.doFilter(RequestCacheAwareFilter.java:45)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.apache.ambari.server.security.authorization.AmbariAuthorizationFilter.doFilter(AmbariAuthorizationFilter.java:182)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.authentication.www.BasicAuthenticationFilter.doFilter(BasicAuthenticationFilter.java:150)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.context.SecurityContextPersistenceFilter.doFilter(SecurityContextPersistenceFilter.java:87)
              at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:342)
              at org.springframework.security.web.FilterChainProxy.doFilterInternal(FilterChainProxy.java:192)
              at org.springframework.security.web.FilterChainProxy.doFilter(FilterChainProxy.java:160)
              at org.springframework.web.filter.DelegatingFilterProxy.invokeDelegate(DelegatingFilterProxy.java:237)
              at org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:167)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.apache.ambari.server.api.MethodOverrideFilter.doFilter(MethodOverrideFilter.java:72)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.apache.ambari.server.api.AmbariPersistFilter.doFilter(AmbariPersistFilter.java:47)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.eclipse.jetty.servlets.UserAgentFilter.doFilter(UserAgentFilter.java:82)
              at org.eclipse.jetty.servlets.GzipFilter.doFilter(GzipFilter.java:294)
              at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1467)
              at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:501)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
              at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)
              at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
              at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
              at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:429)
              at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
              at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
              at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
              at org.apache.ambari.server.controller.AmbariHandlerList.processHandlers(AmbariHandlerList.java:209)
              at org.apache.ambari.server.controller.AmbariHandlerList.processHandlers(AmbariHandlerList.java:198)
              at org.apache.ambari.server.controller.AmbariHandlerList.handle(AmbariHandlerList.java:132)
              at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
              at org.eclipse.jetty.server.Server.handle(Server.java:370)
              at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)
              at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:971)
              at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:1033)
              at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:644)
              at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
              at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
              at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696)
              at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53)
              at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
              at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
              at java.lang.Thread.run(Thread.java:745)
      Caused by: org.apache.ambari.server.ClusterNotFoundException: Cluster not found, clusterName=PIRIPIRI
              at org.apache.ambari.server.state.cluster.ClustersImpl.getCluster(ClustersImpl.java:265)
              at org.apache.ambari.server.topology.LogicalRequest.<init>(LogicalRequest.java:81)
              at org.apache.ambari.server.topology.LogicalRequestFactory.createRequest(LogicalRequestFactory.java:38)
              at org.apache.ambari.server.topology.PersistedStateImpl.getAllRequests(PersistedStateImpl.java:164)
              ... 94 more
      

      The cluster appears to function normally after the Cluster Name change, and this issue only occurs after restarting the Ambari Server.

      This issue was also reproduced using the Hortonworks HDP 2.3 Sandbox.

        Issue Links

          Activity

          mahadev Mahadev konar added a comment -

          Resolved via:

          b04fb76 Thu May 28 17:53:02 EEST 2015 Jonathan Hurley <jhurley@hortonworks.com> AMBARI-11487 - Changed Configurations During Upgrade Are Reverted During Finalize (jonathanhurley)
          Anyway, cluster name was updated successfully at DB

          zmarsh13 Zack Marsh added a comment -

          This issue is still unresolved. Verified most recently using ambari-server-2.1.1-224

          aonishuk Andrew Onischuk added a comment -

          Committed to trunk and branch-2.1

          hudson Hudson added a comment -

          SUCCESS: Integrated in Ambari-trunk-Commit #3409 (See https://builds.apache.org/job/Ambari-trunk-Commit/3409/)
          AMBARI-12538. Attempting to access the Ambari Dashboard results in an HTTP 500 Error after changing cluster name and restarting the Ambari server (aonishuk) (aonishuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=37f8c88f205b196fb02324169f5f55650af0d568)

          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ClusterResourceProviderTest.java
          • ambari-server/src/main/resources/Ambari-DDL-SQLServer-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/topology/ClusterConfigurationRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/orm/entities/TopologyRequestEntity.java
          • ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog212Test.java
          • ambari-server/src/test/java/org/apache/ambari/server/topology/AmbariContextTest.java
          • ambari-server/src/test/java/org/apache/ambari/server/topology/ClusterTopologyImplTest.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ExportBlueprintRequestTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/ClusterTopologyImpl.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/PersistedStateImpl.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyManager.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyRequestFactory.java
          • ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog212.java
          • ambari-server/src/test/java/org/apache/ambari/server/topology/TopologyManagerTest.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ScaleClusterRequestTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/HostRequest.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessorTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/AmbariContext.java
          • ambari-server/src/test/java/org/apache/ambari/server/orm/dao/TopologyLogicalRequestDAOTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ExportBlueprintRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/BaseClusterRequest.java
          • ambari-server/src/test/java/org/apache/ambari/server/orm/dao/TopologyRequestDAOTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/HostResourceProvider.java
          • ambari-server/src/main/resources/Ambari-DDL-MySQL-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClusterResourceProvider.java
          • ambari-server/src/main/resources/Ambari-DDL-Postgres-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ProvisionClusterRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/LogicalRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/orm/dao/TopologyRequestDAO.java
          • ambari-server/src/main/resources/Ambari-DDL-Postgres-EMBEDDED-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ScaleClusterRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/ClusterTopology.java
          • ambari-server/src/main/resources/Ambari-DDL-Oracle-CREATE.sql
          • ambari-server/src/main/resources/Ambari-DDL-SQLAnywhere-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyRequestFactoryImpl.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ProvisionClusterRequestTest.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in Ambari-branch-2.1 #501 (See https://builds.apache.org/job/Ambari-branch-2.1/501/)
          AMBARI-12538. Attempting to access the Ambari Dashboard results in an HTTP 500 Error after changing cluster name and restarting the Ambari server (aonishuk) (aonishuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=a922a53d368b9cadb1d13143c756fdd3271bc005)

          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyRequest.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ProvisionClusterRequestTest.java
          • ambari-server/src/main/resources/Ambari-DDL-SQLServer-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/topology/HostRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/ClusterConfigurationRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/AmbariContext.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyRequestFactoryImpl.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ClusterResourceProviderTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/ClusterTopology.java
          • ambari-server/src/main/resources/Ambari-DDL-MySQL-CREATE.sql
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/BlueprintConfigurationProcessorTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ExportBlueprintRequest.java
          • ambari-server/src/main/resources/Ambari-DDL-Postgres-CREATE.sql
          • ambari-server/src/test/java/org/apache/ambari/server/orm/dao/TopologyLogicalRequestDAOTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClusterResourceProvider.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/LogicalRequest.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ExportBlueprintRequestTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/PersistedStateImpl.java
          • ambari-server/src/test/java/org/apache/ambari/server/orm/dao/TopologyRequestDAOTest.java
          • ambari-server/src/main/resources/Ambari-DDL-Oracle-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyManager.java
          • ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog212.java
          • ambari-server/src/main/resources/Ambari-DDL-Postgres-EMBEDDED-CREATE.sql
          • ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog212Test.java
          • ambari-server/src/test/java/org/apache/ambari/server/topology/ClusterTopologyImplTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/topology/ClusterTopologyImpl.java
          • ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ScaleClusterRequestTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/orm/dao/TopologyRequestDAO.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/BaseClusterRequest.java
          • ambari-server/src/test/java/org/apache/ambari/server/topology/AmbariContextTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/orm/entities/TopologyRequestEntity.java
          • ambari-server/src/test/java/org/apache/ambari/server/topology/TopologyManagerTest.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/HostResourceProvider.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ScaleClusterRequest.java
          • ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ProvisionClusterRequest.java
          • ambari-server/src/main/resources/Ambari-DDL-SQLAnywhere-CREATE.sql
          • ambari-server/src/main/java/org/apache/ambari/server/topology/TopologyRequestFactory.java

            People

            • Assignee:
              aonishuk Andrew Onischuk
              Reporter:
              zmarsh13 Zack Marsh
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development