Uploaded image for project: 'Airavata'
  1. Airavata
  2. AIRAVATA-2246

Python 3 compatibility in Python thrift stubs

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Airavata Client
    • Labels:
      None

      Description

      The current Python thrift stubs depend on Python 2. Would be great moving forward to have a Python 3 compatible version.

      Looks like the latest unreleased version of Thrift supports generating Python 3 compatible stubs.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                marcuschristie Marcus Christie
                Reporter:
                marcuschristie Marcus Christie
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: