Uploaded image for project: 'Accumulo'
  1. Accumulo
  2. ACCUMULO-769

MapReduce API should not use Configuration to set Job state at submission time (ambiguous semantics)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.4.0, 1.4.1
    • Fix Version/s: 1.5.0
    • Component/s: client
    • Labels:
      None

      Description

      ACCUMULO-267 made this change, but I think it was the wrong way to go about it.

      From the comments on ACCUMULO-267:

      This is the wrong way to go about doing this fix. The reason why it took a JobContext is so that it could accept a "Job" object. This was modeled after the pattern Hadoop was using for FileOutputFormat, which is somewhat the standard for conventions in configuring MR jobs.

      While JobContext does specifically state that's what it's purpose is, it is a base class, and Job extends JobContext, and includes a comment that describes it as holding the state of the job at submission time. This API should really be taking a "Job" object, rather than a "JobContext" object. Further, because Job is the only JobContext that actually works as intended here, the change from JobContext to Job does not require any deprecation, because Job will still work, and any other JobContext that isn't a Job will still fail. (We would have to deprecate the ones that were added in 1.4 that took a Configuration object, though... because those were never "correct", if we are going off of the conventions set by Hadoop's provided OutputFormats).

      It is somewhat annoying to deprecate something in 1.5 that was added in 1.4... especially since it allows people to go back to what they were doing before. But, I think it might be worth it to be consistent with the established conventions, and to clarify the semantics of the methods (we are, after all, modifying the state of a job we are about to submit, and not just an arbitrary configuration, which is used for all sorts of things).

        Activity

        kturner Keith Turner added a comment -

        I am not a big fan of the churn in the API this change would make. However I do agree with the goal of this ticket. This leaves me a bit conflicted on this issue. Passing in a Job removes the possibility that the user will do something wrong. With the new API in 1.4 the user can write the following code that is incorrect.

          @Override
          public int run(String[] args) throws Exception {
        
            Configuration conf = getConf();
            Job job = new Job(conf, "Test MR 1");
              .
              .
              .
            job.setOutputFormatClass(AccumuloOutputFormat.class);
            AccumuloOutputFormat.setOutputInfo(conf, "root", "secret".getBytes(), false, "nodes");  //WRONG, modifying conf will not setup the job
          }
        

        Instead the user needs to write the following with the new API

          @Override
          public int run(String[] args) throws Exception {
        
            Configuration conf = getConf();
            Job job = new Job(conf, "Test MR 1");
              .
              .
              .
            job.setOutputFormatClass(AccumuloOutputFormat.class);
            AccumuloOutputFormat.setOutputInfo(job.getConfiguration(), "root", "secret".getBytes(), false, "nodes");  //CORRECT, modifying the job conf will setup the job
          }
        

        If the user just passed in the job object they would not have to think about it and understand that job creates a copy of the config they passed.

        billie.rinaldi Billie Rinaldi added a comment -

        I'm not thrilled about the API churn, either. There's another point of concern related to ACCUMULO-695: the "old" MapReduce API is no longer deprecated and is still considered the stable version. The old API uses Configuration in its static methods.

        billie.rinaldi Billie Rinaldi added a comment -

        I guess it is kind of weird that AccumuloFileOutputFormat has some static methods that take a Configuration and some that take a Job. Does that mean we should create separate classes for the mapred and mapreduce APIs with static methods that match those APIs?

        ctubbsii Christopher Tubbs added a comment -

        Billie Rinaldi - I agree that the API churn is frustrating, but I think if we're going to support the "new" API, we should do it in a way that is consistent and sensible for users familiar with this API, and I think this is consistent with the design intent, documentation, and examples in the "new" API. I think it makes sense to consider ACCUMULO-695 's solution separately, in the context of the "old" API, with a goal of consistency with that API's design intent, documentation, and examples.

        ctubbsii Christopher Tubbs added a comment -

        Billie Rinaldi - Yes, I think we should have separate classes for the "old" API, as users familiar with one and not the other, should not be bombarded with available API methods that aren't suitable to the framework of their choice.

        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk #576 (See https://builds.apache.org/job/Accumulo-Trunk/576/)
        ACCUMULO-467 Change the behavior of AccumuloFileOutputFormat to carry Accumulo properties in an AccumuloConfiguration object, to remove the side-effect behavior of RFileOperations permitting Hadoop configuration to override AccumuloConfiguration in all cases.
        ACCUMULO-769 The new methods that were added were done so in a way that is consistent with Hadoop's context-oriented MapReduce framework. (Revision 1421044)

        Result = FAILURE
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/file/rfile/RFileOperations.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/util/ContextFactory.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormatTest.java
        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk #577 (See https://builds.apache.org/job/Accumulo-Trunk/577/)
        ACCUMULO-467, ACCUMULO-769 Partially revert edits that cause strange compilation errors on the build server, and remove createJob() from the ContextFactory, as it isn't needed. (Revision 1421416)

        Result = SUCCESS
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/util/ContextFactory.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormatTest.java
        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk #578 (See https://builds.apache.org/job/Accumulo-Trunk/578/)
        ACCUMULO-769 Updated partitioners to reflect the only valid, mutable JobContext, which is simply Job; This change is API-compatible with current code that isn't broken, because Job is a JobContext, so no deprecation is needed (though code that uses this may need to be recompiled). (Revision 1421521)

        Result = SUCCESS
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/lib/partition/KeyRangePartitioner.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/lib/partition/RangePartitioner.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/lib/partition/RangePartitionerTest.java
        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk #639 (See https://builds.apache.org/job/Accumulo-Trunk/639/)
        ACCUMULO-769 Deprecated and replaced 1.4.x Mapreduce APIs and updated javadocs for all Mapreduce classes and updated referencing classes. (Revision 1433745)

        Result = SUCCESS
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/cli/ClientOnDefaultTable.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/cli/ClientOnRequiredTable.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/cli/ClientOpts.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloInputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloOutputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloRowInputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/InputFormatBase.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/iterators/user/VersioningIterator.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloInputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloOutputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloRowInputFormatTest.java
        • /accumulo/trunk/examples/simple/src/main/java/org/apache/accumulo/examples/simple/mapreduce/RegexExample.java
        • /accumulo/trunk/examples/simple/src/main/java/org/apache/accumulo/examples/simple/mapreduce/RowHash.java
        • /accumulo/trunk/examples/simple/src/main/java/org/apache/accumulo/examples/simple/mapreduce/TableToFile.java
        • /accumulo/trunk/examples/simple/src/main/java/org/apache/accumulo/examples/simple/mapreduce/TeraSortIngest.java
        • /accumulo/trunk/examples/simple/src/main/java/org/apache/accumulo/examples/simple/mapreduce/UniqueColumns.java
        • /accumulo/trunk/examples/simple/src/test/java/org/apache/accumulo/examples/simple/filedata/ChunkInputFormatTest.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/metanalysis/IndexMeta.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/continuous/ContinuousMoru.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/continuous/ContinuousVerify.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/randomwalk/multitable/CopyTool.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/randomwalk/sequential/MapRedVerifyTool.java
        billie.rinaldi Billie Rinaldi added a comment -

        The trunk changes broke the hadoop 2.0 build due to the use of the TaskAttemptContext constructor. However, the two methods marked as deprecated that instantiate TaskAttemptContext, initialize(InputSplit inSplit, Configuration conf) and getSplits(Configuration conf), are actually new in trunk and can be removed instead of deprecated. We should check over 1.5.0 before release and make sure nothing else is both new and deprecated.

        billie.rinaldi Billie Rinaldi added a comment -

        I think we should continue to standardize on Configuration internally (protected / private methods) while matching the MR API for public methods.

        ctubbsii Christopher Tubbs added a comment -

        Billie Rinaldi Yes, I think you're probably right. To get that benefit, while still reducing confusion for end users due to the clutter of overloaded methods, I'm thinking it best to put the methods that take Configuration in a separate Configurator utility class.

        billie.rinaldi Billie Rinaldi added a comment -

        I'd be in favor of that. Plus then if we have mapred and mapreduce InputFormats, they can share configuration code. We should clearly mark the utility class as not part of the public API, not to be used for manually configuring things.

        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk-Hadoop-2.0 #6 (See https://builds.apache.org/job/Accumulo-Trunk-Hadoop-2.0/6/)
        ACCUMULO-769 Fix Hadoop 2.0 breakage by removing methods marked as deprecated that didn't exist in prior version.
        ACCUMULO-975 Fix proxy pom.xml to support Hadoop 2.0 (Revision 1435230)

        Result = SUCCESS
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/InputFormatBase.java
        • /accumulo/trunk/proxy/pom.xml
        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk #648 (See https://builds.apache.org/job/Accumulo-Trunk/648/)
        ACCUMULO-769 Fix Hadoop 2.0 breakage by removing methods marked as deprecated that didn't exist in prior version.
        ACCUMULO-975 Fix proxy pom.xml to support Hadoop 2.0 (Revision 1435230)

        Result = SUCCESS
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/InputFormatBase.java
        • /accumulo/trunk/proxy/pom.xml
        billie.rinaldi Billie Rinaldi added a comment -

        Are we going to try to get this done for 1.5.0? Do you need any help with that?

        ctubbsii Christopher Tubbs added a comment -

        I'm finishing it up now.

        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk #653 (See https://builds.apache.org/job/Accumulo-Trunk/653/)
        ACCUMULO-769 Modify mapreduce API to use the Hadoop static configurator conventions, but done in a way that allows us to standardize and reuse configurator code to support multiple frameworks. (Revision 1437073)

        Result = SUCCESS
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/cli/ClientOnDefaultTable.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/cli/ClientOnRequiredTable.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloInputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloOutputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloRowInputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/InputFormatBase.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/ConfiguratorBase.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/FileOutputConfigurator.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/InputConfigurator.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/OutputConfigurator.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/package-info.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloInputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloOutputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloRowInputFormatTest.java
        • /accumulo/trunk/examples/simple/src/test/java/org/apache/accumulo/examples/simple/filedata/ChunkInputFormatTest.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/metanalysis/IndexMeta.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/randomwalk/multitable/CopyTool.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/randomwalk/sequential/MapRedVerifyTool.java
        hudson Hudson added a comment -

        Integrated in Accumulo-Trunk-Hadoop-2.0 #11 (See https://builds.apache.org/job/Accumulo-Trunk-Hadoop-2.0/11/)
        ACCUMULO-769 Modify mapreduce API to use the Hadoop static configurator conventions, but done in a way that allows us to standardize and reuse configurator code to support multiple frameworks. (Revision 1437073)

        Result = SUCCESS
        ctubbsii :
        Files :

        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/cli/ClientOnDefaultTable.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/cli/ClientOnRequiredTable.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloInputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloOutputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/AccumuloRowInputFormat.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/InputFormatBase.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/ConfiguratorBase.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/FileOutputConfigurator.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/InputConfigurator.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/OutputConfigurator.java
        • /accumulo/trunk/core/src/main/java/org/apache/accumulo/core/client/mapreduce/util/package-info.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloFileOutputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloInputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloOutputFormatTest.java
        • /accumulo/trunk/core/src/test/java/org/apache/accumulo/core/client/mapreduce/AccumuloRowInputFormatTest.java
        • /accumulo/trunk/examples/simple/src/test/java/org/apache/accumulo/examples/simple/filedata/ChunkInputFormatTest.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/metanalysis/IndexMeta.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/randomwalk/multitable/CopyTool.java
        • /accumulo/trunk/server/src/main/java/org/apache/accumulo/server/test/randomwalk/sequential/MapRedVerifyTool.java

          People

          • Assignee:
            ctubbsii Christopher Tubbs
            Reporter:
            ctubbsii Christopher Tubbs
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development