Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.2, 1.8.1
    • Fix Version/s: 1.7.3, 1.8.2, 2.0.0
    • Component/s: scripts
    • Labels:
      None

      Description

      Ran continuous ingest on a 4 node cluster. Tried running rfile-info on a resulting RFile.

      /opt/accumulo-1.8.1/bin/accumulo rfile-info -d hdfs://localhost:8020/accumulo/tables/2/t-00000bq/C0005ct2.rf
      Reading file: hdfs://localhost:8020/accumulo/tables/2/t-00000bq/C0005ct2.rf
      RFile Version            : 8
      
      Locality group           : <DEFAULT>
          Num   blocks           : 2,868
          Index level 0          : 92,114 bytes  1 blocks
          First key              : 1666667494e6a12f 3156:10ea [] 1488561068054 false
          Last key               : 1777776d22e8074a 711e:4443 [] 1488560945783 false
          Num entries            : 2,672,521
          Column families        : <UNKNOWN>
      
      Meta block     : BCFile.index
            Raw size             : 4 bytes
            Compressed size      : 12 bytes
            Compression type     : gz
      
      Meta block     : RFile.index
            Raw size             : 92,190 bytes
            Compressed size      : 44,822 bytes
            Compression type     : gz
      
      2017-03-03 11:43:10,451 [start.Main] ERROR: Thread 'rfile-info' died.
      java.lang.NullPointerException
          at org.apache.accumulo.core.file.rfile.RFile$Reader.getLocalityGroupCF(RFile.java:1300)
          at org.apache.accumulo.core.file.rfile.PrintInfo.execute(PrintInfo.java:165)
          at org.apache.accumulo.start.Main$1.run(Main.java:120)
          at java.lang.Thread.run(Thread.java:745)
      
      

        Issue Links

          Activity

          kturner Keith Turner added a comment -

          Dave Marion do you know if this happened with other files?

          dlmarion Dave Marion added a comment -

          We restarted CI yesterday. I checked an A and C type files, both exhibit the same symptoms when `-d` is specified. Without `-d`, it works without error.

          kturner Keith Turner added a comment -

          I tracked down the cause of this. When an RFile has more than 1000 column families in the default locality group, it stops tracking it. Code added in ACCUMULO-3420 does not handle this case properly. This code is activated when trying to dump a rfile. Continuous ingest creates more than 1000 families.

          etcoleman Ed Coleman added a comment -

          Because of 1.7.3-rc1 failing the vote due to ACCUMULO-4600, moving the fix version from 1.7.4 to 1.7.3 so that it can be included in 1.7.3-rc2


            People

            • Assignee:
              kturner Keith Turner
              Reporter:
              dlmarion Dave Marion
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 2h
                2h

                  Development