Uploaded image for project: 'Accumulo'
  1. Accumulo
  2. ACCUMULO-4383

Configure animal-sniffer-maven-plugin to fail when new unsupported JDK APIs are used

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.6, 1.7.3, 1.8.0
    • Component/s: build
    • Labels:
      None

      Description

      Benson gave us a great little pointer to http://www.mojohaus.org/animal-sniffer/animal-sniffer-maven-plugin/

      We should configure this plugin to run during our build to catch when we accidentally use JDK APIs which only exist in a newer version of Java than what we target for a specific release line.

      For example, mid-2016, we have problems with JDK8 APIs slipping into release lines which still need to support JDK7. We had a similar problem when switching from JDK6 to JDK7.

        Attachments

          Activity

            People

            • Assignee:
              ctubbsii Christopher Tubbs
              Reporter:
              elserj Josh Elser
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 1h 20m
                1h 20m