Uploaded image for project: 'Accumulo'
  1. Accumulo
  2. ACCUMULO-4379

Clarify the difference between Hadoop and Accumulo native libs in bootstrap_config.sh script

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.6.6, 1.7.3, 1.8.0
    • Component/s: scripts
    • Labels:
      None

      Description

      Lindsey Kruper on serverfault expressed some confusion in bootstrap_config.sh's warning messages in http://serverfault.com/questions/790154/what-should-hadoop-prefix-be-for-accumulo-installation/790255

      Rightfully so, the script's warnings don't differentiate between what is a Hadoop setup issue and what is Accumulo setup.

      We can easily improve this with better error messages.

        Activity

        lindsey Lindsey Kuper added a comment - - edited

        Josh Elser – thanks for filing this.

        To be specific about the issue: I have libaccumulo.so built but not libhadoop.so, so when running bootstrap_config.sh, it's confusing to see "Native libraries could not be found for your sytem in: $HADOOP_PREFIX" followed immediately by "Please remember to compile the native libraries using the bin/build_native_library.sh script".

        The issue is that "native libraries" refers to libhadoop.so in the first case but in the second case it refers to libaccumulo.so. A small wording tweak is probably all that is needed here.

        elserj Josh Elser added a comment -

        Sure thing! Thanks for letting us know in the first place.

        dlmarion Dave Marion added a comment -

        Made messages a little more clear.

        lindsey Lindsey Kuper added a comment -

        Thanks!


          People

          • Assignee:
            dlmarion Dave Marion
            Reporter:
            lindsey Lindsey Kuper
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0h
              0h
              Logged:
              Time Spent - 40m
              40m

                Development