Accumulo
  1. Accumulo
  2. ACCUMULO-2459

accumulo-init RPM conflicts with accumulo-core RPM on /etc/accumulo

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      accumulo-core should provide:

      config(accumulo) = ${project.version}
      /etc/accumulo
      

      accumulo-init should provide:

      config(accumulo-tserver) = ${project.version}
      config(accumulo-master) = ${project.version}
      config(accumulo-gc) = ${project.version}
      config(accumulo-monitor) = ${project.version}
      /etc/accumulo/accumulo-site.xml (etc.)
      

      The symlink in accumulo-core to /etc/accumulo should be removed.

        Issue Links

          Activity

          Al Krinker added a comment -

          Can someone provide me with mode details about this issue? I did not see any conflicts when I tried latest built and I did not see the symlink in accumulo-core. I wonder if it was already resolved. Thank you

          Christopher Tubbs added a comment -

          It looks like you're right, there is no conflict.

          Both the init rpm and the core rpm do stuff with /etc/accumulo. I had thought that they both placed the same files, but it looks like they place different files.

          There's still improvements on declarations we could probably make, but it's not a bug. Thanks for verifying!


            People

            • Assignee:
              Al Krinker
              Reporter:
              Christopher Tubbs
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development