Bug 55739 - Remote Test : Total threads in GUI mode shows invalid total number of threads
Remote Test : Total threads in GUI mode shows invalid total number of threads
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.10
All All
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks: 55510
  Show dependency tree
 
Reported: 2013-11-04 03:04 UTC by harry_no_spot
Modified: 2013-11-04 19:58 UTC (History)
1 user (show)



Attachments
running threads status portion shows '20/0' (62.17 KB, image/png)
2013-11-04 03:04 UTC, harry_no_spot
Details
total threads number info is not refreshed correctly (62.31 KB, image/png)
2013-11-04 08:31 UTC, harry_no_spot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description harry_no_spot 2013-11-04 03:04:06 UTC
Created attachment 31005 [details]
running threads status portion shows '20/0'

1. set up a slave machine
2. prepare any test plan, or prepare the test plan as pic I uploaded
3. 'Run' -> 'Remote Start' -> 'your slave machine's IP'
4. see upper-right, the running threads status portion, which shows '20/0', which is not right. should be '20/20'
5. Run with localhost, status turns right. then change 'Number of Threads', do Remote Start, status turns wrong.
Comment 1 harry_no_spot 2013-11-04 08:29:36 UTC
details about step 5.
5. Run with localhost, status turns right. then change 'Number of Threads', do Remote Start, status turns wrong.

5.1 change 'Number of Threads' to 20, Run with localhost, status is right: 20/20
5.2 stop it. change 'Number of Threads' to 30, Run with remote machine, 'Run' -> 'Remote Start' -> 'your slave machine's IP'. status is wrong: 30/20. that's, the total threads info is not refreshed correctly.
Comment 2 harry_no_spot 2013-11-04 08:31:33 UTC
Created attachment 31006 [details]
total threads number info is not refreshed correctly
Comment 3 Philippe Mouawad 2013-11-04 19:56:59 UTC
Date: Mon Nov  4 19:55:51 2013
New Revision: 1538742

URL: http://svn.apache.org/r1538742
Log:
Bug 55739 - Remote Test : Total threads in GUI mode shows invalid total number of threads
Bugzilla Id: 55739

Modified:
    jmeter/trunk/src/core/org/apache/jmeter/engine/ClientJMeterEngine.java
    jmeter/trunk/xdocs/changes.xml
Comment 4 Philippe Mouawad 2013-11-04 19:58:27 UTC
What is fixed is the wrong number of threads , but bug 55510 is still not fixed