Bug 54187 - Request tab does not show headers if request fails
Request tab does not show headers if request fails
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
unspecified
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 54321 (view as bug list)
Depends on:
Blocks: 54321
  Show dependency tree
 
Reported: 2012-11-21 23:39 UTC by Sebb
Modified: 2012-12-20 20:38 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2012-11-21 23:39:34 UTC
If a request fails, the request headers are not shown.

This is because the headers are currently retrieved after the request is executed so as to ensure that they are up-to-date; this code is not executed if an exception is thrown.
Comment 1 Sebb 2012-11-21 23:46:36 UTC
URL: http://svn.apache.org/viewvc?rev=1412363&view=rev
Log:
Request tab does not show headers if request fails
Bugzilla Id: 54187

Modified:
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC3Impl.java
    jmeter/trunk/src/protocol/http/org/apache/jmeter/protocol/http/sampler/HTTPHC4Impl.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2012-12-20 20:38:08 UTC
*** Bug 54321 has been marked as a duplicate of this bug. ***