Bug 52741 - TestBeanGUI default values do not work at second time or later
TestBeanGUI default values do not work at second time or later
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
unspecified
PC All
: P2 minor (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2012-02-23 07:44 UTC by Tetsuya Takatsuru
Modified: 2012-02-25 16:28 UTC (History)
1 user (show)



Attachments
patch (728 bytes, patch)
2012-02-23 07:44 UTC, Tetsuya Takatsuru
Details | Diff
first time (OK) (52.44 KB, image/png)
2012-02-23 07:45 UTC, Tetsuya Takatsuru
Details
second time (NG) (52.30 KB, image/png)
2012-02-23 07:46 UTC, Tetsuya Takatsuru
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tetsuya Takatsuru 2012-02-23 07:44:52 UTC
Created attachment 28367 [details]
patch

On creating test elements using TestBeanGUI by JMeter GUI, the default values in the elements does not work correctly.

At the first time, default values are set correctly.
At the second time, all default values are ignored.

This is caused by initialization bug of TestBeanGUI.
I attach a patch fixing this bug.
Comment 1 Tetsuya Takatsuru 2012-02-23 07:45:38 UTC
Created attachment 28368 [details]
first time (OK)
Comment 2 Tetsuya Takatsuru 2012-02-23 07:46:09 UTC
Created attachment 28369 [details]
second time (NG)
Comment 3 Philippe Mouawad 2012-02-25 16:28:46 UTC
Date: Sat Feb 25 16:28:06 2012
New Revision: 1293637

URL: http://svn.apache.org/viewvc?rev=1293637&view=rev
Log:
Bug 52741 - TestBeanGUI default values do not work at second time or later

Modified:
   jmeter/trunk/src/core/org/apache/jmeter/testbeans/gui/TestBeanGUI.java
   jmeter/trunk/xdocs/changes.xml