Bug 41842 - [PATCH] Doesn't work with FCKeditor 2.4
[PATCH] Doesn't work with FCKeditor 2.4
Status: RESOLVED FIXED
Product: Lenya
Classification: Unclassified
Component: Miscellaneous
Trunk
Other other
: P2 normal
: 1.4
Assigned To: Lenya Developers
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-03-14 09:18 UTC by Richard Frovarp
Modified: 2007-03-20 08:54 UTC (History)
0 users



Attachments
Makes Lenya work with FCKeditor 2.4 and only FCKeditor 2.4 (3.74 KB, patch)
2007-03-16 06:56 UTC, Richard Frovarp
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Frovarp 2007-03-14 09:18:44 UTC
The FCKeditor module doesn't work with FCKeditor 2.4, which is the latest.
Comment 1 Richard Frovarp 2007-03-16 06:56:06 UTC
Created attachment 19722 [details]
Makes Lenya work with FCKeditor 2.4 and only FCKeditor 2.4

The patch contains what is required to get FCKeditor 2.4 to work with Lenya.
Instructions in the module say to download the latest, which is 2.4. In 2.4
they changed their javascript directory from FCKeditor to fckeditor. The
UniversalKey option in the config throws a visible popup error. 2.4 disables
the Firefox spell checker by adding to the body element of the edited content
the attribute spellcheck="false", which fails validation. This patch changes
path references to fckeditor, removes UniversalKey from the config, changes
clean-xhtml.xsl to remove the spellcheck="false" attribute so that it will pass
validation on that point, and the instructions have been updated. Note due to
path changes, this patch will break existing FCKeditor 2.3 installs.
Comment 2 Richard Frovarp 2007-03-16 06:56:41 UTC
Note, this patch will break existing FCKeditor 2.3 installs due to path case
changes.
Comment 3 Andreas Hartmann 2007-03-19 03:21:36 UTC
The patch doesn't apply anymore (fckloader.js). Would you mind submitting it
again? TIA!
Comment 4 Richard Frovarp 2007-03-19 11:27:00 UTC
This patches against a clean checkout for me.
Comment 5 Andreas Hartmann 2007-03-20 08:54:18 UTC
I applied the patch. Thanks a lot!