Bug 41740 - Environment tags not being picked-up in DefaultContext
Environment tags not being picked-up in DefaultContext
Status: RESOLVED DUPLICATE of bug 40633
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
5.5.20
All other
: P2 regression (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-03-01 08:26 UTC by Ben Dilley
Modified: 2007-03-07 08:55 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Dilley 2007-03-01 08:26:37 UTC
I'm running tomcat 5.5.20 and I'm unable to retrieve Environment variables that
are defined in the DefaultContext. I know this isn't working because if I alter
the DefaultContext tag to a Context one and run the same webapp, the Environment
variables are retrieved successfully by the app.

This is a problem because multiple auto-deployed apps need to share the same
Environment variables. The only available workaround is to repeat the
Environment tags within explicit Context tags for each known webapp deployed in
the Host's appBase.

This has been tested in Linux using jdk 1.6 and in Windows using jdk 1.5.
Comment 1 william.barker 2007-03-01 10:18:51 UTC
There is no DefaultContext tag in TC 5.5+
Comment 2 Ben Dilley 2007-03-01 22:33:29 UTC
Please could the tomcat 5.5 documentation be updated to reflect this? because I
do not know what to use as an alternative. I noticed the DefaultContext page was
taken offline, but all the remaining documentation still refers to it.

In the meantime, could I have a hint as to how to replace the DefaultContext?

Thank you v much!! :)
Comment 3 Mark Thomas 2007-03-02 04:18:31 UTC
Hint: $CATALINA_BASE/conf/context.xml

*** This bug has been marked as a duplicate of 40633 ***
Comment 4 Ben Dilley 2007-03-07 08:55:53 UTC
How do you define default contexts for auto-deployed apps in multiple vhosts,
where each vhost requires different defaults?