Bug 11699 - zip Task does not seem to pick up some a file
zip Task does not seem to pick up some a file
Status: RESOLVED DUPLICATE of bug 10755
Product: Ant
Classification: Unclassified
Component: Core tasks
1.5
PC All
: P3 normal (vote)
: ---
Assigned To: Ant Notifications List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-08-14 17:19 UTC by Dave R Brooks
Modified: 2008-02-22 12:18 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave R Brooks 2002-08-14 17:19:30 UTC
I am having a problem with the zip task in V1.5. I is not picking up a file tha 
t is clearly in the include fileset. The script is not a new one, an we have 
never had a problem with V1.4.1 and before. Here are some details...

target=========================================================================
  <target name="zip-database" if="database.available" depends="zip-program" >
    <echo message="zipping ${DRBDevTools.products.dir}/${data.dir}/
${database.file} to ${release.dir}/${release.name}"/>
    <zip zipfile="${release.dir}/${release.name}" update="true">
      <fileset dir="${DRBDevTools.products.dir}" includes="${data.dir}/
${database.file}"/>
    </zip>
  </target>
target=========================================================================

debug: 1.4.1===================================================================
Setting project property: data.dir -> data
Setting project property: DRBDevTools.products.dir -> e:\DRBDevTools/myProducts
Setting project property: release.name -> drbdatabase.zip
Setting project property: release.dir -> e:\DRBDevTools/myProducts/java/release
Setting project property: database.file -> sample.mdb

Setting project property: database.available -> true

zip-database:
     [echo] zipping e:\DRBDevTools/myProducts/data/sample.mdb to e:\DRBDevTools/
myProducts/java/release/drbdatabase.zip
FileSet: Setup file scanner in dir E:\DRBDevTools\myProducts with patternSet{ in
cludes: [data/sample.mdb] excludes: [] }
      [zip] Updating zip: E:\DRBDevTools\myProducts\java\release\drbdatabase.zip

FileSet: Setup file scanner in dir E:\DRBDevTools\myProducts with patternSet{ in
cludes: [data/sample.mdb] excludes: [] }
FileSet: Setup file scanner in dir E:\DRBDevTools\myproducts\java\code\org\drb\d
atabase with patternSet{ includes: [] excludes: [data/sample.mdb] }
debug: 1.4.1===================================================================

debug: 1.5=====================================================================
Setting project property: data.dir -> data
Setting project property: DRBDevTools.products.dir -> e:\DRBDevTools/myProducts
Setting project property: release.name -> drbdatabase.zip
Setting project property: release.dir -> e:\DRBDevTools/myProducts/java/release
Setting project property: database.file -> sample.mdb

Setting project property: database.available -> true
zip-database:
     [echo] zipping e:\DRBDevTools/myProducts/data/sample.mdb to e:\DRBDevTools/
myProducts/java/release/drbdatabase.zip
fileset: Setup scanner in dir E:\DRBDevTools\myProducts with patternSet{ include
s: [data/sample.mdb] excludes: [] }
      [zip] data\sample.mdb omitted as E:\DRBDevTools\myProducts\java\release\dr
bdatabase.zip is up to date.
debug: 1.5=====================================================================

Notes: 
- The zip file is created by a previous task. I tried this test on an existing 
zip file and no zip file with the same results. 
- I tried update="true" & update="false" with not diff.
- I switch versions of ant by renaming the base directory of the version I want
ex. e:\ant -> e:\ant-1.4.1 and e:\ant-1.5 -> e:\ant and visa/versa

Any help would be appreciated. It is a production script, but we don't have to 
upgrade to 1.5 anytime soon. I was just trying to stay in up-to-date.

Thanks
Dave
Comment 1 Stefan Bodewig 2002-09-03 16:00:31 UTC

*** This bug has been marked as a duplicate of 10755 ***