Issue 99972 - Quichua or Quechua
Quichua or Quechua
Status: CLOSED FIXED
Product: Internationalization
Classification: Code
Component: i18npool
OOo 3.0.1
All All
: P3 trivial (vote)
: ---
Assigned To: stefan.baltzer
issues@l10n
:
: 99603 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 14:54 UTC by gigahz
Modified: 2013-08-07 15:02 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description gigahz 2009-03-06 14:54:39 UTC
I open this issue on the I10n component in addition to lingucomponent
(http://www.openoffice.org/issues/show_bug.cgi?id=99603), because I see a
similar issue has been successfully resolved for Quechua
(http://www.openoffice.org/issues/show_bug.cgi?id=80114).

Please add to the language list selection box "Kichwa (Ecuador)" represented by
the code qu_EC

An OOOv3 (.oxt) dictionary has been written
(http://extensions.services.openoffice.org/project/KichwaSpellchecker) and is
under improvement. 
However, it's hijacking the "Norwegian (Bokmal)" language code until Kichwa can
be selected in the language list selection box.

Sorry to half-double-post this; I couldn't figure out how to reassign issue
#99603 to I10n like the resolved issue #80114.
Comment 1 ooo 2009-03-06 15:46:04 UTC
*** Issue 99603 has been marked as a duplicate of this issue. ***
Comment 2 ooo 2009-03-06 16:06:22 UTC
'qu' is a macrolanguage code, see
http://www.sil.org/iso639-3/documentation.asp?id=que
Which of the various individual Quichua languages in Ecuador would that be and
is your dictionary intended for? See
http://www.ethnologue.com/show_country.asp?name=EC
Quichua, Chimborazo Highland [qug], with 1,000,000 speakers being the most
widely used?
Comment 3 gigahz 2009-03-06 18:10:00 UTC
Hi the Kichwa academy is located in Ambato, province of Chimborazo. 
http://www.dineib.edu.ec/kamak.htm

However, Shukllachishka Kichwa (unified Kichwa) is a new ortography for all the
Quichua dialects in Ecuador. There are plans for making Kichwa an official
language, and a unified orthography is needed.

So I wrote to SIL.org to open a new language identifier for the Unified Kichwa,
but the answer was no: http://www.loc.gov/standards/iso639-2/criteria2.html says
quite clearly that new orthographies are not given new codes. 

In total, since 
1) it seemed incorrect to assign the unified Kichwa to only one of the dialects and
2) Kichwa is [probably] becoming an official language for Ecuador,

I assumed qu_EC would be the most accurate description. qu for "a Quechua
dialect", EC for Ecuador.

If we have to choose one specific dialect, I assume "qxl" would be closest due
to the fact that it is the dialect spoken around Ambato, where the Kichwa
academy is located. However, as stated above, the unified Kichwa is not pure
Salasaca Quichua, but a unification.

http://es.wikipedia.org/wiki/Ambato compared to
http://www.ethnologue.com/show_country.asp?name=EC and
http://www.sil.org/iso639-3/documentation.asp?id=que
Comment 4 gigahz 2009-03-06 21:19:14 UTC
OH sorry

Ambato is located in the Tunguragua province, not Chimborazo...
Comment 5 gigahz 2009-03-13 17:01:15 UTC
Do you need any further information?
Comment 6 gigahz 2009-03-17 22:24:23 UTC
any further info needed?
Comment 7 ooo 2009-03-18 10:20:19 UTC
No, no further information, please, what's available is already confusing enough ;-)

I'm undecided. MS assigned LCID 0x086B for Quechua Ecuador, but in
http://www.microsoft.com/resources/msdn/goglobal/default.mspx they map 'quz' to
all 3, Bolivia, Ecuador and Peru, which I consider wrong anyway.

Maybe using qu-EC would be best in our situation. So yes, let's go for qu-EC.
Comment 8 gigahz 2009-03-19 03:45:54 UTC
ok sorry for the confusion...

I think you're right about micro/soft being wrotg there - quz is the code for
"Cusco Quichua", and it is even a different quechua branch from the one in use
in Ecuador (Compare "Northern" and "Southern" explicatory texts on):
http://en.wikipedia.org/wiki/Quechua_II


I'll notify the Kichwa academy the good news :)
Comment 9 erack 2009-03-23 22:09:36 UTC
Reassigning to spare time account.
Comment 10 erack 2009-06-21 22:27:33 UTC
In cws locales32:

revision 273188
i18npool/source/isolang/isolang.cxx
svtools/source/misc/langtab.src
Comment 11 ooo 2009-09-04 18:22:08 UTC
Reassigning to QA for verification.
Comment 12 stefan.baltzer 2009-09-11 15:53:39 UTC
Verified in CWS locales32.

In language list box, there are 3 entries for Quechua:
 - Quechua (Bolivia, North)
 - Quechua (Bolivia, South)
 - Quechua (Ecuador)

Adjusted summary to reflect the findings (removed "Kichwa")

Comment 13 gigahz 2009-09-11 22:43:50 UTC
Yup I think Quechua is best.

I see that 
http://watchtower.org/languages.htm
list Kichwa with the english name _Quichua_.

While
http://en.wikipedia.org/wiki/Quechua#Language.2FDialect_Groupings
says the english name is _Quechua_.

I don't know which is correct, but to me all the Quechuan languages are so
similar that it would be less confusing leaving it as commited:

Quechua (Ecuador)
Comment 14 stefan.baltzer 2009-09-29 09:53:04 UTC
OK in DEV300_m60. Closed.