Issue 99876 - Graphics are mixed up when printing more pages on one page
Graphics are mixed up when printing more pages on one page
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: printing
OOO310m3
All All
: P3 trivial (vote)
: ---
Assigned To: h.ilter
issues@sw
: regression
Depends on:
Blocks: 95768
  Show dependency treegraph
 
Reported: 2009-03-04 16:00 UTC by h.ilter
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Good result (573.05 KB, application/postscript)
2009-03-04 16:04 UTC, h.ilter
no flags Details
Bad result (427.14 KB, application/postscript)
2009-03-04 16:05 UTC, h.ilter
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description h.ilter 2009-03-04 16:00:35 UTC
- Open the brochure sample document
- Go to PagePreview and set printing all foour pages to one page
- Print
-> Graphic is mixed up
See attachments

Was ok in OOo3.0, Therefore regression.
Comment 1 h.ilter 2009-03-04 16:04:36 UTC
Created attachment 60702 [details]
Good result
Comment 2 h.ilter 2009-03-04 16:05:31 UTC
Created attachment 60703 [details]
Bad result
Comment 3 Oliver-Rainer Wittmann 2009-03-05 08:43:52 UTC
Investigation reveals that the defect has been introduced in DEV300m30 -
DEV300m29 works fine.

Fix in progress.
Comment 4 Oliver-Rainer Wittmann 2009-03-05 09:10:26 UTC
Defect cause: 
All graphics are painted on the output on all pages. This happens also on a
"normal" print, but it is not visible.

Thus issue 98402 comes into my mind.
I am checking, if this issue has the same root cause.
Comment 5 Oliver-Rainer Wittmann 2009-03-05 09:37:36 UTC
Yes, this issue has the same root cause as issue 98402

Thus, proposed solution is the apply fix of issue 98402 also on printing.
Comment 6 Oliver-Rainer Wittmann 2009-03-05 09:56:54 UTC
Applying fix for issue 98402 also for printing solves this issue, too.

Corresponding code change will follow soon.
Comment 7 Oliver-Rainer Wittmann 2009-03-05 11:08:26 UTC
fixed in cws hb20 - changed file:
/svx/source/sdr/contact/objectcontactofpageview.cxx, rev. 268894
Comment 8 Oliver-Rainer Wittmann 2009-03-06 08:26:44 UTC
OD->HI: Checked in internal installation set of cws hb20 - please verify.

VERY IMPORTANT NOTE: Please check also printing in the other applications
Comment 9 h.ilter 2009-03-09 15:44:47 UTC
Verified with cws hb20 = ok
Comment 10 gatis 2009-04-02 22:05:17 UTC
Verified in MasterVersion 3.1. Fixed.
Comment 11 h.ilter 2009-04-03 08:40:13 UTC
closed