Issue 99118 - automatic type recognition doesn't work when pasting from Calc
automatic type recognition doesn't work when pasting from Calc
Status: VERIFIED FIXED
Product: Base
Classification: Application
Component: ReportBuilder
OOo 3.0.1
All All
: P3 trivial (vote)
: OOo 3.2
Assigned To: marc.neumann
issues@dba
:
Depends on:
Blocks: 20748
  Show dependency treegraph
 
Reported: 2009-02-11 12:55 UTC by Frank Schönheit
Modified: 2009-06-03 20:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (7.33 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-02-11 12:56 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2009-02-11 12:55:40 UTC
- open the attached spreadsheet document
- mark the range A1:B6
- Edit / Copy
- open a database document of your choice
- select "Tables" on the left hand side
- Edit / Paste
=> the "Copy table" wizard opens
- on the first page, press "Next"
- on the second page, move all fields to the right hand side list box, and
  press "Next"
- on the third page, press the "Auto" button

This is expected to automatically determine the fields types for all columns.
However, both the "Date" and the "Value" column still have the
"Text [ VARCHAR ]" type. Given that in the source document, "Date" is explicitly
formatted as date, and also contains only date values, where "Value" is
formatted as Number, and contains only numbers, I would say this is not the
expected result.
Comment 1 Frank Schönheit 2009-02-11 12:56:19 UTC
Created attachment 60090 [details]
document to reproduce the bug case
Comment 2 ocke.janssen 2009-03-12 12:55:56 UTC
Fixed in cws dba32b
Comment 3 Frank Schönheit 2009-05-09 20:55:30 UTC
fs->msc: please verify in CWS dba32b
Comment 4 Frank Schönheit 2009-06-03 13:04:30 UTC
going to submit a follow-up issue because copying the date values does not
succeed. As far as the very original bug is concerned, it's fixed - "Auto" does
what it's expected to do.
Comment 5 Frank Schönheit 2009-06-03 20:44:36 UTC
submitted issue 102479 for the failure to copy the "Date" column data.