Issue 96395 - Toolbars will always grabs focus when appearing (on icewm)
Toolbars will always grabs focus when appearing (on icewm)
Status: CLOSED DUPLICATE of issue 113856
Product: Writer
Classification: Application
Component: editing
OOO300m9
PC Linux
: P3 trivial (vote)
: ---
Assigned To: philipp.lohmann
issues@sw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 16:30 UTC by tzp
Modified: 2013-08-07 14:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tzp 2008-11-20 16:30:09 UTC
Debian Linux, icewm:

With OpenOffice 3 a new annoying behaviour appeared:

When editing a document, if the cursor is moved to the beginning of a heading
line, the Bullets and numbering little window pops up, taking away the keyboard
focus from the main doc. window. This is very annoying because one must click to
the main window with the mouse to be able to continue editing.

Writer should prevent this by explicitly setting the keyboard focus to the main
window after popping up the little window.
Comment 1 michael.ruess 2008-11-21 11:17:06 UTC
MRU->PL: under icewm all Toolbars will grab focus when they appear. Two samples
are, if you start a numbered list or insert a table in OOo Writer. Also when
traveling with the cursor in such paragraphs, the toolbar will get the focus.
Comment 2 philipp.lohmann 2008-11-21 11:36:18 UTC
This certainly sucks, but OOo tells the WM explicitly that it doesn't want the
focus set to the toolbar unless it sets it there itself. But what's one more WM
to fight against ... I'll see if we can add just another WM workaround.
Comment 3 tzp 2009-01-12 16:17:03 UTC
What about making the automatic popup feature optional ? (I.e. settable in some
GUI related Options tab)
That way we could be back to the good old 2.4 behaviour.
Comment 4 michael.ruess 2009-03-12 14:37:17 UTC
*** Issue 100149 has been marked as a duplicate of this issue. ***
Comment 5 artur 2009-03-12 15:46:40 UTC
Hi
Although the problem persists, I just found a workaround for it:

Drag the toolbar to the OOo application window, to dock it.
The text will not loose focus again, as the dialog will remain docked.
Comment 6 tzp 2009-03-12 15:57:34 UTC
Thanks for the hint, this really works.
Comment 7 michael.ruess 2009-09-23 11:25:32 UTC
*** Issue 105290 has been marked as a duplicate of this issue. ***
Comment 8 philipp.lohmann 2010-11-11 17:00:53 UTC
this is fixed with issue 113856

*** This issue has been marked as a duplicate of 113856 ***
Comment 9 philipp.lohmann 2010-11-11 17:01:36 UTC
unless icewm is not EWMH compliant

closing