Issue 95768 - track 3.1 release blocker
track 3.1 release blocker
Status: CLOSED FIXED
Product: Build Tools
Classification: Code
Component: code
current
All All
: P3 trivial (vote)
: OOo 3.1
Assigned To: Martin Hollmichel
issues@tools
:
: 97095 (view as issue list)
Depends on: 90062 92532 93939 94763 97032 97159 97987 98168 98206 98240 98358 98387 98391 98418 98467 98525 98553 98740 98786 98791 98861 98983 98990 99024 99068 99123 99167 99227 99249 99293 99299 99360 99364 99384 99417 99451 99466 99564 99567 99576 99618 99662 99680 99686 99710 99717 99762 99768 99789 99822 99844 99855 99876 99899 99918 99919 99922 99924 99967 100012 100014 100035 100036 100040 100042 100043 100044 100062 100063 100070 100102 100110 100116 100131 100132 100135 100172 100177 100219 100227 100235 100258 100277 100300 100346 100349 100373 100406 100416 100424 100449 100470 100489 100500 100505 100522 100537 100538 100541 100617 100618 100676 100681 100707 100732 100789 100819 100823 100836 100861 100866 100928 100956 100993 101016 101029 101092 101097 101116 101118 101169 101210
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-02 16:34 UTC by Martin Hollmichel
Modified: 2009-06-01 17:21 UTC (History)
20 users (show)

See Also:
Issue Type: TASK
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Martin Hollmichel 2008-11-02 16:34:18 UTC
track 3.1 release stopper
Comment 1 Martin Hollmichel 2008-11-02 16:37:06 UTC
set target.
Comment 2 bmarcelly 2008-11-05 10:10:12 UTC
Please consider Issue 95429 for 3.1

Context : Issue 95381 describes an incompatibility created by ODF 1.2 with ADDRESS 
function. Such a document stored in ODF 1.2 is incorrectly read by OOo 1.1.5 to 2.4. 
And this incompatibility will not be corrected.

Issue 95429 proposes enhancements to avoid unwanted change of ODF storage format. 
Such enhancement is necessary to keep some compatibility among various OOO versions 
and storage versions.
Comment 3 tommy27 2008-11-06 15:24:37 UTC
please consider Issue 87672
http://www.openoffice.org/issues/show_bug.cgi?id=87672
autocorrect limit. acor.dat with entry 65535: Loop and/or loss of acor data
Comment 4 davidclayton 2008-11-07 15:23:04 UTC
Added myself to CC. Please see Issue 95957, if I have missed the cut off date
for 3.0.1. David
Comment 5 merschmann 2008-11-18 15:11:01 UTC
This is the Meta issue to track the potential stoppers for the release of OOo 3.1.

If anyone would like to raise an issue for the release, please add the issue id
of the issue you want to raise as dependent issue to the Meta Issue and drop a
note on releases@openoffice.org, that and why you want to declare that issue as
a stopper for releases. 

N.B.: The issue must have been confirmed. 

Discussion on releases@openoffice.org only.
Comment 6 bazooka 2008-12-06 14:10:46 UTC
Please consider these issues for 3.1

Chart
28670	Implement explicit resize of legend	
42946	Error Bars for X values	
75453	Make it possible to copy diagrams to other applications

Spreadsheet
73319	Y axis error bars line is lost when reopen the Excel file
Comment 7 tommy27 2008-12-18 09:22:37 UTC
please consider 
http://www.openoffice.org/issues/show_bug.cgi?id=97081

Impress: color tool changes on image are lost when saving as .ppt
Comment 8 rene 2009-01-06 14:58:51 UTC
add 90062, was a blocker for 3.0.0, not yet in DEV300 tree. Thus is a blocker
here, too
Comment 9 uwe.luebbers 2009-01-14 15:36:27 UTC
removed 80917, because it missed feature freeze.
Comment 10 michael.ruess 2009-01-14 15:55:04 UTC
Due to limited resources, I remove issue 97591.
Comment 11 uwe.luebbers 2009-01-14 16:54:59 UTC
removed 96276, because "closed, works for me"
Comment 12 rene 2009-01-19 14:26:17 UTC
add 98168
Comment 13 norbert2 2009-01-19 15:56:46 UTC
Please consider to fix  Issue 83102 for OOo 3.1. It is about the bad
(unfiltered) display of scaled bitmaps. In my opinion this bug should be fixed
together with antialiasing. So OOo 3.1 would be a suitable release to fix also
this nasty display bug.
Comment 14 ingo.schmidt-rosbiegal 2009-01-22 14:34:56 UTC
i92147 removed, cannot be fixed in OOo 3.1 time frame.
Comment 15 rene 2009-01-23 10:00:17 UTC
10:58 < _Nesshof_> issue 98387 is P1 release blocker for 3.1 release
Comment 16 kpalagin 2009-01-28 14:14:35 UTC
98570 turned out to be dup of fixed 98318. removing 98570.
Comment 17 bmarcelly 2009-02-03 07:19:37 UTC
Please consider Issue 98467
Tools > Customize > Events cannot remove an action (a macro) assigned to an event. 
Comment 18 Olaf Felka 2009-02-03 12:53:09 UTC
I've added issue 98740
Comment 19 uwe.luebbers 2009-02-03 13:16:29 UTC
attached 98740
Comment 20 uwe.luebbers 2009-02-03 13:19:38 UTC
attached 98791
Comment 21 uwe.luebbers 2009-02-04 10:06:09 UTC
attached 98861
Comment 22 Frank Schönheit 2009-02-04 10:36:33 UTC
Uhm - what's the difference between this issue here and issue 97095?
Comment 23 merschmann 2009-02-04 10:51:56 UTC
*** Issue 97095 has been marked as a duplicate of this issue. ***
Comment 24 uwe.luebbers 2009-02-04 14:49:13 UTC
removed 96733, because target 3.2 "closed invalid"
Comment 25 Rainer Bielefeld 2009-02-05 06:54:04 UTC
Transfer regression issue 98358 from DUP Issue 97095

alternating "issue blocker" and "issue stopper" has been used for these tasks. I
prefer "blocker" because something blocked can not start, but you can only stop
something that has already started ;-)
Comment 26 michael.ruess 2009-02-05 07:44:27 UTC
Adding issue 98786.
Comment 27 uwe.luebbers 2009-02-06 14:18:45 UTC
added 97987,98206,98553,98240,92356
Comment 28 hennerdrewes 2009-02-07 09:29:23 UTC
Please add issue 98569. There are many other reports coming in almost daily
(issue 98983, issue 98903): People simply cannot save or export properly under
Vista.

Comment 29 uwe.luebbers 2009-02-11 15:15:56 UTC
attached 98391
Comment 30 uwe.luebbers 2009-02-11 17:56:54 UTC
added 99123
Comment 32 brinzing 2009-02-16 07:10:23 UTC
please consider:

http://qa.openoffice.org/issues/show_bug.cgi?id=98927
PrintHiddenText and PrintHiddenText not saved to "settings.xml"

http://qa.openoffice.org/issues/show_bug.cgi?id=98805
a problem displaying basic dialogs 
Comment 33 bmarcelly 2009-02-16 09:43:43 UTC
Please consider Issue 99526
Regression : Service Function Access crashes OpenOffice
Comment 34 bmarcelly 2009-02-16 09:45:58 UTC
Sorry, wrong number ! Read :

Please consider Issue 99256
Regression : Service Function Access crashes OpenOffice
Comment 35 joerg.skottke 2009-02-16 12:58:27 UTC
CC me
Comment 36 uwe.luebbers 2009-02-16 15:55:00 UTC
removed 98927 beause target 3.2
Comment 37 cno 2009-02-17 21:06:29 UTC
Adding issue 99312
Comment 38 yuko 2009-02-18 08:08:48 UTC
Please consider Issue 99293 because this issue does not occur in OOo 3.0.
Comment 39 uwe.luebbers 2009-02-18 10:23:53 UTC
removed 99312 because duplicate
Comment 40 Olaf Felka 2009-02-18 11:07:18 UTC
adding issue 99257
Comment 41 uwe.luebbers 2009-02-18 15:06:08 UTC
added 98983
Comment 42 michael.ruess 2009-02-19 09:02:44 UTC
I nominate issue 99384 as long as it a nasty and disturbing regression from OOo
3.0.1.
Comment 43 Olaf Felka 2009-02-20 07:24:05 UTC
of: Added issue 99417
Comment 44 michael.ruess 2009-02-20 10:57:31 UTC
Adding issue 99451. It is a regression in the WW8 export filter, which cannot be
workarounded. Tables are a key feature in im/export.
Comment 45 stefan.baltzer 2009-02-23 12:43:50 UTC
Adding issue 99374 "Object selection context menu entries not translated
("Edit", "Properties...", "Save Copy as...")". This one 
- is a regression
- affects all languages (but English :-)
- in "every day use" context menu 
Comment 46 stefan.baltzer 2009-02-23 13:39:21 UTC
Correcting issue ID: Issue 99364. (NOT 99374)
Comment 47 Frank Schönheit 2009-02-23 20:55:13 UTC
Adding issue 97032 "no .lck file created anymore when connecting to an embedded
HSQLDB".

This issue was fixed in CWS dba31h (and indeed it *was* fixed there, as I just
verified in my installation set), but still appears in OO310.m2 (where CWS
dba31h_OOO310 has been integrated). Quite frightening.
Comment 48 merschmann 2009-02-23 21:41:02 UTC
Nominating issue 99082
"Copy&Paste doesn't work in Calc cell"
Comment 49 oc 2009-02-24 13:27:38 UTC
adding 99576 (X86: Selecting sheets leads to multiselection)
Comment 50 uwe.luebbers 2009-02-26 14:33:47 UTC
added 99466 and 99511
Comment 51 uwe.luebbers 2009-02-27 10:19:01 UTC
added 99680
Comment 52 uwe.luebbers 2009-03-02 16:27:38 UTC
added 99762
Comment 53 michael.ruess 2009-03-03 10:29:29 UTC
Added issue 99789 - it is a regression in exporting tables to Word .doc format.
Comment 54 uwe.luebbers 2009-03-04 14:53:42 UTC
attached 99768
Comment 55 uwe.luebbers 2009-03-04 16:33:40 UTC
attached 99876
Comment 56 uwe.luebbers 2009-03-05 11:25:17 UTC
removed 99070, 98962, 99082, becaused "closed duplicate". All original issues are 
fixed in 9.1.
Comment 57 uwe.luebbers 2009-03-06 11:56:50 UTC
added 99918
Comment 58 uwe.luebbers 2009-03-06 13:52:55 UTC
attached 99855
Comment 59 stefan.baltzer 2009-03-06 16:25:34 UTC
Adding issue 99967
[Sample documents open with dialog box "Locked by unknown user"]
Comment 60 michael.ruess 2009-03-09 12:39:19 UTC
Added issue 100043, it is a severe regression in export of numbered lists into
MS Word format.
Comment 61 joerg.skottke 2009-03-09 13:37:19 UTC
Add issue 100044: Testtool has problems retrieving strings from listboxes.
Regression, introduced into OOO310m2.
Comment 62 uwe.luebbers 2009-03-09 14:41:50 UTC
added 100043
Comment 63 uwe.luebbers 2009-03-09 14:44:40 UTC
added 100035
Comment 64 uwe.luebbers 2009-03-09 14:49:03 UTC
added 100042
Comment 65 stefan.baltzer 2009-03-09 15:45:06 UTC
According to current IRC release chat, adding isue 99710.
One closed duplicate of that is issue 10003 that one was already flagged as blocker.
Comment 66 uwe.luebbers 2009-03-09 18:17:07 UTC
added 100062 and 100063
Comment 67 uwe.luebbers 2009-03-09 18:24:52 UTC
removed 100006 because "closed invalid"
Comment 68 uwe.luebbers 2009-03-09 18:26:43 UTC
removed 100003 because "closed duplicate"
Comment 69 michael.ruess 2009-03-10 11:59:01 UTC
Adding issue 100014, as long as it is a P2-regression in the Word filter from
OOO310m2 or m3 to m4.
Comment 70 uwe.luebbers 2009-03-11 15:56:14 UTC
attached 100102

Comment 71 stefan.baltzer 2009-03-11 17:35:55 UTC
Adding issue 100110 "Crash when closing window Styles and Formatting (Stylist)
with F11"
This one is a regression within "trivial default use" of the Stylist.
Was OK in 3.0 and 3.0.1 and up to DEV300_m40.
Broken since OOO310_m1.
Comment 72 uwe.luebbers 2009-03-11 20:20:37 UTC
added 100131
Comment 73 uwe.luebbers 2009-03-11 20:24:32 UTC
added 99564 
Comment 74 uwe.luebbers 2009-03-11 20:28:10 UTC
added 100135
Comment 75 uwe.luebbers 2009-03-12 19:25:55 UTC
added 100132
Comment 76 tommy27 2009-03-16 09:20:49 UTC
All the release stoppers have been fixed and there weren't new entries in the 
last 3 days... is OOo 3.1 on his way to final release?
Comment 77 stefan.baltzer 2009-03-16 13:30:48 UTC
As discussed with UL, adding issue 100172 and issue 100177.
(Fixed in CWS fwk106 that should get RfQA today)
Comment 78 stefan.baltzer 2009-03-16 15:13:02 UTC
Correcting dependencie of these two.
Comment 79 stefan.baltzer 2009-03-16 15:15:21 UTC
Done.
Comment 80 uwe.luebbers 2009-03-16 17:36:11 UTC
attached 100235
Comment 81 uwe.luebbers 2009-03-16 17:42:40 UTC
attached 10072 and 100177
Comment 82 uwe.luebbers 2009-03-16 18:11:21 UTC
removed 10043, far too old
Comment 83 mdxonefour 2009-03-17 13:23:17 UTC
adding 100258
Comment 84 uwe.luebbers 2009-03-18 12:03:28 UTC
added 100300 and 100277
Comment 85 stefan.baltzer 2009-03-18 15:38:39 UTC
Added issue 92532 (PT-BR spellchecker does not work, fixed in CWS sw31bf08)
Comment 86 stefan.baltzer 2009-03-18 15:55:07 UTC
Adding issue 100227 (Macros using User defined DocumentInfo do not run anymore)
This one is fixed in CWS sw31bf08.
Comment 87 uwe.luebbers 2009-03-19 16:00:33 UTC
added 100349
Comment 88 uwe.luebbers 2009-03-23 13:45:53 UTC
added 100470 
Comment 89 uwe.luebbers 2009-03-23 15:18:41 UTC
attached 100424 
Comment 90 uwe.luebbers 2009-03-23 18:57:59 UTC
added 100406
Comment 91 uwe.luebbers 2009-03-25 14:02:14 UTC
added 100538
Comment 92 uwe.luebbers 2009-03-30 14:25:50 UTC
added 100373
Comment 93 uwe.luebbers 2009-03-30 16:24:26 UTC
added 100617 and 100618
Comment 94 uwe.luebbers 2009-03-30 17:44:41 UTC
added 100681
Comment 95 uwe.luebbers 2009-04-01 12:09:38 UTC
added 100707 
Comment 96 wolframgarten 2009-04-06 13:12:10 UTC
Attaching i100537.
Comment 97 uwe.luebbers 2009-04-06 16:10:42 UTC
added 100541 and 100522
Comment 98 uwe.luebbers 2009-04-06 16:18:26 UTC
added 100732
Comment 99 uwe.luebbers 2009-04-06 16:37:49 UTC
added 100823
Comment 100 kongnan 2009-04-07 16:00:57 UTC
added  94763, Filtered cells' borders draw FAILadded 
added 100925, No "lucida sans unicode" for chk characters
(sorry for my poor english)
Comment 101 merschmann 2009-04-08 13:36:22 UTC
Adding issue 100928 "Opening the Tools->Options->Improvement Program Tabpage on
first start accidently activates Usage Tracking"
Was accepted as blocker, cws is dba31m.
Comment 102 camillem 2009-04-08 16:47:13 UTC
Please consider issue 100895 
Deleting lines in a shared spreadsheet can lead to data loss/corruption.
Comment 103 michael.ruess 2009-04-14 11:07:07 UTC
Added issue 101029.
Comment 104 Rainer Bielefeld 2009-04-15 14:53:59 UTC
Added Issue 100993
This problem is really annoying for me, normal working with 3.1 is more or less
impossible. Funny, that no other one has this problem with linked OLE objects?
Comment 105 merschmann 2009-04-16 09:54:44 UTC
Adding issue 101097 "Volker Ahrendt is author of new documents"
(and it means _all_ documents!)
This is embarassing.
Comment 106 uwe.luebbers 2009-04-21 11:56:28 UTC
added 101169 and 101210
Comment 107 george_yves 2009-04-22 19:18:42 UTC
Please consider to fix  Issue 100762
(http://qa.openoffice.org/issues/show_bug.cgi?id=100762) as a release blocker
for OOo 3.1. OOo 3.1 would be a suitable release to fix it.
Comment 108 Frank Schönheit 2009-04-22 19:47:56 UTC
> Please consider to fix  Issue 100762 ... as a release blocker
> for OOo 3.1. OOo 3.1 would be a suitable release to fix it.

Sorry to say, but no, it actually isn't a suitable release. 3.1 is nearly
finished, we already had one release candidate, a second one is expected for
beginning of next week. In this phase, we certainly will not touch the code for
this kind of issues anymore, only the *most* serious issues are allowed to be fixed.
Comment 109 tommy27 2009-04-30 14:48:50 UTC
9 days since last issue has been discovered and fixed.

i hope that you killed 'em all
Comment 110 salvatoremoi 2009-04-30 14:49:10 UTC
Please consider Issue 101454
(http://www.openoffice.org/issues/show_bug.cgi?id=101454) for 3.1 (if possible)

Comment 111 tommy27 2009-05-08 14:11:41 UTC
let's close this issue.
Comment 112 tommy27 2009-05-08 14:11:48 UTC
let's close this issue.
Comment 113 Martin Hollmichel 2009-05-12 08:23:57 UTC
3.1 has been released now, mark as fixed.
Comment 114 mechtilde 2009-06-01 17:21:35 UTC
close because version 3.1 is released