Issue 95684 - Path too long when installing extensions
Path too long when installing extensions
Status: CLOSED DUPLICATE of issue 50885
Product: General
Classification: Code
Component: code
OOo 3.0
PC Windows XP
: P3 trivial (vote)
: ---
Assigned To: hennes.rohling
issues@framework
http://extensions.services.openoffice...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 08:27 UTC by robbk
Modified: 2009-05-11 10:33 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description robbk 2008-10-31 08:27:20 UTC
After installing the Sun Presentation Minimizer extension, two errors occur in
the Windows Event Viewer after every boot. The pertinent error message is (in
German):

"Die Datei C:\Dokumente und
Einstellungen\knapp_r\Anwendungsdaten\OpenOffice.org\3\user\uno_packages\cache\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend\registry\data\org\openoffice\Office\extension\SunPresentationMinimizer.xcu
konnte nicht nach \\ARTWEGER04\VOL1\US\knapp_r\Windows NT 5.1 Workstation
Profile\Anwendungsdaten\OpenOffice.org\3\user\uno_packages\cache\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend\registry\data\org\openoffice\Office\extension\SunPresentationMinimizer.xcu
kopiert werden. Mögliche Fehlerursachen sind Netzwerkprobleme oder nicht
ausreichende Sicherheitsrechte. Wenden Sie sich an den Netzwerkadministrator,
wenn das Problem weiterhin besteht. 

 Details - Der Dateiname oder die Erweiterung ist zu lang."

This means the path name is too long. The path referred to is:
C:\Dokumente und
Einstellungen\knapp_r\Anwendungsdaten\OpenOffice.org\3\user\uno_packages\cache\registry\com.sun.star.comp.deployment.configuration.PackageRegistryBackend\registry\data\org\openoffice\Office\extension\SunPresentationMinimizer.xcu

This is obviously longer than the acceptable Windows path name length.

The error message occurs when using roaming profiles.

Our workaround is to use the following undocumented command line parameter:
soffice -env:UserInstallation=file:///c:/oo

The problem is theroretically not limited to this extension but rather applies
to all extensions that use very long path names.

The problem may not occur under English operating systems because the standard
user folders may have shorter names in English.
Comment 1 Olaf Felka 2008-10-31 08:34:42 UTC
@ jsk: Please have a look
Comment 2 joerg.skottke 2008-11-03 07:42:39 UTC
Confirmed.

JSK-> HRO: You are currently working on a similar issue with the office
configuration paths, so can you please have a look at this one too?
Comment 3 robbk 2009-02-19 13:42:40 UTC
Any progress on this issue? Thanks.
Comment 4 stefan.baltzer 2009-03-26 16:17:19 UTC
Duplicate of issue 50885 ("Need long paths on Windows: Error installing
extension's own configuration schema on Windows", fixed in CWS longpath3 with
target OOo 3.2.)


*** This issue has been marked as a duplicate of 50885 ***
Comment 5 caolanm 2009-05-11 10:33:34 UTC
close as dup