Issue 95434 - incorrect reading of the cross-refs to footnotes in the linked-to file
incorrect reading of the cross-refs to footnotes in the linked-to file
Status: RESOLVED IRREPRODUCIBLE
Product: Writer
Classification: Application
Component: code
OOO300m7
All Linux
: P3 trivial (vote)
: ---
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 22:23 UTC by yury_t
Modified: 2014-03-15 10:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
testcase footnotes file (8.46 KB, application/octet-stream)
2008-10-24 22:24 UTC, yury_t
no flags Details
testcase main file (10.07 KB, application/octet-stream)
2008-10-24 22:25 UTC, yury_t
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description yury_t 2008-10-24 22:23:39 UTC
I'm experiencing this on Linux, with OOO300m7, Pavel Janik's build 9354. I can reproduce 
this, however I didn't do any further experiments. I'd rather have this working :).

So, if:
* I have a section with linked-to file, 
* and there are more than one footnotes in the linked-to file,
* and put cross-references (referencing the footnotes i the linked-to files) in the main file,
* and save the main file,
then:
* after the refreshing of the main file or after the re-reading it, the first of the cross-
references (referring to the 1st footnote) begins to show as referring to the 2nd footnote, 
and the 2nd cross-reference begins to show as "Error: reference source not found.". 

Double-clicking on the cross-ref in themain file yields then:
* in the 1st xref's Name field: 2nd footnote's name and text (read-only );
* in the 2nd xref's Name field: some read-only strangeness.

The main file's contents.xml show *seemingly* correct data, however (attaching the test 
case files).
Comment 1 yury_t 2008-10-24 22:24:54 UTC
Created attachment 57444 [details]
testcase footnotes file
Comment 2 yury_t 2008-10-24 22:25:46 UTC
Created attachment 57445 [details]
testcase main file
Comment 3 michael.ruess 2008-10-26 15:16:35 UTC
Reassigned to ES.
Comment 4 Edwin Sharp 2014-03-05 12:31:07 UTC
No visible error
AOO410m14(Build:9760)  -  Rev. 1573062
2014-03-01_04:11:01 - Rev. 1573123
Debian
Comment 5 yury_t 2014-03-15 10:59:34 UTC
I can't reproduce it on 3.6.7, anyway. Might've been fixed in the meanwhile. :)