Issue 85625 - Flexible positioning of axes and axis labels
Flexible positioning of axes and axis labels
Status: CLOSED FIXED
Product: General
Classification: Code
Component: chart
OOo 3.3 or older
All All
: P3 trivial with 78 votes (vote)
: ---
Assigned To: kla
issues@graphics
http://specs.openoffice.org/chart/Cha...
: ms_interoperability, usability
: 55501 (view as issue list)
Depends on:
Blocks: 79434 91973 96599 96600
  Show dependency treegraph
 
Reported: 2008-01-27 20:52 UTC by diaz_frederic
Modified: 2013-02-24 21:19 UTC (History)
6 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Contains datas plotted in xy diagrams with OOocalc and gnumeric (74.30 KB, text/plain)
2008-02-04 10:09 UTC, diaz_frederic
no flags Details
example document (88.16 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-11-20 11:06 UTC, IngridvdM
no flags Details
Testcasespecification for Axis positioning (51.53 KB, text/html)
2008-12-05 10:59 UTC, kla
no flags Details
Testcasespecification for Axis Scale reference value on secondary Axis (29.01 KB, text/html)
2008-12-05 15:07 UTC, kla
no flags Details
Adding a chart with provisional solution (88.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-03-22 03:03 UTC, mariosv
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description diaz_frederic 2008-01-27 20:52:38 UTC
When we create xy diagrams in OOoCalc, graduations are around a box.
In most of their works, teachers and students need graduations to be placed near
the axes (Ox) and (Oy)
Excel and gnumeric have allready implemented this functionality.
In the same file, graduations are near axes when open with excel or gnumeric,
and around a box when open with OOoCalc. 
http://www.forum-openoffice.org/forum/ftopic3975.html&sid=e8f3556a200bad49368d62a5bf8a0007
This is important for the possibility to use OOoCalc in building officials exams
documents in France.
We find urgent to implement this functionality of graduation near (Ox) and (Oy)
axes.
Comment 1 eric.bachard 2008-01-28 12:21:12 UTC
@fred : after being discussed with Eike Rathke, the issue appear to be a chart issue

@bm : I'm not sure I have choosen the right component/subcomponent, can you
confirm ?  thanks  :-)

Comment 2 eric.bachard 2008-01-28 12:23:36 UTC
As Physics teacher in the real life, I can only confirm this requirement is
really important.

The good behaviour could be: write the list of what exactly has to be done to
solve the issue :

- do we need to wtie specs ?
- do we need to attach screenshots (showing concurent office, and what is expected) 
- (please tell us )

Thanks :-)

Issue confirmed
Comment 3 eric.bachard 2008-01-28 12:45:05 UTC
+ me on CC
Comment 4 bjoern.milcke 2008-01-28 14:46:42 UTC
Taking over.

As far as I understood the French forum discussion, this is about having the
axis labels directly at the axis, instead of having it only on the edges of the
diagram area.

->ericb: It would help to have a screenshot to illustrate the problem. In
addition, we would of course like to offer the current placement. Therefore we
would need some kind of switch to tell the axis where to place its labels. This
requires a specification and an ODF file-format specification.

I wouldn't change the behavior (without switch), not only for compatibility, but
also because it might look bad if the labels overwrite each other, or data
labels, etc. that are at the same place.
Comment 5 lequesnoy 2008-01-28 23:11:25 UTC
it is a real problem in athematic...
Yhank you
Comment 6 lequesnoy 2008-01-28 23:11:29 UTC
it is a real problem in athematic...
Yhank you
Comment 7 eric.bachard 2008-02-04 07:49:54 UTC
ericb@bm

Thanks for taking over the issue, and sorry for answering lately : I'll ask Fred.
Your suggestion about use a switch looks great, and if you need help for build or help for QA, I'm your 
man. 

I just don't understand well the ODFfile-format issue: what happens exactly ? Is it problematic because of 
time issue or because too complicated to add ?
Comment 8 diaz_frederic 2008-02-04 10:09:46 UTC
Created attachment 51347 [details]
Contains datas plotted in xy diagrams with OOocalc and gnumeric
Comment 9 diaz_frederic 2008-02-04 10:12:53 UTC
In this file, you can notice that gnumeric allows user to choose the position of
axes, and especially to make them cross in (0;0)
Comment 10 jean_philippe_froment 2008-02-06 22:35:44 UTC
All secondary schools in North of France (Académie de lille) have  now at least 
one classroom, with one computer for each pupil. We have installed OpenOffice 
(or StarOffice) everywhere.
As a computer science teacher, I have met most of the maths teachers using 
those computers. One main problem  using OpenOffice, instead of excel, is 
having axis labels on the edges of the diagram area. French pupils are not at 
all used to it. Excel can write axis labels directly on the axis, as French 
children do on paper work. So this requirement is really important for us, and 
will favorably influence the choice of OpenOffice Calc in most French schools.
Thanks for your help
Comment 11 jean_philippe_froment 2008-02-06 22:40:46 UTC
All secondary schools in North of France (Académie de lille) have  now at least 
one classroom, with one computer for each pupil. We have installed OpenOffice 
(or StarOffice) everywhere.
As a computer science teacher, I have met most of the maths teachers using 
those computers. One main problem  using OpenOffice, instead of excel, is 
having axis labels on the edges of the diagram area. French pupils are not at 
all used to it. Excel can write axis labels directly on the axis, as French 
children do on paper work. So this requirement is really important for us, and 
will favorably influence the choice of OpenOffice Calc in most French schools.
Thanks for your help
Comment 12 ciber 2008-02-07 21:29:48 UTC
it is a real problem in mathematic...
Thank you
Comment 13 rboulle 2008-03-20 19:35:44 UTC
I had a teacher training today (in France, secondary education) about
spreadsheets (Calc and Excel) and this limitation appeared to be very annoying
to all teachers trained.
It seems to be one of the serious reasons to keep on using, eg, Excel.
Hope OOo 3 will have this feature.
Thanks a lot for your work !
Comment 14 niederbayern 2008-04-07 14:47:15 UTC
Please consider these two additional aspects in order to meet the usual
requirements for use in school:

(1) One must be able to assign an arrow style to the axis (similar to the line
object in the application´s draw functions.

(2) When axis cross at (x=0;y=0) the label "0" must not be displayed twice but
onliy once.

See this example http://de.wikipedia.org/wiki/Bild:Koordinatensystem.png for a
typical coordinate plane used in schools.
Comment 15 jbf.faure 2008-06-30 11:51:22 UTC
Add me to CC.
Comment 16 IngridvdM 2008-07-03 11:39:17 UTC
change owner
Comment 17 IngridvdM 2008-07-22 12:37:39 UTC
change target
Comment 18 IngridvdM 2008-09-19 15:42:30 UTC
I create a specification describing a new page 'Positioning' for the axis dialog:
http://specs.openoffice.org/chart/ChartAxisPositioning.odt
In addition the scale page will change for this feature:
http://specs.openoffice.org/chart/ChartAxisScale.odt

I implemented the described behavior in CWS calcchartrtl01. Thus interested
people knowing how to build a CWS might have a look already. Feedback is welcome.
Loading and saving does not work so far, as the necessary file format changes
need to be send to OASIS first and have to be discussed and approved there.
Comment 19 IngridvdM 2008-10-02 14:42:10 UTC
Created issue 94582 for the necessary changes in the documentation.
Created issue 94581 for the necessary changes in the automatic testing scripts.
Comment 20 IngridvdM 2008-11-12 14:21:38 UTC
moved fixes to CWS rtlchart02.
Comment 21 IngridvdM 2008-11-12 15:05:02 UTC
*** Issue 55501 has been marked as a duplicate of this issue. ***
Comment 22 IngridvdM 2008-11-19 10:35:05 UTC
The OASIS TC has approved the necessary file format extension:
http://wiki.oasis-open.org/office/AxesPosition
The issue is fixed in CWS rtlchart02.
Comment 23 IngridvdM 2008-11-20 11:06:24 UTC
Created attachment 58141 [details]
example document
Comment 24 IngridvdM 2008-11-20 11:12:59 UTC
@Thomas, please verify in CWS rtlchart02.
Comment 25 kla 2008-12-05 10:59:44 UTC
Created attachment 58540 [details]
Testcasespecification for Axis positioning
Comment 26 kla 2008-12-05 15:07:12 UTC
Created attachment 58551 [details]
Testcasespecification for Axis Scale reference value on secondary Axis
Comment 27 kla 2008-12-09 15:32:48 UTC
Seen ok in CWS rtlchart02 -> verified
Comment 28 mariosv 2009-03-22 03:00:38 UTC
I think is possible a provisional solution, adding two lines, one with 0 on x
and another one with 0 on y, mixing with a calculate scale, and showing the
values for this lines.
Comment 29 mariosv 2009-03-22 03:03:42 UTC
Created attachment 61094 [details]
Adding a chart with provisional solution
Comment 30 kla 2009-05-08 10:43:06 UTC
Seen ok in current master -> closed