Issue 83237 - allow transparent background for controls
allow transparent background for controls
Status: CLOSED FIXED
Product: App Dev
Classification: Unclassified
Component: api
OOo 3.3 or older
All All
: P3 trivial
: ---
Assigned To: joerg.skottke
issues@api
:
: 84211 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-02 10:44 UTC by jsc
Modified: 2013-02-24 21:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jsc 2007-11-02 10:44:58 UTC
It can be useful to set a transparent background of controls, e.g. for Label
controls. It is currently not possible to set such a property over the toollkit.
Comment 1 carsten.driesner 2007-11-06 14:14:11 UTC
cd: Implemented. There is a new property called "ImageURL" which is used to set
a background image for a dialog.
Comment 2 carsten.driesner 2007-11-06 14:16:33 UTC
cd: Transparency is now supported for non-compound controls.
Comment 3 carsten.driesner 2007-11-08 12:45:17 UTC
cd: This is a defect. Transparency already works for compound controls. Only
non-compound controls, like fixed text, don't behave correctly. From my point of
view the changes done to support transparency two years ago were not correct.
Comment 4 tkr 2007-11-13 16:57:03 UTC
tkr-> jsk: please verify
Comment 5 joerg.skottke 2007-11-19 14:35:06 UTC
Apparently not all controls are transparent. Submitted issue 83760 as a follow
up with same target but removing UI relevance (this is a fix, really).

Verified
Comment 6 carsten.driesner 2007-12-06 14:44:06 UTC
*** Issue 84211 has been marked as a duplicate of this issue. ***
Comment 7 joerg.skottke 2008-03-12 09:35:38 UTC
Close