Issue 82927 - Add Sámi languages to language list box.
Add Sámi languages to language list box.
Status: CLOSED FIXED
Product: Internationalization
Classification: Code
Component: i18npool
OOo 2.3
All All
: P3 trivial (vote)
: ---
Assigned To: stefan.baltzer
issues@l10n
http://www.divvun.no/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 13:21 UTC by snmdivvun
Modified: 2013-08-07 15:01 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description snmdivvun 2007-10-24 13:21:26 UTC
Hello,

The Norwegian Sámi Parliament has a project running for creating proofing tools for the Sámi 
languages. Among the host applications we want to support is OpenOffice.org.

We now have an alpha version of the required dic and aff files for hunspell, and would like to get the 
necessary language support in place before we start releasing beta versions for the public.

We thus ask the lingucomponent team to include support for spell checking the Sámi languages. 
Presently we need support for two Sámi languages, but future project extensions might cover more. It 
would be best to add support for all languages at the same time. They are:

se
sjd
sma
smj
smn
sms

Several of these languages are spoken (and written!) in more than one country using exactly the same 
spelling and writing convenctions, and it seems most appropriate to us to add the languages as 
unspecified for country, the same way it is done for Esperanto.

Please see our project web page for more information.
Comment 1 stefan.baltzer 2007-10-24 17:03:10 UTC
SBA: For setting appropriate "Priority" flag, please see
http://www.openoffice.org/scdocs/ddIssues_EnterModify.html#priority
Thank you for your comprehension.
However, supporting OOo by adding further languages support is a fine thing. ->
Confirming issue.
Set type to "feature" (-> new language entries needed)

Set Prio to P3.
Put ER and Nemeth on CC.
-> Eike, Lazlo: Please advise about the "order of steps" in this case.
Comment 2 milek_pl 2007-10-25 10:10:31 UTC
confirming the issue according to sba's comment (apparently it hasn't been
confirmed by mistake)
Comment 3 nemeth.lacko 2007-10-26 22:11:53 UTC
L10n issue: Add Sámi languages to language list box.
Comment 4 ooo 2007-11-07 13:25:59 UTC
I have no time anymore to get this into OOo2.4 before UI translation freeze,
retargeting to OOo3.x

@snmdivvun: Even if the language list box entries usually map to locales
including country information, the dictionaries usually are setup for language
only such that from the locale only the language information is used. For
details please contact the lingucomponent project. Esperanto is an exception to
other locales as there is no country associated at all with Esperanto that could
serve as a default country.
Comment 5 snmdivvun 2007-11-08 09:55:01 UTC
We urge you to reconsider inclusion in the OOo 2.4 release, and have included all relevant lang_COUNTRY codes 
below, as well as the translation of the language names into as many OOo languages as possible for us (see 
below).

If there is anything else we could do to promote the issue, we would be 
glad to contribute and help in any way. It is important to us to make the proofing tools available to the users as 
soon as possible.

Exhaustive list of language_Country codes:

se_NO
se_SE
se_FI
sjd_RU
sma_NO
sma_SE
smj_NO
smj_SE
smn_FI
sms_FI


Native language names:

se:davvisámegiella
sjd:са̄мь кӣлл
sma:åarjelsaemie
smj:julevsámegiella
smn:anarâškiellâ
sms:sää'mǩiõll


The following list gives the ISO-639 code for the target language, 
thereafter the code for the translated language name, and finally the 
translated name itself. The __ are just added for legibility.

Please note that Breton has a double set of entries, one set with ISO-639-1, two-letter code 'br', and one set 
with 639-2 code 'bre'. We have, on the other hand, not given a separate translation for "Brazilian".

The list contains most OOo "Level 2" languages, but admittedly not all. We 
confined ourselves to the languages we knew ourselves, and the languages
for which there were comprehensive Wikipedia articles on the Sámi languages.

br:__se:Samieg an norzh
br:__sjd:Samieg Kildin
br:__sma:Samieg ar su
br:__smj:Samieg Lule
br:__smn:Samieg Inari
br:__sms:Samieg Skolt
bre:__se:Samieg Inari
bre:__smj:Samieg Lule
bre:__sme:Samieg an norzh
bre:__sma:Samieg ar su
bre:__sjd:Samieg Kildin
bre:__sms:Samieg Skolt

ca:__se:Sami septentrional
ca:__sjd:Sami de Kildin
ca:__sma:Sami meridional
ca:__smj:Sami de Lule
ca:__smn:Sami d'Inari
ca:__sms:Sami skolt

cs:__se:severní sámština
cs:__sjd:kildinská sámština
cs:__sma:jižní sámština
cs:__smj:luleská sámština
cs:__smn:inarijská sámština
cs:__sms:skoltská sámština

da:__se:Nordsamisk
da:__sjd:Kildinsamisk
da:__sma:Sydsamisk
da:__smj:Lulesamisk
da:__smn:Enaresamisk
da:__sms:Skoltesamisk

de:__se:Nordsamisch
de:__sjd:Kildinsamisch
de:__sma:Südsamisch
de:__smj:Lulesamisch
de:__smn:Inarisamisch
de:__sms:Skoltsamisch

en:__se:North Sámi
en:__sjd:Kildin Sámi
en:__sma:South Sámi
en:__smj:Lule Sámi
en:__smn:Inari Sámi
en:__sms:Skolt Sámi

es:__se:Norte Sami
es:__sjd:Kildin Sami
es:__sma:Súr Sami
es:__smj:Lule Sami
es:__smn:Inari Sami
es:__sms:Skolt Sami

et:__se:Põhjasaami keel
et:__sjd:Kildinisaami keel
et:__sma:Lõunasaami keel
et:__smj:Luulesaami keel
et:__smn:Inarisaami keel
et:__sms:Koltasaami keel

eo:__se:nord-samea lingvo
eo:__sjd:kildin-samea lingvo
eo:__sma:sudsamea lingvo
eo:__smj:lule-samea lingvo
eo:__smn:inari-samea lingvo
eo:__sms:skolt-samea lingvo

fi:__se:Pohjoissaame
fi:__sjd:Kilttinänsaame
fi:__sma:Eteläsaame
fi:__smj:Luulajansaame
fi:__smn:Inarisaame
fi:__sms:Koltansaame

fr:__se:Sami du Nord
fr:__sjd:Sami du Kildin
fr:__sma:Sami du Sud
fr:__smj:Sami de Lule
fr:__smn:Sami d'Inari
fr:__sms:sami skolt

hu:__se:északi számi
hu:__sjd:kildini számi
hu:__sma:déli számi
hu:__smj:lulei számi
hu:__smn:inari számi
hu:__sms:kolta számi

it:__se:sami settentrionale
it:__sjd:sami di Kildin
it:__sma:sami meridionale
it:__smj:sami di Lule
it:__smn:sami di Inari
it:__sms:sami skolt

ko:__se:북사미어
ko:__sjd:킬딘 사미어
ko:__sma:남사미어
ko:__smj:룰레 사미어
ko:__smn:이나리 사미어
ko:__sms:스콜트 사미어

nb:__se:Nordsamisk
nb:__sjd:Kildinsamisk
nb:__sma:Sydsamisk
nb:__smj:Lulesamisk
nb:__smn:Enaresamisk
nb:__sms:Skoltesamisk

nl:__se:Noord-Samisch
nl:__sjd:Kildin-Samisch
nl:__sma:Zuid-Samisch
nl:__smj:Lule-Samisch
nl:__smn:Inari-Samisch
nl:__sms:Skolt-Samisch

nn:__se:Nordsamisk
nn:__sjd:Kildinsamisk
nn:__sma:Sørsamisk
nn:__smj:Lulesamisk
nn:__smn:Enaresamisk
nn:__sms:Skoltesamisk

pt:__se:Norte Sami
pt:__sjd:Kildin Sami
pt:__sma:Sul Sami
pt:__smj:Lule Sami
pt:__smn:Inari Sami
pt:__sms:Skolt Sami

ru:__se:Северносаамский язык
ru:__sjd:Кильдинский язык
ru:__sma:Южносаамский язык
ru:__smj:Луле-саамский язык
ru:__smn:Инари-саамский язык
ru:__sms:Колтта-саамский язык

se:__se:davvisámegiella
se:__sjd:Gielddasámegiella
se:__sma:lullisámegiella
se:__smj:Julevsámegiella
se:__smn:Anársámegiella
se:__sms:Nuortalawgiella

sk:__se:severná saamčina
sk:__sjd:kildinská saamčina
sk:__sma:južná saamčina
sk:__smj:luleská saamčina
sk:__smn:inariská saamčina
sk:__sms:skoltská saamčina

sv:__se:Nordsamiska
sv:__sjd:Kildinsamiska
sv:__sma:Sydsamiska
sv:__smj:Lulesamiska
sv:__smn:Enaresamiska
sv:__sms:Skoltsamiska

Comment 6 ooo 2007-11-08 14:09:55 UTC
The reasons why I retargeted this are:

1. I personally don't have time to work on this right now, I'm busy with other
   things.

2. We are short before UI freeze, which is Nov-15, see
   http://wiki.services.openoffice.org/wiki/OOoRelease24

3. Including all of the requested locales would need some research whether MS
   defined some new LangIDs for Sami, additionally to the already known ones,
   see below. If not, new IDs in the user space would have to be created. New
   mappings would be needed anyway.

4. I don't have a CWS open anymore that is UI/translation relevant where
   I could add language list box entries. (btw, localized names are up to the
   localization teams and not relevant here, we add only English entries to
   the resource files)

5. If someone had such a CWS for this, it would have to go through QA before
   UI freeze, QA people are already overloaded for OOo2.4

6. Additional obstacle in case we could push this in somewhere:
   svx/source/dialog/langtab.src, where the list box entries are defined, will
   be moved to svtools/source/misc/langtab.src upon integration of CWS
   langstatusbar. Release engineering would have to take extra care of that
   and merge entries from the than dead file to the new file.


So, to solve this:

1. We'll have to find someone who can work on this.

2./4./5. In a very timely manner on a CWS that is scheduled to be certainly
   integrated until UI freeze. With English list box entries that conform to
   the "Language (Country)" convention we use.

3. To not have to come up with yet other LangID definitions, we should use and
   add list box entries only for the ones we already have defined, see below.
   This would also restrict changes to the svx/source/dialog/langtab.src file
   and we wouldn't have to touch the i18npool module.

6. The responsible developer must keep an eye on integration of the CWS if
   that happens after CWS langstatusbar was integrated.

The list of the currently available LangID definitions with ISO code mappings:

#define LANGUAGE_SAMI_INARI                 0x243B
    { LANGUAGE_SAMI_INARI,                 "smn", "FI" },
#define LANGUAGE_SAMI_LULE_NORWAY           0x103B
    { LANGUAGE_SAMI_LULE_NORWAY,           "smj", "NO" },
#define LANGUAGE_SAMI_LULE_SWEDEN           0x143B
    { LANGUAGE_SAMI_LULE_SWEDEN,           "smj", "SE" },
#define LANGUAGE_SAMI_NORTHERN_FINLAND      0x0C3B
    { LANGUAGE_SAMI_NORTHERN_FINLAND,       "se", "FI" },
#define LANGUAGE_SAMI_NORTHERN_SWEDEN       0x083B
    { LANGUAGE_SAMI_NORTHERN_SWEDEN,        "se", "SE" },
#define LANGUAGE_SAMI_SKOLT                 0x203B
    { LANGUAGE_SAMI_SKOLT,                 "sms", "FI" },
#define LANGUAGE_SAMI_SOUTHERN_NORWAY       0x183B
    { LANGUAGE_SAMI_SOUTHERN_NORWAY,       "sma", "NO" },
#define LANGUAGE_SAMI_SOUTHERN_SWEDEN       0x1C3B
    { LANGUAGE_SAMI_SOUTHERN_SWEDEN,       "sma", "SE" },

Adding corresponding entries to the langtab.src file is easy once we have
suitable strings, just that someone has to do it and all the administrative
work related to CWSs. I'll ask on IRC and on dev@l10n if someone could take
over.

Thanks for understanding.

  Eike
Comment 7 snmdivvun 2007-11-08 21:39:58 UTC
Thanks for your consideration, I/we fully understand your concerns. To your numbered list of 
obstacles/issues to solve:

1. I can only hope you find somebody - we will do whatever we can do to help ease the task, hopefully 
enough that somebody will actually do it.

2./4./5. I don't know much about OOo internals, processes and tools (yet), and I don't know what CWS is, 
but how I read this is that all you need is the English variant (but that perhaps somebody in the 
localisation teams would be happy to receive the list of localised language names we have provided).

3. I am happy to only add the languages for which there are already defined codes. Your list is missing one 
language, I have provided an updated list (and a reference) below. After the correction, only Kildin Sámi (in 
Russia) would be left out this time. That is acceptable, given the present available resources for proofing 
tools for that language.

6. No useful comment until I understand what CWS is.

The *UPDATED* list of the currently available(? they are available at least in the sense that both ISO and 
MS have defined codes for them) LangID definitions with ISO code mappings:

#define LANGUAGE_SAMI_INARI                 0x243B
   { LANGUAGE_SAMI_INARI,                 "smn", "FI" },
#define LANGUAGE_SAMI_LULE_NORWAY           0x103B
   { LANGUAGE_SAMI_LULE_NORWAY,           "smj", "NO" },
#define LANGUAGE_SAMI_LULE_SWEDEN           0x143B
   { LANGUAGE_SAMI_LULE_SWEDEN,           "smj", "SE" },
#define LANGUAGE_SAMI_NORTHERN_FINLAND      0x0C3B
   { LANGUAGE_SAMI_NORTHERN_FINLAND,       "se", "FI" },
#define LANGUAGE_SAMI_NORTHERN_SWEDEN       0x083B
   { LANGUAGE_SAMI_NORTHERN_SWEDEN,        "se", "SE" },
#define LANGUAGE_SAMI_NORTHERN_NORWAY       0x043B
   { LANGUAGE_SAMI_NORTHERN_NORWAY,        "se", "NO" },
#define LANGUAGE_SAMI_SKOLT                 0x203B
   { LANGUAGE_SAMI_SKOLT,                 "sms", "FI" },
#define LANGUAGE_SAMI_SOUTHERN_NORWAY       0x183B
   { LANGUAGE_SAMI_SOUTHERN_NORWAY,       "sma", "NO" },
#define LANGUAGE_SAMI_SOUTHERN_SWEDEN       0x1C3B
   { LANGUAGE_SAMI_SOUTHERN_SWEDEN,       "sma", "SE" },

The added language is 0x043B/Northern Sámi, Norway.

The Microsoft language code for it can be found on these pages:

http://www.microsoft.com/globaldev/nlsweb/default.mspx?OS=Windows%20XP%20Service%20Pack%202

and

http://msdn2.microsoft.com/en-us/library/ms172470.aspx

Northern Sámi in Norway is the locale with the largest population, and if it is missing in the OOo LangID 
definitions, that has to be an oversight (I'm not 100% sure of the status of the code list you provided - I 
have just extended it based on information from MS and ISO). But given that North Sámi is still defined for 
Finland and Sweden, it would probably not be too much of an annoyance for the users if it would be 
missing - the *language* would still be available.

Finally - what strings are the "suitable strings" you mention in the last paragraph? Anything we can 
provide?

The English language names were given in an earlier comment.
Comment 8 stefan.baltzer 2007-11-09 12:18:53 UTC
SBA: About CWS (child workspace):
http://wiki.services.openoffice.org/wiki/CWS_Policies
http://tools.openoffice.org/dev_docs/OOo_cws.html
Comment 9 ooo 2007-11-09 13:16:38 UTC
Just to let you know that hopefully we found a solution, I'll go into detail later.
Comment 10 snmdivvun 2007-11-09 20:32:22 UTC
Thank you very much for your support and help:)

Please don't hesitate to ask if there's anything more we can do to help you.
Comment 11 ooo 2007-11-12 13:07:28 UTC
In CWS dba24lms:

i18npool/inc/i18npool/lang.h  1.8.46.1
i18npool/source/isolang/isolang.cxx  1.12.44.1
svx/source/dialog/langtab.src  1.77.188.1

This now adds the following entries to the language list box:
"Sami, Inari (Finland)"
"Sami, Lule (Norway)"
"Sami, Lule (Sweden)"
"Sami, Northern (Finland)"
"Sami, Northern (Norway)"
"Sami, Northern (Sweden)"
"Sami, Skolt (Finland)"
"Sami, Southern (Norway)"
"Sami, Southern (Sweden)"

Regarding the 0x043B/Northern Sámi, Norway:
That wasn't in the list of known mappings because in older MS listings
it was only described as "Sami (Lappish)", which I considered nonsense.
See http://www.microsoft.com/globaldev/reference/lcid-all.mspx (that btw
does not list all assignments as the name and the title might suggest).
It slipped my attention that it was more precisely described in the
newer listings for Windows XP, thanks for pointing out.
Comment 12 snmdivvun 2007-11-12 13:48:48 UTC
Thank you very much for your support and action, we appreciate it enormously.

Should I create a separate issue for Kildin Sámi, with target 3.0?

Comment 13 ooo 2007-11-12 14:00:12 UTC
Yes, please create a separate issue for missing languages with target 3.x
Comment 14 ooo 2007-11-12 18:00:40 UTC
Reassigning to QA for verification.
Comment 15 christoph.lukasiak 2007-11-13 15:19:02 UTC
clu->sba: like we have spoken, your issue
Comment 16 stefan.baltzer 2007-11-20 11:51:29 UTC
SBA: Verified in CWS dba24lms.
Comment 17 stefan.baltzer 2008-04-15 23:22:37 UTC
OK in OOo 2.4
Closed.