Issue 81027 - Problems with accessibility and screen reader JAWS
Problems with accessibility and screen reader JAWS
Status: CONFIRMED
Product: General
Classification: Code
Component: accessibility
OOo 2.2.1
PC Windows XP
: P3 trivial with 2 votes (vote)
: ---
Assigned To: AOO issues mailing list
: needmoreinfo
: 108594 (view as issue list)
Depends on:
Blocks: winA11y
  Show dependency treegraph
 
Reported: 2007-08-25 13:30 UTC by leiflodahl
Modified: 2013-11-04 23:23 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Test (6.36 KB, application/vnd.oasis.opendocument.text)
2007-08-26 18:14 UTC, leiflodahl
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description leiflodahl 2007-08-25 13:30:09 UTC
This issue regards accessibility. I'm posting on behalf of a blind user.

JAWS is screen reader.

Reading text within the edit field i.e. reading of the document seems somewhat
unpredictable. When I have typed a couple of words, I want to review the line,
but the command for reading the current line does not always give the desired
result. 

I have adjusted the zoom factor in the "view" menu to 75%, but there might be
some settings that you recommend for optimal use that I am not aware of, so if
you have suggestions please go ahead.
Comment 1 Olaf Felka 2007-08-25 16:31:05 UTC
@ es: Plese review.
Comment 2 eric.savary 2007-08-26 15:09:01 UTC
What do you mean exactly with:

"but the command for reading the current line does not always give the desired
result"

Please attach a sample document with wihich we could reproduce a problem.
Comment 3 leiflodahl 2007-08-26 18:14:35 UTC
Created attachment 47790 [details]
Test
Comment 4 leiflodahl 2007-08-26 18:15:39 UTC
Hi,

Well, when I tried to reproduce the issue, the command to say the current line
(Ins+up arrow) did indeed read the current line of text. However, when I press
an arrow key to get to that line, the text is not read out automatically. Only
when I hit the aforementioned command, I get the text on that particular line. I
have attached a document with just 1 line. I hope that the issue can be
reproduced at your end (smile). When I move with the up and down arrow keys,
JAWS announces "edit" even when that particular line does contain text which
then is supposed to be read out automatically. But only "edit" is spoken
automatically.

Hope this makes sense. Otherwise do ask again.

Best regards
Daniel  (dg-at-danielgartmann.dk)
Comment 5 Marcus 2010-01-23 09:31:47 UTC
*** Issue 108594 has been marked as a duplicate of this issue. ***
Comment 6 kailash81 2010-01-25 04:25:49 UTC
This issue is raised in August 2007. Still no solution/ fix-up for this? 
Comment 7 Rob Weir 2013-02-02 02:59:56 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 8 Paul Ambler 2013-02-11 22:15:48 UTC
Hi,

I am a blind user of Openoffice.org and I have noticed that NVDA can only read words and letters after typing them.  I have also tried using the combination keys needed to get NVDA to read what my last sentance was and it fails to read it out. .  However Openoffice seams to read out dialog boxes now but I am unsure if that is due to the installation of Java Access Bridge.

I have tried the following:

1) Pressing Ctrl and down rrow which should read the sentance out but it doesn't
2) Pressing down on it's own this also didn't work
3) Pressing ctrl + shift + down/right arrow key to select the sentance/word but this doesn't work either.

I have installed java access bridge and set openoffice.org to recognize this and I have changed the settings which tell openoffice.org to allow assisted technology to be used, but this hasn't resolved the issue either.

Please can someone look into this as I like openoffice due to it's comprehensive functions, but I find it harder to use due to the above issue.

Thanks

Paul
Comment 9 V Stuart Foote 2013-02-13 18:03:34 UTC
Will need testing with a current release of JAWS, but implementation of IAccessibile2 with the ia2 branch merge of the IBM Symphony contribution should resolve, see bug 107914