Issue 79512 - Crash on Use of Address Data Source Wizard
Crash on Use of Address Data Source Wizard
Status: CLOSED FIXED
Product: porting
Classification: Code
Component: MacOSX
680m220
Mac Mac OSX, all
: P3 trivial (vote)
: OOo 2.4
Assigned To: cremlae
issues@porting
http://bugzilla.neooffice.org/bug.php...
:
Depends on: 77591
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 23:23 UTC by cremlae
Modified: 2009-07-20 15:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Based on pluby's original patch, this also checks for a null header when processing arrays (1.52 KB, patch)
2007-07-11 23:31 UTC, cremlae
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description cremlae 2007-07-11 23:23:06 UTC
This is a copy of the crash on NeoOffice (see URL). It is as yet unconfirmed on
OpenOffice.org, but pluby's proposed patch on issue 77591 likely prevents a
crash and is smart.
Comment 1 cremlae 2007-07-11 23:31:11 UTC
Created attachment 46708 [details]
Based on pluby's original patch, this also checks for a null header when processing arrays
Comment 2 cremlae 2007-07-11 23:37:35 UTC
cremlae->pluby: Do you have a particular address book record that I could
recreate to confirm this issue on OOo?
Comment 3 cremlae 2007-07-11 23:52:47 UTC
cremlae->pluby: Also, I noticed that in your patch, you removed the line "length
+= dictHeaders[i]->getSize();" (just before your addition to check if
dictHeaders[i] exists) ... My attached patch doesn't do this yet since I don't
understand it. What is the reason for it?

Thanks for your help!
Comment 4 pluby 2007-07-12 00:11:31 UTC
pluby->cremlae: Good catch! It looks like I botched the diff as the getSize()
line should not be deleted. Also, I noticed that your patch also fixes one of
the same errors conditions that I missed.

FYI. I will use your patch and you can ignore the patch that I posted in 77591.
Comment 5 cremlae 2007-07-13 21:04:52 UTC
Committed the patch of cws macaddressbook01, resolving as fixed.
Comment 6 eric.bachard 2007-09-06 15:58:59 UTC
set target
Comment 7 florian 2007-09-08 10:50:24 UTC
Does not occur with a current build.
Comment 8 thorsten.ziehm 2009-07-20 15:18:54 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues