Issue 74965 - New Chart: Color of formatted pie segments changes to first one after save and reload
New Chart: Color of formatted pie segments changes to first one after save an...
Status: CLOSED FIXED
Product: General
Classification: Code
Component: chart
OOo 3.3 or older
All All
: P3 trivial (vote)
: ---
Assigned To: kla
issues@graphics
: new_implementation
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 12:58 UTC by bjoern.milcke
Modified: 2013-02-24 21:21 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description bjoern.milcke 2007-02-28 12:58:49 UTC
1. Enter four numbers in a column in a spreadsheet
2. Insert Chart, choose Pie chart type, Finish Wizard.
3. Pull out the second, third or fourth pie segment a bit (or do any other
formatting, except fill color, that creates a data point object)
4. Save the chart and reload, activate the chart in the reloaded document
=> the formatted points will get the color of the first series (which is the
same as the first segment)

The problem is in the saved file, i.e. the colors of the data points that are
stored in the content.xml stream are already wrong. (Loading is correct as what
comes up is what is in the file).

See chart2mst3 milestone 11.
Comment 1 bjoern.milcke 2007-02-28 13:00:00 UTC
keyword added
Comment 2 IngridvdM 2007-02-28 16:55:51 UTC
fixed in CWS chart2mst3
Comment 3 IngridvdM 2007-03-02 13:01:53 UTC
->Thomas, please verify in Milestone 11_1.
Comment 4 kla 2007-03-06 10:27:28 UTC
Seen ok in mst11_1 -> verified
Comment 5 lohmaier 2007-06-14 13:45:12 UTC
OK in m215 → closing