Issue 74716 - straight connector lines created in MS Powerpoint wrongly displayed in OpenOffice.org 2.1
straight connector lines created in MS Powerpoint wrongly displayed in OpenOf...
Status: CONFIRMED
Product: Impress
Classification: Application
Component: open-import
OOo 2.1
PC Windows XP
: P3 trivial (vote)
: ---
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-21 07:58 UTC by kenosc
Modified: 2013-08-07 15:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: easy


Attachments
StraightConnectorIssue (11.00 KB, text/plain)
2007-02-21 07:59 UTC, kenosc
no flags Details
Straight Connector Issue (11.00 KB, application/vnd.ms-powerpoint)
2007-02-21 08:02 UTC, kenosc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kenosc 2007-02-21 07:58:12 UTC
The straight connector lines created using MS powerpoint 97 was incorrectly
displayed when opened with OpenOffice.org 2.1 (and 2.0.3)

Steps to create the "error"
1. create a new powerpoint presentation
2. use the drawing toolbar, click AutoShapes > Basic Shapes > and click Arc
3. click on anywhere on the empty presentation slide and an Arc will be created.
4. use the drawing toolbar again, click AutoShapes > Basic Shapes > and click Oval
5. click on anywhere on the empty presentation slide and a circle will be created.
6. select the straight connector tool by using the drawing toolbar, click
AutoShapes > Connectors > Straight Connector
7. click on one end of the Arc and one side of the circle, a line will join the
Arc to the Circle.
8. repeat step 6-7 to join the other side of the Arc and the other side of the
circle.
9. save the MS powerpoint file as a .ppt file
10. open the .ppt file with OpenOffice.org 2.1 (or 2.0.3, error tested on both
of these versions)
11. when the .ppt is opened with OpenOffice.org, the connector lines does not
join to the Arc.

thank you.
Comment 1 kenosc 2007-02-21 07:59:06 UTC
Created attachment 43218 [details]
StraightConnectorIssue
Comment 2 kenosc 2007-02-21 08:02:26 UTC
Created attachment 43219 [details]
Straight Connector Issue
Comment 3 michael.ruess 2007-02-21 09:14:48 UTC
Reassigned to Presentation component.
Comment 4 christian.guenther 2007-02-23 08:08:51 UTC
one for me.
Comment 5 christian.guenther 2007-02-23 15:53:55 UTC
Set to new and change the target.
Comment 6 christian.guenther 2007-02-23 16:12:26 UTC
I can reproduce the bug
It looks also wrong in PPT xp.
After the import there are 2 gluepoints which I can't see in PPT 97.
The connectors snap to the gluepoints. In my mind the connectors are correct but
the position  of the gluepoints are wrong.
Please have a look.
Comment 7 Regina Henschel 2012-08-03 17:32:14 UTC
The shape has a gluepoint in the center of the circle in PowerPoint. That is missing in AOO.