Issue 70446 - Loop after opening odt containing many captioned objects
Loop after opening odt containing many captioned objects
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: code
OOo 2.0.4
All All
: P2 trivial (vote)
: ---
Assigned To: michael.ruess
issues@sw
: crash, oooqa
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-15 13:18 UTC by zlamma
Modified: 2013-08-07 14:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
File causing breakage in OO. (93.04 KB, application/vnd.oasis.opendocument.text)
2006-10-15 13:20 UTC, zlamma
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description zlamma 2006-10-15 13:18:26 UTC
Hello.
OO Writer hangs a while after loading the attached file.
As It was made purely in OpenOffice Writer i find this a bug in the software.
I had some hard time trying to restore it. Finally KOffice let me export it to
rtf, so that i could repair it in OpenOffice again.
Comment 1 zlamma 2006-10-15 13:20:22 UTC
Created attachment 39763 [details]
File causing breakage in OO.
Comment 2 aziem 2006-10-15 18:55:16 UTC
Confirmed on OOo 2.0.4 Linux.  I saw the first page of 17, and then OOo became
unresponsive as it consumed CPU (but not memory).
Comment 3 zlamma 2006-10-15 23:37:04 UTC
Yes I forgot to mention about the permanent 100% CPU usage while hanging. This
seems to be an infinite loop on some of the document's element.

Thank you for your interest.
I hope this is a rare case for I am concerned about the safety of other users' work.
Comment 4 fmaier 2006-10-16 08:51:37 UTC
I can confirm all effects described here for OOo 2.03, 100% CPU and my window
manager (kwin) is not reponding, too. Had to kill soffice from the console manually.
Comment 5 michael.ruess 2006-10-27 16:06:48 UTC
MRU->OD: Open attached document; will loop after a short time of formatting
process. Was good in 2.0.1.
Comment 6 frank.meies 2007-09-05 08:52:26 UTC
Loop does not occur anymore due to the implementation of some general loop
controls in the Writer layout engine, see issue 81146.
Comment 7 frank.meies 2007-09-10 13:38:18 UTC
fme->mru: Ready for QA.
Comment 8 michael.ruess 2007-09-17 13:05:42 UTC
Verified in CWS loopcontrol.
Comment 9 michael.ruess 2007-11-05 15:47:40 UTC
Checked fix in OO 2.4 dev build 680m235.