Issue 69367 - TextPortionType "Frame" is undocumented
TextPortionType "Frame" is undocumented
Status: CLOSED FIXED
Product: App Dev
Classification: Unclassified
Component: api
OOo 3.3 or older
All All
: P3 trivial
: ---
Assigned To: chne
issues@api
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-07 17:00 UTC by mux2005
Modified: 2013-02-24 21:08 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description mux2005 2006-09-07 17:00:59 UTC
The IDL documentation does not document the TextPortionType "Frame". The
attachment to issue 69366 contains such a TextPortion for instance (a line
anchored at a character). The IDL documentation should be amended to list
"Frame" among the possible TextPortionType values.

A similar issue seems to have been reported already as issue 24444. But please
DO NOT close my issue as duplicate of issue 24444. That issue is 3 years old and
against OOo 1.1 (and should be closed WONTFIX as that's obviously the reality). 

Unlike issue 24444 I'm NOT asking for OOo to return "TextContent" instead of
"Frame" as the reporter of issue 24444. That doesn't seem to be correct, since
the IDL docs say that TextContent text portions are returned via
XContentEnumerationAccess which the objects in question are not.

TextPortions of type "Frame" are clearly a different type of TextPortions and
therefore should be properly documented in the IDL docs.
Comment 1 jsc 2006-09-08 07:55:07 UTC
jsc -> tl: can you please check this
Comment 2 thomas.lange 2006-09-11 12:38:10 UTC
.
Comment 3 thomas.lange 2006-09-11 12:38:31 UTC
Fixed in CWS tl25.

Files changed:
- offapi/com/sun/star/text/TextPortion.idl
Comment 4 thomas.lange 2006-11-27 12:27:01 UTC
.
Comment 5 chne 2007-01-22 16:23:07 UTC
ok in tl25
Comment 6 chne 2007-02-02 13:27:10 UTC
ok in src680_m202 (but currently not on openoffice.org)