Issue 66014 - Carriage return/line break directly below table cannot be removed
Carriage return/line break directly below table cannot be removed
Status: CLOSED IRREPRODUCIBLE
Product: Writer
Classification: Application
Component: formatting
OOo 2.0
PC Windows XP
: P3 trivial with 11 votes (vote)
: ---
Assigned To: requirements
issues@sw
: oooqa
: 81666 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 20:37 UTC by antonbijl
Modified: 2009-01-01 17:48 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample document showing problem (12.50 KB, application/vnd.oasis.opendocument.text)
2009-01-01 17:48 UTC, Joe Smith
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description antonbijl 2006-06-01 20:37:10 UTC
To recreate:
1 - Open new Text doc
2 - Ctrl-F12 (Insert.Table)
3 - OK
note: you now have a blank document with a table (2x2 in my case) on the first
line of the first page
4 - Click directly below the table
note: cursor now appears on blank line below table

Problem: blank line below table cannot be deleted. Pressing backspace moves the
cursor to the last cell of the table.

This is particularly annoying when that line happens to cause a page break at
the end of a document.

Issue 57586 is related but I don't believe it's a duplicate although in alci's
2005-11-14 02:35 comment on that issue he mentions this too.

Refer also http://www.oooforum.org/forum/viewtopic.phtml?p=149894 on the user
forums.

Note that a workaround exists as per following steps:
1 - Create frame
2 - Create table in frame
3 - type text on the blank line below the table in the frame
4 - select text typed in 3 above
5 - Table.Convert.Text to table...
6 - right click in (single-row) table created in 5 and select Row.Delete

Note also that the behaviour of the line break after the table seems to match
the behaviour of an object with "No Wrap" setting (e.g. frame). However, on
table there appears to be no way of changing the wrap setting of the table.
Comment 1 antonbijl 2006-06-01 20:46:53 UTC
I'm indicating platfrom PC + WinXP Pro (SP2) + OOo 2.0 as this is what I'm
using, but based on other user experiences relayed on forum thread mentioned in
original description I believe it does occur on WinXP, OOo 2.0.2 as well.

Also, note that the workaround results in the table being inside a frame, which
some users might not appreciate.
Comment 2 michael.ruess 2006-06-02 08:00:45 UTC
Reassigned to requirements. A possibility to remove an empty paragraph below a
table is desired.
Comment 3 michael.ruess 2007-09-18 12:22:12 UTC
*** Issue 81666 has been marked as a duplicate of this issue. ***
Comment 4 lohmaier 2007-09-19 12:48:56 UTC
worksforme, you can already delete the paragraph after the table.

put the cursor at the end of the last cell, then press <ctrl>+<shift>+<del>
Comment 5 lohmaier 2007-09-19 12:51:00 UTC
Feature already present and working → closing

To create a paragraph after the table again, put the cursor at the end of the
last cell, then press <alt>+<enter>
Comment 6 syockit 2008-07-14 10:35:41 UTC
Reopen please. Paragraph after a nested table cannot be deleted.

Steps to recreate:
1 - Create a table.
2 - Create another table inside the cell of the table created in step 1.
3 - Select the last cell inside the table created in step 2.
4 - Press <ctrl>+<shift>+<del>

Expected result:
 Empty line after the table created in step 2 gets deleted.

What happens instead:
 Cursor moves to the aforementioned line.

Of course, right now, the possible alternative is to create a frame and make a new 
table inside it instead.
Comment 7 lohmaier 2008-07-14 10:56:39 UTC
nested tables are a different topic, so file a seperate issue please
Comment 8 Joe Smith 2009-01-01 17:46:10 UTC
There is still one situation where the empty paragraph is impossible to remove:
after a table at the end of a document. Using Ctrl+Shift+Delete removes the
trailing empty paragraph, and the paragraph is not present in the saved
document's XML, but on loading, Writer adds the empty paragraph again.

This situation is common when a table is used to produce the page layout and may
contain the entire document content, e.g. a reference card or catalog.

See the attached document for a demonstration.
Comment 9 Joe Smith 2009-01-01 17:48:15 UTC
Created attachment 59105 [details]
sample document showing problem