Issue 60401 - ux-ctest: Calc does not support all users' strategies regarding sorting data
ux-ctest: Calc does not support all users' strategies regarding sorting data
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: ui
recent-trunk
All All
: P2 trivial (vote)
: ---
Assigned To: oc
issues@sc
:
: 53134 (view as issue list)
Depends on:
Blocks: 15522 72764 99999
  Show dependency treegraph
 
Reported: 2006-01-12 07:32 UTC by hans_werner67
Modified: 2013-08-07 15:14 UTC (History)
11 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
The specification. (63.88 KB, text/plain)
2008-10-27 08:48 UTC, yonggang.mao
no flags Details
update the specification. (63.88 KB, text/plain)
2008-10-28 03:21 UTC, yonggang.mao
no flags Details
The patch file is about i60401#-v1. (46.59 KB, text/plain)
2008-10-28 09:57 UTC, yonggang.mao
no flags Details
The patch file is about i60401#-v2. (29.31 KB, text/plain)
2008-10-30 04:33 UTC, yonggang.mao
no flags Details
The patch file is about i60401#-v2. (29.31 KB, text/plain)
2008-10-30 04:35 UTC, yonggang.mao
no flags Details
The patch file is about i60401#-v3. (29.25 KB, text/plain)
2008-10-30 09:48 UTC, yonggang.mao
no flags Details
update the specification. (117.06 KB, text/plain)
2008-10-30 11:17 UTC, yonggang.mao
no flags Details
The patch file is about i60401#-v4. (29.55 KB, text/plain)
2008-11-19 08:10 UTC, yonggang.mao
no flags Details
Update the specification again. (285.55 KB, text/plain)
2008-11-20 05:58 UTC, yonggang.mao
no flags Details
Update the patch. (36.35 KB, text/plain)
2008-12-03 11:55 UTC, yonggang.mao
no flags Details
Update the specification again. (314.14 KB, text/plain)
2008-12-04 07:38 UTC, yonggang.mao
no flags Details
New version of the Sort Range dialog specification. Replaces "Sorting_StrategyDialog". (247.59 KB, application/vnd.oasis.opendocument.text)
2008-12-10 07:40 UTC, pgan
no flags Details
Update the patch. (38.41 KB, text/plain)
2008-12-19 02:54 UTC, yonggang.mao
no flags Details
Update the patch again. (37.09 KB, text/plain)
2009-03-30 10:13 UTC, yonggang.mao
no flags Details
Update patch again. (36.19 KB, text/plain)
2009-04-06 12:28 UTC, yonggang.mao
no flags Details
Update the patch again. (29.88 KB, text/plain)
2009-04-07 07:23 UTC, yonggang.mao
no flags Details
Update the specification for Sort Range dialog again. (236.49 KB, text/plain)
2009-04-09 04:14 UTC, yonggang.mao
no flags Details
Update the spec again. (236.19 KB, text/plain)
2009-04-16 03:49 UTC, yonggang.mao
no flags Details
Update the patch again. (30.06 KB, text/plain)
2009-04-17 10:07 UTC, yonggang.mao
no flags Details
Update the finial specification. (220.66 KB, text/plain)
2009-04-23 07:33 UTC, yonggang.mao
no flags Details
TestCaseSpecification (16.99 KB, text/html)
2009-07-09 14:42 UTC, oc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hans_werner67 2006-01-12 07:32:26 UTC
Calc does not support all users' strategies regarding sorting data that are
supported by Excel:
Only selecting the column to sort by and then trying to sort, either by clicking
the icon or using the menu entry, results in a user error.

Recommendation: Make more intelligent auto selections.
Comment 1 frank.loehmann 2006-01-30 15:00:49 UTC
Keyword: ux-ctest
Comment 2 frank.loehmann 2006-07-13 16:28:10 UTC
set target to OOo 2.x
Comment 3 frank.loehmann 2007-09-06 16:29:36 UTC
Set target to OOo later.
Comment 4 frank.loehmann 2008-05-22 09:39:25 UTC
This issue is important and listed on the quarterly review for Calc:
http://wiki.services.openoffice.org/wiki/2008_Q2_Review_of_Spreadsheet_Project
Therefore adjusting target to 3.x.
Comment 5 yonggang.mao 2008-10-27 04:05:38 UTC
Accepted
Comment 6 yonggang.mao 2008-10-27 04:06:00 UTC
Started
Comment 7 yonggang.mao 2008-10-27 06:26:07 UTC
*** Issue 53134 has been marked as a duplicate of this issue. ***
Comment 8 yonggang.mao 2008-10-27 08:48:55 UTC
Created attachment 57489 [details]
The specification.
Comment 9 yonggang.mao 2008-10-28 03:21:44 UTC
Created attachment 57516 [details]
update the specification.
Comment 10 yonggang.mao 2008-10-28 09:57:55 UTC
Created attachment 57519 [details]
The patch file is about i60401#-v1.
Comment 11 yonggang.mao 2008-10-30 04:33:24 UTC
Created attachment 57563 [details]
The patch file is about i60401#-v2.
Comment 12 yonggang.mao 2008-10-30 04:35:28 UTC
Created attachment 57564 [details]
The patch file is about i60401#-v2.
Comment 13 yonggang.mao 2008-10-30 09:48:27 UTC
Created attachment 57568 [details]
The patch file is about i60401#-v3.
Comment 14 yonggang.mao 2008-10-30 09:51:47 UTC
modify ID from (SC_DIALOGS_START + 145) to (SC_DIALOGS_START + 147)
Comment 15 yonggang.mao 2008-10-30 11:17:42 UTC
Created attachment 57571 [details]
update the specification.
Comment 16 yonggang.mao 2008-11-19 08:10:31 UTC
Created attachment 58110 [details]
The patch file is about i60401#-v4.
Comment 17 yonggang.mao 2008-11-20 05:58:15 UTC
Created attachment 58131 [details]
Update the specification again.
Comment 18 yonggang.mao 2008-12-03 11:55:20 UTC
Created attachment 58468 [details]
Update the patch.
Comment 19 niklas.nebel 2008-12-03 19:14:16 UTC
The strings "A2:C4" and "B2:B4" in the dialog should be replaced by the actual
ranges (dynamically).
Comment 20 yonggang.mao 2008-12-04 07:38:14 UTC
Created attachment 58492 [details]
Update the specification again.
Comment 21 pgan 2008-12-10 07:40:44 UTC
Created attachment 58671 [details]
New version of the Sort Range dialog specification. Replaces "Sorting_StrategyDialog".
Comment 22 ooo 2008-12-10 15:06:34 UTC
The question which range has to be applied when the user has selected more than
one single cell and cells next to the selection do also contain data, is not
only relevant for sorting.

Same situation is with AutoFilter, DataPilot, AutoFormat,...

Maybe we should not create a "Sort Range Dialog" but a more common "Range
Dialog". For the sake of consistency we should apply the same concept and
similar dialogs to all similar situations.
Comment 23 yonggang.mao 2008-12-19 02:54:05 UTC
Created attachment 58927 [details]
Update the patch.
Comment 24 niklas.nebel 2009-01-13 19:48:52 UTC
The selection of the new range looks good.

There's still the problem that pDocSh->GetDBData modifies the unnamed database
range (even if "cancel" is selected), and your new code is there three times
(should be merged together).
Comment 25 yonggang.mao 2009-03-30 10:13:57 UTC
Created attachment 61272 [details]
Update the patch again.
Comment 26 yonggang.mao 2009-04-06 12:28:30 UTC
Created attachment 61406 [details]
Update patch again.
Comment 27 yonggang.mao 2009-04-06 12:35:12 UTC
I deleted some unuseful call for pDBData->SetArea(...) method in cellsh2.cxx.
Comment 28 niklas.nebel 2009-04-06 18:35:40 UTC
I see one problem now: If the data range (say, B3:C6) has column headers, column
C is selected, and the "Extend selection" button pressed, the sort dialog
doesn't use column headers.

And I really suggest to move the new code - from "if( aSortParam.nCol1 !=
aSortParam.nCol2 )" to "ClearHighlightRanges" - into a helper function, instead
of having it 3 times.
Comment 29 yonggang.mao 2009-04-07 07:23:41 UTC
Created attachment 61419 [details]
Update the patch again.
Comment 30 yonggang.mao 2009-04-07 07:25:19 UTC
According to your suggestion,I have fixed it.
Comment 31 yonggang.mao 2009-04-09 04:14:38 UTC
Created attachment 61466 [details]
Update the specification for Sort Range dialog again.
Comment 32 yonggang.mao 2009-04-16 03:49:15 UTC
Created attachment 61594 [details]
Update the spec again.
Comment 33 yonggang.mao 2009-04-17 10:07:59 UTC
Created attachment 61626 [details]
Update the patch again.
Comment 34 yonggang.mao 2009-04-17 10:09:11 UTC
>Niklas
I used OOom45 version,the WordBreak can work well,I submitted a patch again.
Comment 35 niklas.nebel 2009-04-20 12:43:15 UTC
taking the issue
Comment 36 niklas.nebel 2009-04-20 12:55:36 UTC
I added the last patch, with some small changes to the dialog resource, to CWS
"dr68".
Comment 37 yonggang.mao 2009-04-23 07:33:07 UTC
Created attachment 61747 [details]
Update the finial specification.
Comment 38 niklas.nebel 2009-05-19 09:12:10 UTC
reassigning to QA for verification
Comment 39 oc 2009-07-09 14:42:30 UTC
Created attachment 63454 [details]
TestCaseSpecification
Comment 40 oc 2009-07-09 14:43:24 UTC
verified in internal build cws_dr68
Comment 41 amy2008 2009-07-31 03:56:48 UTC
Verified in DEV300m53 on WinXP.
Works very well
Closing
Comment 42 ooo 2009-12-02 19:41:43 UTC
Reopening. Current implementation in OOO320_m6 and OOO300_m57 violates the
specification!

The specification reads:

"This document specifies a new dialog that will appear if the user invokes the
sort function when the selection contains more than one cell but some cells next
to the selection contain data."

And further:

"If the user selects a range of cells and then invokes the Sort button in the
toolbar or invokes the Data-Sort menu item, but there is data next to the
selected cells, then the user should be asked if s/he wants to sort only the
selected range, or the whole contiguous data range that contains the selection
and all the adjacent cells that contain data .  This is to prevent user errors
where a smaller range is sorted than the user thinks."

However, the current implementation shows the new dialog only if the user´s
selection inside a bigger contiguous range spans only one single column or one
single row. Thus, the specification is not fulfilled. Moreover, the current
implementation does *not* prevent user errors where a smaller range is sorted
than the user thinks, which is the main intention and the origin of the
specified feature.

Adding this issue as blocker of issue 99999 (Release stopper for OOo 3.2)
Comment 43 niklas.nebel 2009-12-03 16:10:29 UTC
The origin of the issue was usability testing, where users selected the column
by which the range was to be sorted.

Special handling of single-column or row selection was mentioned on the list
(http://ux.openoffice.org/servlets/ReadMsg?list=discuss&msgNo=2640), and others
also do it that way, so I think the current behavior is intentional. The spec
should be updated then, or if there is consensus that the behavior isn't good,
it can be changed in a later version. But there's no need to treat this as a 3.2
stopper.
Comment 44 ooo 2009-12-03 18:35:47 UTC
After discussion with nn in IRC we agreed that the implementation differs from
the spec. However, it still is a useful change that should be released with 3.2.

Please follow-up for further improvement with issue #107423.
Comment 45 ooo 2009-12-03 18:37:10 UTC
closing.