Issue 57426 - Wrong default font for Greek, full width Asian font is chosen
Wrong default font for Greek, full width Asian font is chosen
Status: CLOSED FIXED
Product: Internationalization
Classification: Code
Component: ui
OOO 2.0 Beta2
All Linux
: P3 trivial with 2 votes (vote)
: ---
Assigned To: stefan.baltzer
issues@l10n
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-06 13:49 UTC by simos.bugzilla
Modified: 2009-07-13 08:50 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Demonstration of writing Greek with default font (also shows correct version) (125.76 KB, image/png)
2005-11-06 14:08 UTC, simos.bugzilla
no flags Details
Document used to produce the previous screenshot. Has the Greek alphabet with "default" and proper Greek fonts. (6.38 KB, application/vnd.oasis.opendocument.text)
2005-11-06 14:10 UTC, simos.bugzilla
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description simos.bugzilla 2005-11-06 13:49:55 UTC
In a default installation of OpenOffice.org, when you write in Greek (for
example, in Writer), the default font chosen is an Asian full-width font.

This Asian font
1. has Greek characters due to a Japanese/Korean standard requiring them.
2. however it is full width (spacing is to big for western languages)
3. however it lacks characters with accents (they do not appear on screen)

Free/open-source fonts with Greek characters are
1. FreeFonts (FreeSans, FreeSerif, FreeMono), available by default with most
Linux distributions
2. MgOpen fonts (MgOpen Canonica, MgOpen Moderna, MgOpen Cosmetica, MgOpen
Modata), available by default in Ubuntu Linux. Fonts found at
http://www.ellak.gr/fonts/mgopen/

<a
href="http://util.openoffice.org/source/browse/util/officecfg/registry/data/org/openoffice/VCL.xcu">VCL.xcu
</a> does not have a section for Greek. 
Adding such a section and including Greek fonts appears to solve the problem.

However, when you choose from the font menu a font to display greek text, and
this font does not have greek characters, OOo falls back to the Asian font.

According to the last comment at <a
href="http://qa.openoffice.org/issues/show_bug.cgi?id=16746">bug 16746</a>, 

"Greek characters have been treated wrong in the past (as CTL chars) see also
issue 30465. This will finally work in OO.o 1.1.3 (not yet available).
Considering issue as fixed."

I am not sure if there is a regression here.

I have created a custom VCL.xcu which includes a greek font (FreeSans) in every
field for the "en" and "el" sections. When I choose a font that does not have
Greek for some Greek text, the Asia font is chosen.
Comment 1 simos.bugzilla 2005-11-06 14:08:26 UTC
Created attachment 31218 [details]
Demonstration of writing Greek with default font (also shows correct version)
Comment 2 simos.bugzilla 2005-11-06 14:10:40 UTC
Created attachment 31219 [details]
Document used to produce the previous screenshot. Has the Greek alphabet with "default" and proper Greek fonts.
Comment 3 simos.bugzilla 2005-11-06 14:25:54 UTC
Description of screenshot
=========================

I am using the latest Build of OOo, as provided by Pavel, at
ftp://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/SRC680_m137/Build-1/OOo_SRC680_m137_LinuxIntel_install_el_deb.tar.gz
The behaviour is similar to the English build. For example, I get the same
behaviour with Ubuntu 5.10.

a. Lines 1, 2
Here you can notice that characters are missing; there are characters that have
accents on them. The Asian font chosen here conforms to a Japanese/Korean
standard that requires Greek characters, however apparently it does not require
greek characters with accents. There was a discussion on this at the fontconfig
mailing list (http://lists.freedesktop.org/archives/fontconfig/) in September
(due to some issue, archiving of the list stops at August).

b. Lines 3-6 (default font) and 7-10 (FreeSans)
In line 3, the asian font is used for all characters apart from Omega
In line 4, some letters are shown with the asian font.
In line 5, all but pi (π) is shown with the asian font.
In line 6, all but one character is even shown.

In lines 7-10 you can see the correct display of the Greek text corresponding to
3-6.
Comment 4 simos.bugzilla 2005-11-06 14:43:37 UTC
Relevant bugs:

1. https://bugs.freedesktop.org/show_bug.cgi?id=4639
Fontconfig (font configuration in Linux distributions and more) had a bad
preference list for the display of fonts, giving priority to Asian fonts.
This has been fixed. My system has a patched version of the configuration file,
with a fixed preference order.

2. https://bugzilla.ubuntu.com/show_bug.cgi?id=2374
The same bug noted in Ubuntu. There is a long discussion with more details.
Unfortunatelly it does appear to fix the problem.
Comment 5 simos.bugzilla 2005-11-06 18:16:25 UTC
To sum up, the issue here is that when OOo tries to display Greek and the
currently selected font does not have Greek characters, a fallback to an Asian
font takes place which is inappropriate for Modern Greek. I have no idea how to
influence this internal behaviour; this appears to be the core of the problem.

It is possible to get OOo to choose Greek fonts by adding a section for Greek
("el") to VCL.xcu. This would fix the issue when the end-user uses the Greek
locale. However, when the default locale is other than Greek, (such as English,
"en"), and the font does not have Greek characters, the problem appears. This is
a common occurence for different configurations that end-users have.

In fontconfig, we placed free (open-source) fonts with Greek characters higher
than the CJK fonts (see https://bugs.freedesktop.org/show_bug.cgi?id=4639) which
solves the problem. 
How can this be achieved in OOo?
Comment 6 pkst 2006-01-05 08:13:43 UTC
This bug makes the Greek help files unreadable in openoffice 2.0.x in linux. The
font used in the help component does not render the Greek text properly. See
screenshot at http://osdn.dl.sourceforge.net/sourceforge/hop/oohelp.png
Comment 7 pkst 2006-01-05 15:44:27 UTC
Sorry the previous lin is broken:
new link with the screenshot at:
http://ovh.dl.sourceforge.net/sourceforge/hop/oohelp.png
Comment 8 simos.bugzilla 2007-06-23 13:58:06 UTC
This issues has been resolved in the current version of OpenOffice.org.
Close issue.
Comment 9 stefan.baltzer 2009-07-13 08:50:10 UTC
Closed.