Issue 51726 - Shapes in Writer cannot be named via context menu
Shapes in Writer cannot be named via context menu
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: ui
OOo 2.0
All All
: P3 trivial (vote)
: ---
Assigned To: michael.ruess
issues@sw
: accessibility, oooqa
: 27687 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 14:11 UTC by frank.loehmann
Modified: 2013-08-07 14:40 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description frank.loehmann 2005-07-08 14:11:31 UTC
Separate issue for Writer. Please also note same i51351 for Calc.

1. Open a new Writer document
2. Draw a shape
3. Select the shape and open the context menu
--> you cannot name a single shape. Only Groups of shapes can be named

This task is important because shapes that do not have names cannot be utilized
by accessibility tools.

Please see "Naming of drawing objects" section in the following spec. for details:
http://specs.openoffice.org/appwide/accessibility/Accessibility_Issues_For_OpenOffice_2.0.1.odt
Comment 1 Oliver Specht 2005-07-08 14:40:55 UTC
os->mib: Am I wrong or is it still the case that xmloff determines if Writer or
Draw objects (text frames) are imported depending on the 'Name'-property?

Comment 2 lohmaier 2005-07-08 17:18:17 UTC
this issue is duplicate of issue 27687
Comment 3 michael.brauer 2005-08-02 12:55:51 UTC
Currently, its in fact the name that is used to differ between Writer and Daw
text boxes. This could be changed to any other detection mechanism as long as
there is a feature that is only supported by WRiter or by Draw text boxes.
MIB->OD: Please evaluate which feature could be used. Maybe the rotation or
transformation that is only supoorted by Draw text boxes?
Comment 4 Oliver-Rainer Wittmann 2005-08-02 14:06:18 UTC
As discussed with FL and OS this issue is retarget due to limited resources to
OOo 2.0.2

After the evaluation, which "feature" can be used to distinguish Writer objects
and Draw objects - namely graphics and text boxes -, the above given
specification has to be adjusted accordingly.
Comment 5 mdxonefour 2005-09-07 14:57:25 UTC
added keyword accessibility
Comment 6 Oliver-Rainer Wittmann 2006-01-30 13:48:05 UTC
re-target to OOo 2.0.3.
Comment 7 Oliver-Rainer Wittmann 2006-03-13 14:39:33 UTC
Currently, the above given specification is a draft and has to be adjusted.
Beside the change of the context menu and the navigator it's is needed to adjust
the import of the XML file formats (OpenDocument and OpenOffice.org) and the
export to the OpenOffice.org file format. 
The import needs adjustment, because the existence of name is used to
distinguish Writer graphics/text boxes and Draw graphics/text boxes. The new
criterium is now, that Draw graphics/text boxes of Writer documents doesn't have
a parent style.
The export to the OpenOffice.org file format needs adjustment, because a Writer
document in the OpenOffice.org file format doesn't contain names for shapes.

Fixed in cws swa11y203 - changed files:
allow naming of all drawing objects:
/sw/source/ui/shells/drwbasesh.cxx, 1.20.250.1
show named drawing objects in navigator:
/sw/source/ui/utlui/content.cxx, 1.36.176.1
renaming of resource FN_NAME_GROUP and MN_NAME_GROUP:
/sw/inc/cmdid.h, 1.68.118.1
/sw/ui/inc/localize.sdf, 1.20.54.1
/sw/ui/app/mn.src, 1.44.118.1
/sw/ui/app/localize.sdf, 1.17.54.1
/sw/sdi/_drwbase.sdi, 1.4.254.1
/sw/sdi/swriter.sdi, 1.63.118.1
/sw/sdi/swslots.src, 1.126.118.1
/sw/sdi/localize.sdf, 1.16.54.1
distinguish Writer graphics/text boxes and Draw graphics/text boxes in
OpenDocument file format:
/xmloff/source/text/XMLTextFrameContext.hxx, 1.22.88.1
/xmloff/source/text/XMLTextFrameContext.cxx, 1.66.88.1
export of shape name for text documents, except for group shapes, only if
OpenDocument file format is written.
/xmloff/inc/xmlexp.hxx, 1.60.90.1
/xmloff/source/core/xmlexp.cxx, 1.120.90.1
/xmloff/source/draw/shapeexport.cxx, 1.72.90.1
Comment 8 frank.loehmann 2006-03-13 17:05:56 UTC
Please find the most current spec. here:
http://specs.openoffice.org/appwide/accessibility/Naming_Drawing_Objects_in_Writer_and_Calc.odt
Comment 9 Oliver-Rainer Wittmann 2006-03-14 07:56:52 UTC
reopen, becaue the string for the naming dialog in Writer have to be changed.
Comment 10 Oliver-Rainer Wittmann 2006-03-14 10:25:36 UTC
adjust string of naming dialog - changed files:
/sw/source/ui/inc/shells.hrc, 1.9.254.1
/sw/source/ui/shells/shells.src. 1.49.236.1
/sw/source/ui/shells/drwbassh.cxx, 1.20.250.2
/sw/source/ui/shells/localize.sdf, 1.14.106.1

improve xml export (adjust new interface of class <SvXMLExport>:
/xmloff/inc/xmlexp.hxx, 1.60.90.2
/xmloff/source/core/xmlexp.cxx, 1.120.90.2
/xmloff/source/draw/shapeexport.cxx, 1.72.90.2
Comment 11 Oliver-Rainer Wittmann 2006-03-17 07:55:43 UTC
OD->MRU: Checked in internal installation set of cws swa11y203 - please verify.
Comment 12 Oliver-Rainer Wittmann 2006-03-17 07:57:09 UTC
assign to MRU
Comment 13 Oliver-Rainer Wittmann 2006-03-17 07:58:01 UTC
set status back to FIXED.
Comment 14 michael.ruess 2006-03-21 10:44:08 UTC
Verified fix in CWS swa11y203.
Comment 15 michael.ruess 2006-03-31 15:01:30 UTC
Checked in build 680m161.
Comment 16 lohmaier 2006-04-03 13:25:45 UTC
*** Issue 27687 has been marked as a duplicate of this issue. ***