Issue 51638 - patch to implement a mailmerge email component for OOo
patch to implement a mailmerge email component for OOo
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: code
680m114
All All
: P3 trivial (vote)
: ---
Assigned To: Martin Hollmichel
issues@sw
:
: 11244 14706 (view as issue list)
Depends on: 51637
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-06 12:55 UTC by caolanm
Modified: 2013-08-07 14:42 UTC (History)
15 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
patch to implement (18.25 KB, patch)
2005-07-06 12:56 UTC, caolanm
no flags Details | Diff
additional bit (563 bytes, patch)
2005-07-06 18:45 UTC, caolanm
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description caolanm 2005-07-06 12:55:18 UTC
as described, patch attached to implement a simple email componenent to
facilitate email mail merge in writer
Comment 1 caolanm 2005-07-06 12:56:55 UTC
Created attachment 27745 [details]
patch to implement
Comment 2 caolanm 2005-07-06 13:06:53 UTC
caolanm->ama: Here's something which should suffice (the simple case tested so
far) as an email component for mail-merge for OpenOffice.org (as opposed to the
existing solution for StarOffice)
Comment 3 kami911 2005-07-06 13:43:40 UTC
Yeah!
Great news!
I wanted to leave message on your blog, but I can't. This patch must be extend
and integrate as soon as possible.
Here is my vote :o)
Comment 4 andreas.martens 2005-07-06 13:44:07 UTC
AMA->OS: Please have a look.
Comment 5 kami911 2005-07-06 13:46:01 UTC
Please check this issue: http://www.openoffice.org/issues/show_bug.cgi?id=11244
They talk about very same thing.
Comment 6 Oliver Specht 2005-07-06 14:02:27 UTC
->mba: Is it the right place to put this into /cvs/framework/scripting as
suggested by the patch?
Comment 7 Mathias_Bauer 2005-07-06 17:08:21 UTC
This part of the scripting framework code is not maintained by us, but by our
well-known former mate Jörg Budischewski. So every patch in PyUNO and/or (as
her) the scripting provider for PyUNO should be discussed with him.
Comment 8 caolanm 2005-07-06 18:45:32 UTC
Created attachment 27752 [details]
additional bit
Comment 9 Oliver Specht 2005-07-07 08:07:38 UTC
->jbu: So how about putting the code into /cvs/framework/scripting?
Comment 10 lohmaier 2005-07-07 13:26:21 UTC
*** Issue 11244 has been marked as a duplicate of this issue. ***
Comment 11 grsingleton 2005-07-07 13:42:09 UTC
added cc
Comment 12 joergbudi 2005-07-07 20:13:54 UTC
Hi,

the patch should work and it is the easiest way to integrate it into ooo.

But in general, one should group components by semantics and not by
implementation language.

So if I would need to decide, I'd place the components somewhere, where also a c++
mailmerge component would be placed. There it just needs to be copied into bin
output tree and d.lst needs to be modified to export .py files to solver

In scp2, one can then also add the component in the scp2/source/writer module
instead of the scp2/source/python
module. 

However, I don't mind to keep the patch as it is currently, so I would leave
the decision up to you.

Feel free to ask in case there is something unclear.

Bye,

Joerg

Comment 13 kami911 2005-07-23 14:56:23 UTC
When it can be the part of official distribution? I would happy with 2.0 or 2.0.1
Comment 14 ecastro 2005-09-04 10:17:30 UTC
Hi
I have readed discussions in #11244. And I must re-state that this feature was
present in OOo pre 1.1.x. We all were promised that OOo 2.0 will include it. The
target milestone MUST be 2.0 final, not something like 2.0.1

As o OOo2.0b2 (m125) the "e-mail message" button appears in teh Mail merge
wizard. But there is no mailmerge.py included with teh regular distribution,
neither installing JavaMail will activate it.

Just a comment: activating this button requires to manually edit the
~/.openoffice.org2/user/registry/data/org/openoffice/Office/Writer.xcu
file to set EMailSupported option
+#  <prop oor:name="EMailSupported" oor:type="xs:boolean">
+#   <value>true</value>
+#  </prop>

This is not acceptable for regular use. Thsi is more on the category of "hack".
In addition, this hack will work for a single user, should be repeated for all
users in the machine.

If you want to consider EMailSupported as a selectable option, there should be a
proper "option entry" in the regular OOo Options page for normal users to set
on/off.

Enrique 
Comment 15 Martin Hollmichel 2005-09-04 18:27:59 UTC
@cmc: will you take action to open a cws for this to integrate this in OOo ?
Comment 16 caolanm 2005-09-05 08:15:35 UTC
I'm willing to do so,
Comment 17 caolanm 2005-09-09 09:35:24 UTC
oooemailmerge workspace
Comment 18 caolanm 2005-09-13 10:30:45 UTC
Added in workspace oooemailmerge.
http://ooomisc.services.openoffice.org/pub/OpenOffice.org/cws/upload/oooemailmerge/
I'm not certain I have the windows packaging correct.

ecastro's point is valid I think, but not addressed here. If a user has started
writer and played with the email mailmerge and the python of java solution is
not available the user config is set as not supporting it. Installing a
systemwide solution afterwards will be ignored. That should affect both the
staroffice solution as well as the openoffice.org one if I understand correctly,
so not specific to this backend addition.
Comment 19 caolanm 2005-09-13 10:31:18 UTC
done in oooemailmerge
Comment 20 eberlein 2005-11-01 12:30:48 UTC
We are coming closer to 2.0.1...
Any news about the Windows build?

Peter
Comment 21 hummusman 2005-11-03 09:18:27 UTC
well i downloaded 2.0 expectantly yesterday and it didn't work -

even installing javamail.

so anyway

accidentally stumbled across some stuff

and then got it to work!!

actually it's the same patch as above - but can be installed without 
recompiling patched source code.

it requires - copying python script to OOo program folder, running "unopkg" 
from command line to add it to OOo - then editing one value in obscure 
file "Writer.xcu" - 

i made a doc with complete instructions -

http://internet.cybermesa.com/~aaron_w/OOo_email_merge/OOo_email_merge.html

until this makes it into release, i'm a very happy camper that i got this to 
work at all - this has been out there apparently since july, with several 
others using it successfully, but I just found out about it now and wanted to 
share the news.

peace

aaron w
Comment 22 hummusman 2005-11-03 09:26:33 UTC
Thank you caolan for this.  I only wish someone would have put these 
instructions on here sooner, and answered somewhere what was up with this 
feature not working - so so many of us wouldn't have been pulling our hair out 
dicking with javamail in futility.
Comment 23 lohmaier 2005-11-09 22:13:28 UTC
*** Issue 14706 has been marked as a duplicate of this issue. ***
Comment 24 Martin Hollmichel 2005-11-10 17:45:27 UTC
verified (reported by hi).
Comment 25 caolanm 2005-11-18 19:29:45 UTC
closed, in m401, but see issue 58137
Comment 26 dalo 2007-02-19 21:18:51 UTC
Using OOo2.1 On XP

DEFECT - sorry not the privileges
OPEN

In OOo2.1 mail merge using Mail is not visible or configurable.
I refuse to do the hack patch mystery as I am a 'regular' user-trainer.
I'll have to inform my trainees that mail merge mail is apparently not available
to OOo Standard Version.
Comment 27 grsingleton 2007-02-19 22:20:14 UTC
=> dalo 
I think you have a XP configuration problem. I cannot reproduce what you claim
and the errors you have reported look to me like Windows errors. 2.1,
out-of-the-box mailmerge works very well.  If fixing permissions for your user
does not help open a new issue.
Comment 28 lohmaier 2007-03-06 16:09:16 UTC
as the mailmerge-component is written in python, you won't get it if you disable
the pyuno runtime during setup. So check whether you got pyuno installed (if you
can run any of the python-hello-world macros, then everything should be there
and you should file a new issue with a more detailed explanation of the problem.
If you don't see any python Macros, then install pyuno and try again.

Tools|Macros → run → OOo Macros → HelloWorld → HelloWorldPython and/or
Tools|Macros → run → OOo Macros → pythonSamples → TableSample → createTable