Issue 49174 - gengal: Utility to generate OO.o gallery files
gengal: Utility to generate OO.o gallery files
Status: CLOSED FIXED
Product: Draw
Classification: Application
Component: code
680m100
PC Linux
: P3 trivial (vote)
: OOo 2.0.1
Assigned To: wolframgarten
issues@graphics
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 18:01 UTC by pmladek
Modified: 2005-11-14 12:28 UTC (History)
4 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
The basic version of the utility (18.66 KB, patch)
2005-05-12 18:02 UTC, pmladek
no flags Details | Diff
This patch adds the --destdir option (8.00 KB, patch)
2005-05-12 18:03 UTC, pmladek
no flags Details | Diff
This patch adds the --number-from option instead of the uglu --num option. Also it cleans the shell wrapper. (13.05 KB, patch)
2005-05-12 18:04 UTC, pmladek
no flags Details | Diff
This patch allows to build gengal with gcc4 (1.75 KB, patch)
2005-05-12 18:05 UTC, pmladek
no flags Details | Diff
This patch adds the new source file, wrapper and makefile (17.95 KB, patch)
2005-05-16 12:27 UTC, pmladek
no flags Details | Diff
This patch includes the necessary changes in the core code of the svx module (9.26 KB, patch)
2005-05-16 12:28 UTC, pmladek
no flags Details | Diff
This patch includes the necessary changes in the scp2 module (1.24 KB, patch)
2005-05-16 12:29 UTC, pmladek
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description pmladek 2005-05-12 18:01:07 UTC
Michael Meeks and me created a commandline tool, which allows to generare and
update OOo galleries from given bitmaps.

The tool consists of the following files:
<OOO_HOME>/program/gengal        # only on Linux
<OOO_HOME>/program/gengal.bin
<OOO_HOME>/program/gengal.rdb

It provides the follwing functionality:

$ <OOO_HOME>/program//gengal --help
Utility to generate OO.o gallery files

using: gengal --name <name> --path <dir> [ --destdir <path> ]
              [ --number-from <num> ] [ files ... ]

options:
 --name <theme>         defines a name of the created or updated theme.
 --path <dir>           defines directory where the gallery files are created
                        or updated.
 --destdir <dir>        defines a path prefix to be removed from the paths
                        stored in the gallery files. It is useful to create
                        RPM packages using the BuildRoot feature.
 --number-from <num>    defines minimal number for the newly created gallery
                        theme files.
 files                  lists files to be added to the gallery. Absolute paths
                        are required.


I will attach 4 patches. The tool was developed in some stages. I did not merge
the changes because you might not like a particular feature and the separate
patches would be helpful then :-)

1st patch provides basic version of the tool. It does not provide the
possibility to define the destdir and there is an ugly option --num implemented
in the shell script

2nd path adds the option --destir

3rd patch adds the option --num-from instead of the ugly --num option. Also
it cleans up the shell wrapper.

4th path allows to build gengal with gcc-4.0. It makes the necessary symbols
visible.

I am open for any reminders and can rework the patches on request.
Comment 1 pmladek 2005-05-12 18:02:40 UTC
Created attachment 26071 [details]
The basic version of the utility
Comment 2 pmladek 2005-05-12 18:03:36 UTC
Created attachment 26072 [details]
This patch adds the --destdir option
Comment 3 pmladek 2005-05-12 18:04:47 UTC
Created attachment 26073 [details]
This patch adds the --number-from option instead of the uglu --num option. Also it cleans the shell wrapper.
Comment 4 pmladek 2005-05-12 18:05:27 UTC
Created attachment 26074 [details]
This patch allows to build gengal with gcc4
Comment 5 wolframgarten 2005-05-13 08:01:45 UTC
Reassigned. Please handle.
Comment 6 mmeeks 2005-05-13 12:23:39 UTC
Petr - the patch set looks a little confusing - even to me :-)

Any chance you can re-generate it splitting it, so the patches are not incremental:

ie. re-generate new files vs. /dev/null, and split out the pieces that patch the
core code ?

The core changes to svx/ are really rather trivial here, it's a shame to hide
that fact :-)
Comment 7 pmladek 2005-05-16 12:24:20 UTC
OK, I have re-merged the four patches and created another 3 patches that are not
incremental.
Comment 8 pmladek 2005-05-16 12:27:04 UTC
Created attachment 26193 [details]
This patch adds the new source file, wrapper and makefile
Comment 9 pmladek 2005-05-16 12:28:25 UTC
Created attachment 26194 [details]
This patch includes the necessary changes in the core code of the svx module
Comment 10 pmladek 2005-05-16 12:29:11 UTC
Created attachment 26195 [details]
This patch includes the necessary changes in the scp2 module
Comment 11 kami911 2005-07-17 10:11:51 UTC
Is it currently part of official source or it will be part?
Comment 12 mmeeks 2005-07-18 11:43:25 UTC
kami - well of course I'd love to see this in 2.0.x - and since the core changes
are really rather minimal / trivial - I don't see why that shouldn't happen.

Re-targetting to 2.0.1 - hope that's ok. It'd be nice to have some up-stream
comment.
Comment 13 clippka 2005-08-03 14:24:05 UTC
I will add this patch to OOo 2.0.1 in cws impress58
Comment 14 clippka 2005-08-03 16:03:41 UTC
I can't build your patch, I get the following error when linking svx

gengal.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) pu
blic: static unsigned char __cdecl ucb::ContentBroker::initialize(class com::sun
::star::uno::Reference<class com::sun::star::lang::XMultiServiceFactory> const &
,class com::sun::star::uno::Sequence<class com::sun::star::uno::Any> const &)" (
__imp_?initialize@ContentBroker@ucb@@SAEABV?$Reference@VXMultiServiceFactory@lan
g@star@sun@com@@@uno@star@sun@com@@ABV?$Sequence@VAny@uno@star@sun@com@@@4567@@Z
) referenced in function "public: virtual void __thiscall GalApp::Main(void)" (?
Main@GalApp@@UAEXXZ)
..\..\wntmsci10\bin\gengal.bin.exe : fatal error LNK1120: 1 unresolved externals
Comment 15 pmladek 2005-08-03 16:58:18 UTC
What milestone do you use for your build? Do you use gcc4 with the visibility
feature?
Comment 16 clippka 2005-08-03 17:04:16 UTC
I use milestone m118 with windows non pro
Comment 17 mmeeks 2005-08-03 17:18:54 UTC
I imagine that the Win32 linker is more pernickerty about deps.

Can you add $(UCBHELPERLIB) to the APP1STDLIBS in svx/source/gengal/makefile.mk
and try again ? - I guess there may be a couple of other missing pieces in there
too.

Sorry for the pain - we don't see that on Linux.
Comment 18 clippka 2005-08-05 12:53:27 UTC
Ok that did it,

I also had to change
regcomp [blablabla]
			-c libfwl$(UPD)$(DLLSUFFIX)$(DLLPOST) \
			-c libucpfile1$(DLLPOST) \
			-c libfileacc$(DLLPOST) \
			-c libucb1$(DLLPOST)
to
			-c $(DLLPRE)fwl$(UPD)$(DLLSUFFIX)$(DLLPOST) \
			-c $(DLLPRE)ucpfile1$(DLLPOST) \
			-c $(DLLPRE)fileacc$(DLLPOST) \
			-c $(DLLPRE)ucb1$(DLLPOST)

a simple compile on at least one windows and one unix plattform for patches
would be nice in the future.

Anywhay, if this patch doesnt break any regression tests on my cws, consider it
done for OOo 2.0.1
Comment 19 clippka 2005-08-05 17:03:50 UTC
sources commited on branch for cws impress58
Comment 20 mmeeks 2005-08-08 10:37:47 UTC
cool - thanks :-)
Of course - with this utility in place, we can tweak a number of other things
more easily: extending the web-export gallery stuff automatically, etc. and
reduce our patch-set yet further which will be great.

Thanks again.
Comment 21 clippka 2005-08-16 16:07:05 UTC
patch verified in cws.

@cl->wg, please verify that our normal gallery feature is not harmed by this
patch. Please test creation and handling of user themes and also drag'n'drop
from to gallery.

re-open issue and reassign to wg@openoffice.org
Comment 22 clippka 2005-08-16 16:07:14 UTC
reassign to wg@openoffice.org
Comment 23 clippka 2005-08-16 16:07:22 UTC
reset resolution to FIXED
Comment 24 wolframgarten 2005-08-18 11:39:00 UTC
Verified in CWS.
Comment 25 wolframgarten 2005-11-14 12:28:11 UTC
Closed.