Issue 48012 - Calc: chattype 'interpolated' is missing
Calc: chattype 'interpolated' is missing
Status: CONFIRMED
Product: General
Classification: Code
Component: chart
OOo 3.3 or older
All All
: P4 minor (vote)
: ---
Assigned To: AOO issues mailing list
:
: 71735 109228 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-23 10:02 UTC by stefantiger
Modified: 2014-02-28 12:46 UTC (History)
4 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation on: 4.1-dev
Developer Difficulty: ---


Attachments
XY-diagram with lines only (17.60 KB, image/png)
2006-03-08 20:15 UTC, stefantiger
no flags Details
XY-diagram with cubic spline interpolation (17.12 KB, image/png)
2006-03-08 20:16 UTC, stefantiger
no flags Details
XY-diagram with interpolation issue (16.40 KB, application/vnd.sun.xml.calc)
2006-03-08 20:17 UTC, stefantiger
no flags Details
Comparison LibreOffice and Excel (98.71 KB, image/png)
2013-02-08 11:37 UTC, stefantiger
no flags Details
Calc 4.1 vs. Excel 2010 (160.34 KB, image/png)
2014-02-28 11:51 UTC, Edwin Sharp
no flags Details
Smooth lines: Excel 2010 vs. Calc 4.1 (64.05 KB, image/png)
2014-02-28 12:45 UTC, Edwin Sharp
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description stefantiger 2005-04-23 10:02:57 UTC
In calc a chattype 'interpolated' is missing. The 'spline'-type don't satisfy. 
Look in MS-Excel for it and how it works. 
 
It's important for technical dokumentations.
Comment 1 kla 2005-04-27 09:37:14 UTC
reassign
Comment 2 IngridvdM 2006-03-08 19:17:57 UTC
Could you please give a more detailed description? Are both spline types not
sufficient for you? And why not. Which version of Excel do you refer to? Thanks
a lot.
Comment 3 stefantiger 2006-03-08 20:15:16 UTC
Created attachment 34679 [details]
XY-diagram with lines only
Comment 4 stefantiger 2006-03-08 20:16:17 UTC
Created attachment 34680 [details]
XY-diagram with cubic spline interpolation
Comment 5 stefantiger 2006-03-08 20:17:33 UTC
Created attachment 34681 [details]
XY-diagram with interpolation issue
Comment 6 stefantiger 2006-03-08 20:18:56 UTC
For many cases the cubic-spline is fine. 
 
I have no Excel at the moment, but I found the oo-clac file in which I had 
this issue. I made 2 Screenshots and a seperat calc-file in which is only this 
issue. 
 
Please see attechments. 
 
Thanks. 
Comment 7 IngridvdM 2006-05-18 15:41:20 UTC
Ok, thanks Stefan. I see that the smooth lines in Excel look diffferent from
B-Splines or Cubic-Splines. Do you or anybody know how they are calculated in
Excel. Or do you or anyone has special expectations for the functions used for
calculating the interpolation? Thanks.
Comment 8 Regina Henschel 2007-07-18 17:28:16 UTC
With the new parametric method for cubic splines (issue 13699) your example
looks much better, but it is not the same as in Excel. You might say that Excel
does it still nicer.

I've looked a little bit around in the internet. There seems to be no "official"
site, which describes the Excel way. But people think, that the way Dr. Brian T.
Murphy (Rotating Machinery Analysis, Inc.) does it in his macro solves the
problem. The macro is included in the file
http://www.xlrotor.com/smooth_curve_bezier_example_file.zip
from
http://www.xlrotor.com/resources/files.shtml
or
http://www.xlrotor.com/excel_stuff.htm

The description is inside the macro. He writes, that he uses Bézier curves. I
have not examined the code yet. The example in the file also works with other 4
points. To run the macro on my German Excel 97 I had to replace the
round(something) function with int(something+0.5).

Would it be possible legally to adapt that code to OOo?
Comment 9 IngridvdM 2007-10-12 16:21:17 UTC
*** Issue 71735 has been marked as a duplicate of this issue. ***
Comment 10 Regina Henschel 2010-02-17 23:04:34 UTC
*** Issue 109228 has been marked as a duplicate of this issue. ***
Comment 11 Rob Weir 2013-02-02 02:54:54 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 12 stefantiger 2013-02-08 11:35:54 UTC
Now, after approximately 7 years since the report, I have re-drawn the diagrams in LibreOffice Calc 3.6.4.3 and Excel 2007.

I have seens there are now several options in LibreOffice about interpolation. I tried several settings there. Unfortunately no setting draws it as nice as Excel does. For comparison I have attached a screenshot.

I have not seen any options about interpolation in Excel. Why are options in LibreOffice necessary?

As I have also attached 2006 the data of the diagrams everybody can use them to re-draw the diagrams in any program for other comparisons. So I would only mark this as resolved if the interpolation between Excel and LibreOffice (or OpenOffice; does not matter) look really identical.
Comment 13 stefantiger 2013-02-08 11:37:12 UTC
Created attachment 80235 [details]
Comparison LibreOffice and Excel
Comment 14 Edwin Sharp 2014-02-28 11:51:25 UTC
Created attachment 82755 [details]
Calc 4.1 vs. Excel 2010

Save as xls of attachment 34681 [details]
Comment 15 Edwin Sharp 2014-02-28 12:45:39 UTC
Created attachment 82756 [details]
Smooth lines: Excel 2010 vs. Calc 4.1
Comment 16 Edwin Sharp 2014-02-28 12:46:30 UTC
Confirmed with
AOO410m14(Build:9760)  -  Rev. 1572807
Rev.1572807
Win 7