Issue 4039 - better automatic positions for labels on pie segments
better automatic positions for labels on pie segments
Status: CLOSED FIXED
Product: General
Classification: Code
Component: chart
OOo 3.3 or older
PC All
: P3 trivial (vote)
: ---
Assigned To: kla
issues@graphics
: ms_interoperability, oooqa, usability
: 13652 (view as issue list)
Depends on: 63857
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-15 12:53 UTC by armek
Modified: 2013-02-24 21:21 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
example doc (39.45 KB, application/vnd.oasis.opendocument.spreadsheet)
2007-11-06 19:12 UTC, IngridvdM
no flags Details
Testdocument for BestFit (58.98 KB, application/vnd.sun.xml.calc)
2007-11-08 12:42 UTC, kla
no flags Details
Testcasespecification (30.86 KB, text/html)
2007-11-09 12:48 UTC, kla
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description armek 2002-04-15 12:53:31 UTC
I've been using the program at work for a couple of years now.  I generate a 
monthly report displaying returned goods according to responsibility in a pie 
chart.

The problem is that with many 'pie wedges' the text labels overlap each other 
and become useless.  I'm only an observer with no programming knowledge, but 
I'd love to see the ability to shift the order of the pie slices to make them 
easier to see. There should also be a function to make the text labels 
automatically spread out with lines connecting them to their associated wedges.

Right now I have to reveal a single slice's text label, write down it's value, 
hide it, and then do the same for each adjacent slice.  Then I activate the 
text labels that don't overlap others.  Finally I add individual text boxes and 
draw lines to the associated wedges.  Not too bad until I resize the chart and 
have to change the font size of each added text box.

Thanks,
Ric
Comment 1 peter.junge 2002-04-15 13:13:53 UTC
Hi Björn,
1 4 U.
Peter
Comment 2 bjoern.milcke 2002-04-15 14:12:04 UTC
This is an issue for the new chart implementation.
Comment 3 bjoern.milcke 2004-08-03 12:31:33 UTC
issue is not resolved but will be done later (thus the OOo Later Target)
Comment 4 bjoern.milcke 2004-08-03 12:32:04 UTC
accepted
Comment 5 IngridvdM 2005-04-26 09:56:29 UTC
set keyword, type and changed summary for better readability
Comment 6 IngridvdM 2005-04-26 10:48:56 UTC
*** Issue 13652 has been marked as a duplicate of this issue. ***
Comment 7 IngridvdM 2006-03-17 18:54:22 UTC
iha->bm: I'll take this issue.
Comment 8 IngridvdM 2006-03-17 18:55:19 UTC
.
Comment 9 IngridvdM 2006-03-17 18:55:57 UTC
accepted
Comment 10 IngridvdM 2007-04-03 17:55:32 UTC
changed target to 2.3
Comment 11 IngridvdM 2007-06-19 13:51:30 UTC
changed target to 2.x
Comment 12 IngridvdM 2007-09-12 10:01:44 UTC
adapting target
Comment 13 IngridvdM 2007-11-06 19:10:47 UTC
Fixed in CWS chart17.
I implemented an algorithm that moves away overlapping labels.
Labels that are more on top or more below are moved to the left or right.
Labels that are more on the left or right side are moved in direction to the top
or to the bottom.
If enough space is available in the according direction on the chart page the
labels are moved thus they don't overlap anymore.
I'll attach a test document to show which scenarios now should be displayed
without overlaps.
When labels are moved they are connected with lines to the corresponding piece.
The line color is equal to the text color of the label. When the line is shorter
than about 5percent of the length of the diagonal of the whole chart the line is
not drawn as so short lines don't look good.
Comment 14 IngridvdM 2007-11-06 19:12:38 UTC
Created attachment 49476 [details]
example doc
Comment 15 IngridvdM 2007-11-06 19:14:15 UTC
->Thomas, please verify in CWS chart17.
Comment 16 kla 2007-11-08 12:42:44 UTC
Created attachment 49522 [details]
Testdocument for BestFit
Comment 17 kla 2007-11-09 12:48:15 UTC
Created attachment 49553 [details]
Testcasespecification
Comment 18 kla 2007-11-09 12:50:02 UTC
seen ok in cws chart17, tcs written -> verified
Comment 19 kla 2008-06-13 12:47:02 UTC
seen ok in current master -> closed