Issue 39914 - MAc OSX m67 automation breaks main function missing
MAc OSX m67 automation breaks main function missing
Status: CLOSED DUPLICATE of issue 39927
Product: porting
Classification: Code
Component: code
680m67
PowerPC Mac OSX, all
: P3 trivial (vote)
: ---
Assigned To: eric.bachard
issues@porting
:
Depends on:
Blocks: 42382
  Show dependency treegraph
 
Reported: 2005-01-04 23:48 UTC by eric.bachard
Modified: 2005-02-09 22:38 UTC (History)
3 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
M&c OSX m67 automation part 1 (605 bytes, patch)
2005-01-04 23:52 UTC, eric.bachard
no flags Details | Diff
Mac OSX m67 automation part 2 (554 bytes, patch)
2005-01-04 23:52 UTC, eric.bachard
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description eric.bachard 2005-01-04 23:48:26 UTC
Build of SRC680 m67 on Mac OSX / gcc-3.3 XCode1.5 (latest)

breaks in automation  module

A log :

Making: ../unxmacxp.pro/bin/testtool
unx
gcc -Wl,-multiply_defined,suppress -bind_at_load -L../unxmacxp.pro/lib
-L/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib -L/usr/lib
-L/usr/X11R6/lib -o ../unxmacxp.pro/bin/testtool -dylib_file
@executable_path/libuno_cppuhelpergcc3.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libuno_cppuhelpergcc3.dylib
-dylib_file
@executable_path/libuno_sal.dylib.3:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libuno_sal.dylib.3
-dylib_file
@executable_path/libstlport_gcc.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libstlport_gcc.dylib
-dylib_file
@executable_path/libuno_cppu.dylib.3:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libuno_cppu.dylib.3
-dylib_file
@executable_path/libtl680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libtl680mxp.dylib
-dylib_file
@executable_path/libucbhelper3gcc3.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libucbhelper3gcc3.dylib
-dylib_file
@executable_path/libuno_cppuhelpergcc3.dylib.3:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libuno_cppuhelpergcc3.dylib.3
-dylib_file
@executable_path/libuno_salhelpergcc3.dylib.3:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libuno_salhelpergcc3.dylib.3
-dylib_file
@executable_path/libvos3gcc3.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libvos3gcc3.dylib
-dylib_file
@executable_path/libbasegfx680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libbasegfx680mxp.dylib
-dylib_file
@executable_path/libutl680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libutl680mxp.dylib
-dylib_file
@executable_path/libcomphelp4gcc3.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libcomphelp4gcc3.dylib
-dylib_file
@executable_path/libsvt680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libsvt680mxp.dylib
-dylib_file
@executable_path/libtk680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libtk680mxp.dylib
-dylib_file
@executable_path/libvcl680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libvcl680mxp.dylib
-dylib_file
@executable_path/libsot680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libsot680mxp.dylib
-dylib_file
@executable_path/libicuuc.dylib.26:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libicuuc.dylib.26
-dylib_file
@executable_path/libicudata.dylib.26:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libicudata.dylib.26
-dylib_file
@executable_path/libicule.dylib.26:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libicule.dylib.26
-dylib_file
@executable_path/libjvmaccessgcc3.dylib.3:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libjvmaccessgcc3.dylib.3
-dylib_file
@executable_path/libsvl680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libsvl680mxp.dylib
-dylib_file
@executable_path/libj680mxp_g.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libj680mxp_g.dylib
-dylib_file
@executable_path/libso680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libso680mxp.dylib
-dylib_file
@executable_path/libsb680mxp.dylib:/Users/ericb/Desktop/OpenOffice.org680/solver/680/unxmacxp.pro/lib/libsb680mxp.dylib
-lapp -lsample -luno_cppuhelpergcc3 -ltl680mxp -lutl680mxp -lsvt680mxp
-lsvl680mxp -lvcl680mxp -luno_sal -lj680mxp_g -lvos3gcc3 -lso680mxp
-lucbhelper3gcc3 -lcomphelp4gcc3 -lsot680mxp -lsb680mxp -lvos3gcc3 -lvos3gcc3
-luno_sal -lsb680mxp -luno_cppu -luno_cppu -lapp -lsample -lpthread -lm
-lstlport_gcc -lstdc++ -filelist ../unxmacxp.pro/misc/testtool.list
ld: Undefined symbols:
_main
dmake:  Error code 1, while making '../unxmacxp.pro/bin/testtool'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making
/Users/ericb/Desktop/OpenOffice.org680/automation/util
dmake:  Error code 1, while making 'build_all'
'---* tg_merge.mk *---'


Under Mac OS X, main function *must exist* in an executable. just add this
function make
gcc happy  :-)

These 2 patches are from Kevin Hendricks (one for testtool , one for miniapp,
breaking the build  with the same error type)
Comment 1 eric.bachard 2005-01-04 23:52:18 UTC
Created attachment 21071 [details]
M&c OSX m67 automation part 1
Comment 2 eric.bachard 2005-01-04 23:52:50 UTC
Created attachment 21072 [details]
Mac OSX m67 automation part 2
Comment 3 pavel 2005-02-08 08:31:18 UTC
Duplicate of #i39927#.


*** This issue has been marked as a duplicate of 39927 ***
Comment 4 pavel 2005-02-09 22:38:59 UTC
.