Issue 33681 - In html, tfoot content displayed above tbody content.
In html, tfoot content displayed above tbody content.
Status: CONFIRMED
Product: Writer
Classification: Application
Component: formatting
OOo 1.1.1
All All
: P3 trivial with 2 votes (vote)
: ---
Assigned To: AOO issues mailing list
http://home.swiftdsl.com.au/~jolyon/a...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-01 10:45 UTC by jolyon
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Minimal example of the OOo table bug (368 bytes, text/html)
2004-09-01 10:52 UTC, jolyon
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jolyon 2004-09-01 10:45:27 UTC
In html files, when a table is displayed,
thead is displayed above tbody (OOo displays it correctly)
tfoot should be displayed below tbody (OOo displays it above tbody)
Recent browsers (Firefox, IE, Opera) do this correctly.

Few websites currently use thead, tfoot and tbody sections of tables, but they
will become more important in xhtml as the tfoot allows you to repeat table
header and footer for each printed page, or have scrollable table contents with
thead and tfoot always visible.

I suspect that this is an issue across platforms and versions.

Example page at the URL listed above.
Comment 1 jolyon 2004-09-01 10:52:07 UTC
Created attachment 17469 [details]
Minimal example of the OOo table bug
Comment 2 michael.ruess 2004-09-01 10:55:32 UTC
MRU->ES: please investigate.
Comment 3 eric.savary 2004-09-01 12:56:41 UTC
Open the attach document in OOo
-> it shows:
Table Header
Table Footer
Row One
Row Two
Row Three

which is wrong.

Mozilla (for instance) displays:
Table Header
Row One
Row Two
Row Three
Table Footer

which is correct.
Comment 4 volker_d 2007-06-28 12:59:52 UTC
Still a bug here.
OpenOffice 2.2.0 doesn´t display tfoot.