Issue 328 - $SRC/external directories require gnu tar - not standard on irix
$SRC/external directories require gnu tar - not standard on irix
Status: CLOSED NOT_AN_ISSUE
Product: porting
Classification: Code
Component: documentation
614
SGI IRIX
: P3 trivial (vote)
: ---
Assigned To: Unknown
issues@www
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-26 14:04 UTC by issues@www
Modified: 2008-03-24 12:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description issues@www 2001-01-26 14:04:44 UTC
I've encountered this situation with at least the external/glibc and
external/jpeg areas.	

When running the glibcpatch.sh script, the tarballs aren't getting extracted,
therefore the patches don't really work.

The cause for this is the following part of the script:

#LINUX and others
    tar -T flist.cp -x -z -f $tarball
  fi

The IRIX tar command doesn't support -T.....I happen to have gtar on my system,
so changing the line to

gtar -T flist.cp -x -z -f $tarball

makes it work.

There may be a command set to get the same results with irix tar, but I didn't
investigate further than that.
Comment 1 sander_traveling 2001-01-26 15:35:10 UTC
Re-assigning to Jeff Hanson as IRIX specific.
Comment 2 Unknown 2001-01-26 15:51:44 UTC
Actually it should require /usr/freeware/bin/tar which is gnu tar
versions fw_tar
I = Installed, R = Removed

   Name                 Date        Description

I  fw_tar               08/03/2000  tar-1.13 GNU tar
I  fw_tar.man           08/03/2000  tar-1.13 man pages
I  fw_tar.man.info      08/03/2000  tar-1.13 info pages
I  fw_tar.man.relnotes  08/03/2000  tar-1.13 Release Notes
I  fw_tar.man.tar       08/03/2000  tar-1.13 man pages
I  fw_tar.sw            08/03/2000  tar-1.13 execution only env
I  fw_tar.sw.tar        08/03/2000  tar-1.13 execution only env

I made the assumption that this is likely to be installed for someone interested
in OpenOffice but I didn't document this.  I propose to add a search for
this into config_office/configure.in. This could also work for Solaris or
other non gnu native tar programs.  For now, install fw_tar from
http://freeware.sgi.com.  I'll confirm for OO614B that this works.
Comment 3 issues@www 2001-03-12 17:08:37 UTC
I have a feeling that this issue is probably not resolvable because of the wide
range of user customized stuff.

For example, the gnu tar on my system is called 'gtar'....but I also have
regular irix 'tar' installed, so checking for such details is probably not feasible.

I guess the only check to make would be to test each tar combination to verify
that it is gnu tar....which is probably more work than is necessary.
Comment 4 Martin Hollmichel 2008-03-24 12:39:52 UTC
close issue