Issue 23970 - Crash when invoking 'data in rows' in XY chart
Crash when invoking 'data in rows' in XY chart
Status: CLOSED FIXED
Product: General
Classification: Code
Component: chart
OOo 3.3 or older
All All
: P2 trivial with 2 votes (vote)
: ---
Assigned To: kla
issues@graphics
:
: 23969 24459 27448 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-30 08:50 UTC by ipip
Modified: 2013-02-24 21:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Screenshot (118.58 KB, image/png)
2003-12-30 08:51 UTC, ipip
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ipip 2003-12-30 08:50:17 UTC
OO also crash in the regular version of 1.1.
To crash OO do:
1. Open clean Calc sheet.
2. Create some random data:
   fill in A1-A20 1,2,3,4... 
   fill in B1-B20 =A1*A1 (1,4,9,16,25...)
3. Insert Chart for that data( $Sheet1.$A$1:$B$20 ).
4. Next>>
5. XY Chart
6. Next>>
7. Cubic Spline
8. Next>>
9. Create.
10.On the left toolbar press "Data In Rows"
11.OpenOffice CRASH! "An unrecoverable error has occurred..."

I hope you will fix it soon.
Comment 1 ipip 2003-12-30 08:51:35 UTC
Created attachment 12184 [details]
Screenshot
Comment 2 peter.junge 2003-12-30 09:27:38 UTC
@Björn: Seems at least to work in StarOffice 6
-> Regression Target OOo 1.1.2/PP3
adjusted title and component

@Submitter: lowered Priority because P1 would mean that at least a whole
component (e.g. chart) is _completely_ unusable.


#0  0x47ab1c4b in (anonymous namespace)::lcl_SplineCalculation::Calculate() ()
   from /opt/OpenOffice.org/program/libsch645li.so
#1  0x47ab1b77 in (anonymous
namespace)::lcl_SplineCalculation::lcl_SplineCalculation(_STL::vector<_STL::pair<double,
double>, _STL::allocator<_STL::pair<double, double> > > const&, double, double) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#2  0x47ab22ef in
SchCalculationHelper::CalculateCubicSplines(_STL::vector<_STL::pair<double,
double>, _STL::allocator<_STL::pair<double, double> > > const&, long,
XPolyPolygon&, long, long) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#3  0x47a8247b in ChartModel::Create2DXYChart(Rectangle) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#4  0x47a5d127 in ChartModel::CreateChart(Rectangle const&) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#5  0x47a71951 in ChartModel::BuildChart(unsigned char, long) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#6  0x47a5435b in ChartModel::ChangeSwitchData(unsigned char) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#7  0x47b180ec in SchViewShell::FuTemporary(SfxRequest&) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#8  0x47b18f38 in SfxStubSchViewShellFuTemporary(SfxShell*, SfxRequest&) ()
   from /opt/OpenOffice.org/program/libsch645li.so
#9  0x454091af in SfxDispatcher::Call_Impl(SfxShell&, SfxSlot const&,
SfxRequest---Type <return> to continue, or q <return> to quit---
&, unsigned char) () from /opt/OpenOffice.org/program/libsfx645li.so
#10 0x4540a5d0 in SfxDispatcher::_Execute(SfxShell&, SfxSlot const&,
SfxRequest&, unsigned short) () from /opt/OpenOffice.org/program/libsfx645li.so
#11 0x4541a1bc in SfxBindings::Execute_Impl(SfxRequest&, SfxSlot const*,
SfxShell*) () from /opt/OpenOffice.org/program/libsfx645li.so
#12 0x45419d98 in SfxBindings::Execute_Impl(unsigned short, SfxPoolItem const**,
unsigned short, unsigned short, SfxPoolItem const**, unsigned char) ()
   from /opt/OpenOffice.org/program/libsfx645li.so
#13 0x4541995b in SfxBindings::Execute(unsigned short, SfxPoolItem const**,
unsigned short, unsigned short, SfxPoolItem const**) ()
   from /opt/OpenOffice.org/program/libsfx645li.so
#14 0x454676f6 in SfxToolBoxControl::Select(unsigned char) ()
   from /opt/OpenOffice.org/program/libsfx645li.so
#15 0x454676ab in SfxToolBoxControl::Select(unsigned short) ()
   from /opt/OpenOffice.org/program/libsfx645li.so
#16 0x4544b27a in SfxToolBoxManager::Select(ToolBox*) ()
   from /opt/OpenOffice.org/program/libsfx645li.so
#17 0x4544b216 in SfxToolBoxManager::LinkStubSelect(void*, void*) ()
   from /opt/OpenOffice.org/program/libsfx645li.so
#18 0x4026da4a in ToolBox::Select() ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#19 0x402685dc in ToolBox::ImplHandleMouseButtonUp(MouseEvent const&, unsigned
char) () from /opt/OpenOffice.org/program/libvcl645li.so
---Type <return> to continue, or q <return> to quit---
#20 0x402693fb in ToolBox::Tracking(TrackingEvent const&) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#21 0x40287c4b in Window::EndTracking(unsigned short) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#22 0x4028a0d3 in ImplHandleMouseEvent(Window*, unsigned short, unsigned char,
long, long, unsigned long, unsigned short, unsigned short) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#23 0x4028c942 in ImplWindowFrameProc(void*, SalFrame*, unsigned short, void
const*) () from /opt/OpenOffice.org/program/libvcl645li.so
#24 0x402ec88d in SalFrameData::HandleMouseEvent(_XEvent*) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#25 0x402ee75f in SalFrameData::Dispatch(_XEvent*) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#26 0x4031dedc in SalDisplay::Dispatch(_XEvent*) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#27 0x4031dc22 in SalDisplay::Yield(unsigned char) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#28 0x403199e9 in DisplayYield(int, SalDisplay*) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#29 0x403185ff in SalXLib::Yield(unsigned char) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#30 0x40321302 in SalInstance::Yield(unsigned char) ()
   from /opt/OpenOffice.org/program/libvcl645li.so
---Type <return> to continue, or q <return> to quit---
#31 0x4013b1bd in Application::Yield() ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#32 0x4013b0db in Application::Execute() ()
   from /opt/OpenOffice.org/program/libvcl645li.so
#33 0x08069ac4 in desktop::Desktop::Main() ()
#34 0x4013ffaf in SVMain() () from /opt/OpenOffice.org/program/libvcl645li.so
#35 0x40316f4e in main () from /opt/OpenOffice.org/program/libvcl645li.so
#36 0x4143dd17 in __libc_start_main () from /lib/i686/libc.so.6
Comment 3 peter.junge 2003-12-30 09:30:55 UTC
@TZ: Hope this is OK for PP3.
Comment 4 peter.junge 2003-12-30 09:42:06 UTC
Yes Thomas, you want to be CC
Comment 5 bjoern.milcke 2004-01-09 09:40:11 UTC
Duplicate to internal issue (bug-id: 112350). This is fixed (the CWS sch7pp1
which is integrated) in version FIX645 m1.

PJ: Can't be set to duplicate as the other issue is an internal one, but can be
set to fixed, as the fix is already in the master.
Comment 6 bjoern.milcke 2004-01-09 09:52:41 UTC
*** Issue 23969 has been marked as a duplicate of this issue. ***
Comment 7 peter.junge 2004-01-09 09:55:24 UTC
PJ->TK: Please close this one along with the internal issue.
You can set this one to resolved->verified I think.
Comment 8 kla 2004-01-09 10:28:27 UTC
fixed
Comment 9 peter.junge 2004-01-09 10:31:30 UTC
OOPS, wrong owner
Comment 10 peter.junge 2004-01-09 10:32:23 UTC
sorry for the mail traffic
Comment 11 kla 2004-01-09 10:37:12 UTC
verified
Comment 12 kla 2004-01-09 14:47:49 UTC
*** Issue 23969 has been marked as a duplicate of this issue. ***
Comment 13 kla 2004-01-16 09:52:20 UTC
*** Issue 24459 has been marked as a duplicate of this issue. ***
Comment 14 ipip 2004-03-04 22:26:41 UTC
verified in 1.1.1a in debian experimental package. I think you can add it to the
kist of the fixed bugs in 1.1.1.

Thank you guys!
You are great!
Comment 15 kla 2004-04-06 13:44:37 UTC
closed
Comment 16 kla 2004-04-06 13:46:05 UTC
*** Issue 27448 has been marked as a duplicate of this issue. ***