Issue 22858 - Program crashes when using ‘undoÂ’ with 3d view
Program crashes when using ‘undo’ with 3d view
Status: CLOSED FIXED
Product: General
Classification: Code
Component: chart
OOo 3.3 or older
PC All
: P3 trivial (vote)
: ---
Assigned To: kla
issues@graphics
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 00:37 UTC by georginikolov
Modified: 2013-02-24 21:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description georginikolov 2003-11-26 00:37:59 UTC
Steps to reproduce:
1)Start the presentation component
2)Create a "title, chart" slide
3)Double click to add a chart
4)Right click on the chart, select Chart TypeÂ…, select 3D, press OK
5)Select Format -> 3D ViewÂ… ->Enter some number in the x axis field (100.0 for 
example) and press OK.
6)Right click on the chart, select Chart TypeÂ…, select 2D, press OK
7)Select ‘Undo: Edit chart type’
8)Select ‘Undo: Edit 3D view'
9)Select ‘Undo: '

90% of time step 9) crashes the program. In case it doesnÂ’t you have to 
press ‘undo’ until the beginning and then pressing ‘redo’ several times, 
you’ll see ‘redo: ‘ that crashes it.

Sometimes it crashes even if step 6) is replaces with other step or is not 
there at all.
Comment 1 wolframgarten 2003-11-26 08:25:51 UTC
Changed component to chart and reassigned it.
Comment 2 kla 2003-11-27 12:52:28 UTC
Hi Bjoern,
as discussed, for you.
tk
Comment 3 bjoern.milcke 2003-11-28 09:43:33 UTC
Looks like svx would create an extra undo-action for the change of the
3d-transformation matrix.
Comment 4 bjoern.milcke 2003-11-28 17:16:56 UTC
The undo-action was created by the chart function.  I removed it. Undo
still does not work very well, but the problem is, that the rotation
entered in the dialog moves the camera whereas the rotation with the
mouse rotates the scene. Thus the old values filled in the dialog are
incorrect.

In the new chart implementation we will no longer rotate the camera.
Comment 5 bjoern.milcke 2003-12-04 13:46:55 UTC
Please verify
Comment 6 kla 2003-12-15 14:22:43 UTC
verified
Comment 7 kla 2003-12-15 14:23:11 UTC
verified
Comment 8 kla 2004-01-22 10:59:19 UTC
closed