Issue 13212 - Wrong clipboard format (localized data)
Wrong clipboard format (localized data)
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: code
OOo 1.1 Beta
PC Windows 2000
: P3 trivial (vote)
: ---
Assigned To: frank
issues@sc
:
Depends on:
Blocks: 13197
  Show dependency treegraph
 
Reported: 2003-04-09 12:54 UTC by josef.cacek
Modified: 2013-08-07 15:12 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Table with czech chars (3.03 KB, image/jpeg)
2003-04-09 12:55 UTC, josef.cacek
no flags Details
Clipboard format "Enhanced Metafile" is OK (48.14 KB, image/jpeg)
2003-04-09 12:57 UTC, josef.cacek
no flags Details
Clipboard format "Picture" is wrong (49.43 KB, image/jpeg)
2003-04-09 12:57 UTC, josef.cacek
no flags Details
Calc document for testing copy&paste (5.18 KB, application/octet-stream)
2003-04-09 14:00 UTC, josef.cacek
no flags Details
clipboard format Picture from build 8600 (69.97 KB, image/jpeg)
2003-06-04 12:31 UTC, josef.cacek
no flags Details
Screenshot showing correct behaviour (30.20 KB, image/gif)
2003-06-04 13:26 UTC, frank
no flags Details
The clipboard content of my W2k SP3 (145.89 KB, application/octet-stream)
2003-06-05 10:23 UTC, frank
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description josef.cacek 2003-04-09 12:54:47 UTC
I have localized data in list and I want use copy&paste functionality to get it
into another application. Most of clipboard formats is OK, but into format
"Picture" are placed wrong data (problem eg. when exporting into MS-Paint).
See attachments for screenshots.
Comment 1 josef.cacek 2003-04-09 12:55:57 UTC
Created attachment 5541 [details]
Table with czech chars
Comment 2 josef.cacek 2003-04-09 12:57:10 UTC
Created attachment 5542 [details]
Clipboard format "Enhanced Metafile" is OK
Comment 3 josef.cacek 2003-04-09 12:57:47 UTC
Created attachment 5543 [details]
Clipboard format "Picture" is wrong
Comment 4 frank 2003-04-09 13:53:52 UTC
Hi,

could you please attach a document that uses such chararcters ?

It makes work much easier.

Thanks

Frank
Comment 5 josef.cacek 2003-04-09 14:00:44 UTC
Created attachment 5544 [details]
Calc document for testing copy&paste
Comment 6 frank 2003-04-09 16:04:39 UTC
Hi Sven,

as discussed this one is for you.

Frank
Comment 7 sven.jacobi 2003-04-15 15:32:13 UTC
SJ->HDU: We are converting GDIMetafiles into EMF files if pasting into
other applications on windows. I found out that the problem already
happened if recording our own GDI metafile format.

I changed the target, because I think that this issue is really
important and should be fixed for 6.1 Beta2.

Could you please have a look at it and provide this Issue to the
proper person.


Comment 8 hdu@apache.org 2003-04-15 18:59:35 UTC
HDU->SJ: have a look at the MetaTextArrayAction::Write() method and especially 
  the line with WriteByteString( maUnicodeStr, pData->meActualCharSet :-) 
 
Comment 9 sven.jacobi 2003-04-16 10:04:13 UTC
This bug needs to be fixed, I will start just now.
Comment 10 sven.jacobi 2003-04-16 11:37:31 UTC
This bug has been fixed now, it will be available in OOo1.1 Beta2.

The fix takes place in cws[mav4]->vcl/source/gdi/metaact.cxx

Thanks for providing this bug.
Comment 11 sven.jacobi 2003-04-22 11:14:01 UTC
SJ->FST: This bug is now ready to be verified on cws[mav4].
Comment 12 frank 2003-04-23 10:54:24 UTC
Restoring fixed state
Comment 13 oc 2003-04-23 12:52:31 UTC
Verified in internal build mav04
Comment 14 frank 2003-05-07 10:48:18 UTC
Found integrated in srx644m13
Comment 15 josef.cacek 2003-06-03 16:42:28 UTC
Still the bug for Picture clipboard format in OOo1.1Beta2.
Comment 16 kla 2003-06-04 11:07:59 UTC
Sorry, i can't reproduce it. It works fine.
Build Id: 8600
Comment 17 kla 2003-06-04 11:08:30 UTC
Closed fixed
Comment 18 josef.cacek 2003-06-04 12:31:24 UTC
Created attachment 6649 [details]
clipboard format Picture from build 8600
Comment 19 josef.cacek 2003-06-04 12:35:11 UTC
I created new attachment with screenshot from clipbrd.exe, data was
copied from English OOo11Beta2. 
Can you provide screeshot like this from your windows, if this runs
correctly for you?

part of setup.ini:
ProfileItem gid_Profileitem_Bootstrap_Buildid
	ModuleID	 = gid_Module_Root;
	ProfileID	 = gid_Profile_Bootstrap_Ini;
	Section		 = "Bootstrap";
	Key			 = "buildid";
	Value		 = "644(Build:8600)";
	Order		 = 6;
End
Comment 20 frank 2003-06-04 13:25:00 UTC
It's the same version and build ID.

I've attached a screenshot of the clipboard viewer on my system.

Frank
Comment 21 frank 2003-06-04 13:26:21 UTC
Created attachment 6650 [details]
Screenshot showing correct behaviour
Comment 22 hassmanm 2003-06-04 15:19:12 UTC
I have the same results as kwart on OO1.1beta2 on windows 2000
(Service Pack 2).

I have tested it on two computers (but with the same configuration)
with original OO1.1beta2 and also on some czech localized builds of
OO1.1beta2 and I have obtained same results as kwart in attachment
(id=6649) everytime!

From clipbrd.exe - there is possible to save content of the clipboard
(with all clipboard formats) and later open it in clipbrd.exe.

TO fst: Can you please put your saved clipboard as attachement, so we
can compare it on our computers?
Comment 23 frank 2003-06-05 10:23:00 UTC
Created attachment 6669 [details]
The clipboard content of my W2k SP3
Comment 24 josef.cacek 2003-06-05 11:11:20 UTC
It's really OK in your clipboard.
I have also Win2K SP3 and the bug is there :(.
Has the file vcl644mi.dll from your installation 1,884,226 B?
(MD5sum: a6fd0d576ab9fa16dea074fbdb1628b7 *vcl644mi.dll)
Comment 25 frank 2003-06-05 11:35:35 UTC
Yeep,

Byte count and md5sum are the same for vcl644mi.dll

Frank
Comment 26 josef.cacek 2003-06-05 12:06:11 UTC
I've get it.
My locale and default language settings was set to Czech. If I change
it to English (US) it's OK.
Probably default language settings for system is the main problem. I
have WinNT4 with configuration [default regional settings:Czech;
regional settings: English] on second machine and bug is also there.

Can you correct also this bug?
Comment 27 hassmanm 2003-06-05 12:25:50 UTC
Yes kwart has true. The same for me on win2k Service Pack 2.

The bug depends on default locale. Not on current locale.

1) When I have in Control panels-Regional Option:
  Your locale(location):
    Czech

  Language settings for your system:
    Central Europe (defalt)
    Wester Europe and United States

BUG happened

2) When I change this to (and restart computer):
  Your locale(location):
    Czech

  Language settings for your system:
    Central Europe
    Wester Europe and United States (Defalt)
Everyting seems O.K.
Comment 28 frank 2003-06-05 13:52:51 UTC
Hi,

finally we found out what the problem is. Sorry to tell you, but we
can't fix it. The problem is that the picture view is an WMF format.
WMF is not capable to handle unicode characters. So this is a problem
of the underlying picture format. 

What we have fixed is the ability to use the other formats in
conjunction with metafiles.

Sorry for no better reply.

Frank
Comment 29 frank 2003-06-05 13:56:58 UTC
closed fixed