Issue 12666 - autofilter works just on one sheet (only one auto-range per document)
autofilter works just on one sheet (only one auto-range per document)
Status: RESOLVED FIXED
Product: Calc
Classification: Application
Component: formatting
3.4.0
All All
: P3 trivial with 101 votes (vote)
: 4.0.0
Assigned To: Zhang Lu
issues@sc
: ms_interoperability, rfe_eval_ok
: 11594 25214 35647 38042 40113 44394 51706 67394 73169 82037 88087 94823 95546 105091 108389 114345 117332 118143 120479 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-26 14:14 UTC by Unknown
Modified: 2013-09-13 16:01 UTC (History)
38 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
autofilter test spreadsheet (10.14 KB, application/vnd.sun.xml.calc)
2006-04-11 19:31 UTC, dkeskar
no flags Details
function spec (15.17 KB, application/vnd.oasis.opendocument.text)
2012-08-13 02:31 UTC, Zhang Lu
zhanglu.aoo: review?
Details
Add patch (121.08 KB, patch)
2012-08-14 02:16 UTC, Zhang Lu
zhanglu.aoo: review?
Details | Diff
Add patch (28.31 KB, patch)
2012-08-14 08:06 UTC, Zhang Lu
zhanglu.aoo: review?
Details | Diff
test cases for new filter feature (23.41 KB, application/vnd.oasis.opendocument.text)
2012-08-15 07:02 UTC, Tan Li
litan.test: review?
Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-03-26 14:14:50 UTC
I'm working for Sun Microsystems and so using also staroffice. I found the same problem with seting up autofilter as with staroffice (fixed now in version 6b). If you activate an autofilter on, let's say sheet-1 and after that you set an autofilter on sheet-2, your autofilter is gone on sheet-1.

This is specially ignoring if you use more sheets in one document.
Comment 1 oc 2003-05-28 13:42:43 UTC
Thats not quite correct; you can have more than one autofilter but
only if you define a range per dataarea (DATA-DEFINE RANGE).
I agree that this in not very intuitive, therefor I set this issue as
enhancement
Comment 2 bettina.haberer 2003-12-04 18:23:08 UTC
Summary: Allow setting autofilters on several sheets
This one is considered for Office Later.
Comment 3 askoning 2004-01-03 19:37:49 UTC
This problem is also (still) present in 1.1.0 and 1.1.1a for Linux.
And what has not been commented until now -and what I'd like to note here- is
that losing the autofilter does not unhide the filtered-away rows, which is
quite annoying.
If possible please consider raising priority to 3. Thanks.
Comment 4 frank 2004-02-09 10:53:48 UTC
*** Issue 25214 has been marked as a duplicate of this issue. ***
Comment 5 john.marmion 2004-02-13 10:06:54 UTC
*** Issue 11594 has been marked as a duplicate of this issue. ***
Comment 6 noidea 2004-02-14 17:28:10 UTC
From the duplicates it more precisely boils down to: 
 
1) support multiple "auto-data-ranges" in OOo documents 
 
That is what ppl implicitly rely on for easy autofiltering and is needed so that subsequent data 
additions to their tables do not break filtering. (at the point when a static range does not 
include additions anymore) 
 
2) don't forget to remove workaround in .xls filter that: 
  - imports auto-ranges as static data ranges 
  - exept when only one auto-range present.  (issue 10995) 
 (user does not notice this but strange things will happen later)  (really bad) 
 
Comment 7 frank 2004-10-18 09:01:35 UTC
*** Issue 35647 has been marked as a duplicate of this issue. ***
Comment 8 frank 2004-11-29 10:32:33 UTC
*** Issue 38042 has been marked as a duplicate of this issue. ***
Comment 9 frank 2005-01-07 16:16:23 UTC
*** Issue 40113 has been marked as a duplicate of this issue. ***
Comment 10 frank 2005-03-24 13:26:41 UTC
*** Issue 44394 has been marked as a duplicate of this issue. ***
Comment 11 frank 2005-07-08 10:41:29 UTC
*** Issue 51706 has been marked as a duplicate of this issue. ***
Comment 12 javascriptdude 2005-07-09 06:54:05 UTC
If this issue is not going to be fixed prior to 2.0 final, please at least
please patch the issue posted by askoning on Sat Jan 3 12:37:49 -0700 2004:

When adding second filter on spreadsheet, initial filter is removed but the rows
remain hidden.

If the first filter is removed, please have it removed completely. i.e. Remove
filter graphics and show all hidden rows.

If left unfixed, this issue will be troublesome to many new users who are trying
to switch to OOO from MSO.
Comment 13 dkeskar 2006-04-11 19:27:19 UTC
This is annoying & counterintuitive. Just to reiterate. 
1) Select autofilter in sheet 1 - choose some column & value
2) Switch to sheet 2 & select autofilter
3) Come back to sheet 1. Autofilter UI (arrows) are gone. But sheet only shows
filtered data. 
Comment 14 dkeskar 2006-04-11 19:31:02 UTC
Created attachment 35639 [details]
autofilter test spreadsheet
Comment 15 delorea 2006-07-16 20:50:41 UTC
*** Issue 67394 has been marked as a duplicate of this issue. ***
Comment 16 norbert2 2006-07-16 21:57:48 UTC
The fact that the sheet where the autofilter buttons have vanished shows
filtered data makes this issue a DEFECT, non an ENHANCEMENT.
Comment 17 gnustavo 2006-08-21 19:13:12 UTC
I'd second that.  Please, consider changing the issue type to deffect.
Comment 18 kpalagin 2007-01-05 20:49:48 UTC
*** Issue 73169 has been marked as a duplicate of this issue. ***
Comment 19 bettina.haberer 2007-09-26 15:39:09 UTC
Hi Niklas, please take this issue to your ownership. Thank you!
Comment 20 kpalagin 2007-11-20 09:00:45 UTC
*** Issue 82037 has been marked as a duplicate of this issue. ***
Comment 21 kpalagin 2007-11-27 13:30:16 UTC
Niklas,
what is your take on this issue?
Do you consider it important? Does it have a chance of being resolved for 3.0?

Thanks a lot for your response.
Regards,
Kirill Palagin.
Comment 22 kyoshida 2008-01-25 14:33:06 UTC
Issue 85305 is relevant to this issue.  That one fixes the static database range
issue when importing an Excel document by supporting dynamic resizing of
filtered range at run-time.  This way we can leave the current importer behavior
as-is.  This also has the added benefit that the user can now append new data
rows and have them take effect immediately without resetting the autofilter
explicitly.
Comment 23 frank 2008-04-09 11:52:01 UTC
*** Issue 88087 has been marked as a duplicate of this issue. ***
Comment 24 pagalmes.lists 2008-04-09 12:58:28 UTC
+1 with kpalagin

It would really be great to see this one in OOo 3.0 as this has 60 votes.
Comment 25 villeroy 2008-04-29 21:27:33 UTC
A simple solution: http://www.openoffice.org/issues/show_bug.cgi?id=66015
Comment 26 frank.loehmann 2008-05-22 09:31:33 UTC
This issue is important and listed on the quarterly review for Calc:
http://wiki.services.openoffice.org/wiki/2008_Q2_Review_of_Spreadsheet_Project
Therefore adjusting target to 3.x.
Comment 27 anowak 2008-07-29 11:12:19 UTC
As long as this issue is not fixed, you can use the autOOoFilter extension
http://extensions.services.openoffice.org/project/autOOoFiltre .
Comment 28 frank 2008-10-10 08:59:14 UTC
*** Issue 94823 has been marked as a duplicate of this issue. ***
Comment 29 Rainer Bielefeld 2008-10-29 06:36:55 UTC
*** Issue 95546 has been marked as a duplicate of this issue. ***
Comment 30 mrmaceurope 2009-08-03 17:41:28 UTC
Any update on this issue?
Comment 31 dtardon 2009-09-17 09:15:37 UTC
*** Issue 105091 has been marked as a duplicate of this issue. ***
Comment 32 clemare 2009-12-18 05:52:53 UTC
Same issue here... I detect it happening in OOO310m19 Build 9420 on Mac OS X and
NeoOffice (yes I know, this is not the place, but is good to know that
derivatives work has also the problem).

I consider that this is a very important Bug, and I can't believe that there is
only 20 people following this.

Well I just figured out that if I select the range and define a name for that
"database range" the autofilter will stay if you autofilter another range. I
also discover that the problem occurs in the same sheet as in other tabs sheets.
And finally, in order to mantain Excel compatibility (and in this case is not an
Excel Bug, I mean that have 2 autofilters without defining a "database range")
OOo should work like Excel.

Thanks.

clemare
Comment 33 clemare 2009-12-18 05:54:04 UTC
Same issue here... I detect it happening in OOO310m19 Build 9420 on Mac OS X and
NeoOffice (yes I know, this is not the place, but is good to know that
derivatives work has also the problem).

I consider that this is a very important Bug, and I can't believe that there is
only 20 people following this.

Well I just figured out that if I select the range and define a name for that
"database range" the autofilter will stay if you autofilter another range. I
also discover that the problem occurs in the same sheet as in other tabs sheets.
And finally, in order to mantain Excel compatibility (and in this case is not an
Excel Bug, I mean that have 2 autofilters without defining a "database range")
OOo should work like Excel.

Thanks.

clemare
Comment 34 Regina Henschel 2010-01-17 14:56:07 UTC
*** Issue 108389 has been marked as a duplicate of this issue. ***
Comment 35 jbf.faure 2010-01-24 22:39:50 UTC
Add me to cc.
Comment 36 annunaki2k2 2010-05-25 12:02:51 UTC
Just been hit by this one - agreeing with most comments so far. It really does
feel like a defect rather than an enhancement. Please can we get this on into
the next version of oo?
Comment 37 syzygy 2010-06-19 06:18:02 UTC
Maybe 3.3? This important improvement, and much it is necessary. Already 91 
voice.
Comment 38 philhibbs 2010-11-18 13:38:14 UTC
Also, copying a sheet that has an AutoFilter creates a sheet that has the
drop-down button but no filtered area defined. This gives the impression that it
has been copied with the filter intact, but it is non-functional. It should
either work or be cleared as part of the copy process.
Comment 39 Regina Henschel 2011-03-11 13:46:51 UTC
*** Issue 117332 has been marked as a duplicate of this issue. ***
Comment 40 Regina Henschel 2011-03-11 13:59:39 UTC
*** Issue 114345 has been marked as a duplicate of this issue. ***
Comment 41 Regina Henschel 2011-06-07 15:40:51 UTC
*** Issue 118143 has been marked as a duplicate of this issue. ***
Comment 42 de_logics 2011-07-13 13:18:48 UTC
Popular bug.
Comment 43 louqle 2012-06-13 06:55:05 UTC
the problem remains in Aoo 3.4. It's a popular function, suggest to fix
Comment 44 Regina Henschel 2012-06-13 15:49:20 UTC
Name your data range by menu Data > Define Range. Then you can have an autofilter for each range.
Comment 45 Andrey 2012-06-15 00:08:25 UTC
I wonder, why this bug is marked as "enhancement", as this deficiency literally making the suite unusable.
Comment 46 Robert Pollak 2012-06-15 07:22:47 UTC
By the way, LibreOffice has this fixed, see https://bugs.freedesktop.org/show_bug.cgi?id=38548 .
Comment 47 Regina Henschel 2012-08-07 10:18:52 UTC
*** Issue 120479 has been marked as a duplicate of this issue. ***
Comment 48 Andrey 2012-08-07 10:36:50 UTC
Wait, I think, I have "un idea".
There was an issue (I don't know, if it's still true), when you ask Calc to print current sheet, it'd print whole book.
The root of this bug may be there. It defining one autofilter range per "sheet" that is actually a whole book.
Comment 49 Zhang Lu 2012-08-13 02:31:01 UTC
Created attachment 78913 [details]
function spec

I am working on this issue, I have attached function spec, and will upload patch soon.
Comment 50 Zhang Lu 2012-08-14 02:16:47 UTC
Created attachment 78920 [details]
Add patch

I have uploaded patch for this issue
Comment 51 Zhang Lu 2012-08-14 08:06:55 UTC
Created attachment 78935 [details]
Add patch

latest patch
Comment 52 Wang Lei 2012-08-14 08:27:40 UTC
Zhang Lu, thanks for your codes.

I apply the patch at revision 1372767
Comment 53 Tan Li 2012-08-15 07:02:14 UTC
Created attachment 78947 [details]
test cases for  new filter feature
Comment 54 fanyuzhen 2013-09-13 16:01:42 UTC
I do not see this problem on build AOO401m4(Build:9713)  -  Rev. 1521921