Issue 123681 - Unresponsive warning window, program can not export to rescue data, only force quit will close
Unresponsive warning window, program can not export to rescue data, only forc...
Status: RESOLVED DUPLICATE of issue 119006
Product: General
Classification: Code
Component: ui
4.0.1
Mac Mac OSX, 10.9
: P3 blocker with 7 votes (vote)
: 4.1.0
Assigned To: AOO issues mailing list
:
: 123749 123833 123878 123911 123923 124024 124029 124047 124113 124152 124169 124208 124215 124274 124317 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 21:12 UTC by trysil7
Modified: 2014-03-10 08:21 UTC (History)
28 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description trysil7 2013-11-13 21:12:20 UTC
My AOO was upgraded to 4.0.1. on Sept 20, 2013. After upgrading my MacBook Pro to OSX 10.9 on Oct. 26, 2013, I CANNOT USE AOO 4.0.1! 

AOO 4.0.1 loads very slow, many top tool bar options are unresponsive, and once loaded a warning window appears foremost in center screen. The warning window contents are, “The last time you opened OpenOffice, it unexpectedly quit while reopening windows. Do you want to try to reopen its windows again? If you choose not to reopen windows, you may have to open and position the windows yourself." At the bottom of the window are two buttons, ”Don't reopen" & "Reopen.” Neither button produces any response. 

The warning window will not disappear or move to the background.
Uninstalling/re-installing AOO 4.0.1 does not affect/correct the problem. AOO documents cannot exported for access by another software  package! (I have huge amounts of data that are only accessible from screen captures!) Only Force Quit will quit/close AOO 4.0.1.
Comment 1 jlong 2013-11-16 17:14:43 UTC
I have the same issue on MAC. Cannot Save or Save As because window will not open. OpenOffice is unusable and have to use TextEdit to open office documents.
Comment 2 drowlord76 2013-11-28 20:07:40 UTC
I have the same issue with mine as well no matter how many times I might delete the program or reinstall
Comment 3 Paul 2013-12-04 20:31:20 UTC
I have this same issue on iMac.  AOO worked fine for months, even after update to Mavericks, but began exhibiting this same behavior.  Any attempt to open AOO produces this same dialogue box who's buttons are unresponsive.  Box won't go away without a forced quit.  I installed/uninstalled and tried deleting the entire user profile directory (Users/<user>/Library/Application Support/OpenOffice) with no effect.  The app's Preferences and Quit selections from the menu are grayed out so the only way to quit the app is to force quit from the OS.  Very unfortunate.
Comment 4 Rainer Bielefeld 2013-12-12 14:02:04 UTC
Looks like DUP of "Bug 119006 - Restore windows problem on Mac OS X", but that one should have been fixed for 4.0.1?

I doubt that that's a Writer issue.

@reporter:
thank you for your feedback! Unfortunately you are wrong here, this is the AOO bug tracking system, not a help desk.
You can get assistance at
<http://user.services.openoffice.org/en/forum/>
or here:<http://www.openoffice.org/support/>
If you want to report bugs please consider hints on <http://wiki.openoffice.org/wiki/QA/HowToFileIssue> 

Are you sure that you selected correct AOO Version?
Comment 5 David 2013-12-13 17:09:07 UTC
I have the same "pesky" OpenOffice quit unexpectedly. I can't even un-install, the 4.0, force to quit doesn't work as well??
Any other suggestions?
Comment 6 rchev 2013-12-20 00:37:24 UTC
This renders AOO completely unusable--a major crash problem!
Comment 7 Rainer Bielefeld 2013-12-27 18:30:04 UTC
*** Issue 123878 has been marked as a duplicate of this issue. ***
Comment 8 Rainer Bielefeld 2013-12-27 18:30:16 UTC
*** Issue 123833 has been marked as a duplicate of this issue. ***
Comment 9 Rainer Bielefeld 2013-12-27 18:30:57 UTC
*** Issue 123911 has been marked as a duplicate of this issue. ***
Comment 10 Rainer Bielefeld 2013-12-27 18:31:06 UTC
*** Issue 123749 has been marked as a duplicate of this issue. ***
Comment 11 Rainer Bielefeld 2013-12-30 15:40:24 UTC
CONFIRMED by number of DUPS.

Might be a DUP of "Bug 119006 - Restore windows problem on Mac OS X"  (if that one has reappeared), but that's not sure; might also be a new bug with the same symptoms.
Comment 12 Rainer Bielefeld 2013-12-30 15:52:35 UTC
@hdu
Can you please check? Or forward to someone else with MAC experience?
Comment 13 lgusaas 2013-12-30 15:57:22 UTC
(In reply to Rainer Bielefeld from comment #11)
> CONFIRMED by number of DUPS.
> 
> Might be a DUP of "Bug 119006 - Restore windows problem on Mac OS X"  (if
> that one has reappeared), but that's not sure; might also be a new bug with
> the same symptoms.

I had bug occur once after getting new computer with OSX ver.10.9 (Mavericks).
Same workaround as for Bug 119006 fixed the problem:
Option-click the Go menu
Choose Library from the menu to open the folder in the Finder.
Click on the folder Saved Application State
Delete the file org.openoffice.script.savedState
Comment 14 Rainer Bielefeld 2013-12-31 15:07:45 UTC
*** Issue 123923 has been marked as a duplicate of this issue. ***
Comment 15 trysil7 2013-12-31 22:58:21 UTC
(In reply to lgusaas from comment #13)
> (In reply to Rainer Bielefeld from comment #11)
> > CONFIRMED by number of DUPS.
> > 
> > Might be a DUP of "Bug 119006 - Restore windows problem on Mac OS X"  (if
> > that one has reappeared), but that's not sure; might also be a new bug with
> > the same symptoms.
> 
> I had bug occur once after getting new computer with OSX ver.10.9
> (Mavericks).
> Same workaround as for Bug 119006 fixed the problem:
> Option-click the Go menu
> Choose Library from the menu to open the folder in the Finder.
> Click on the folder Saved Application State
> Delete the file org.openoffice.script.savedState

THIS WORKAROUND WORKS!!!!!! THANK YOU AND BLESS YOU!
Comment 16 trysil7 2013-12-31 23:05:50 UTC
(In reply to Rainer Bielefeld from comment #14)
> *** Bug 123923 has been marked as a duplicate of this bug. ***

PLEASE SEE WORKAROUND COMMENT IN COMMENT # 13 FROM LGUSAAS!

THIS WORKS! THANKS TO YOU AND ALL WHO HAVE WORKED TO FIX THIS PROBLEM!

HAPPY NEW YEAR!!!!
Comment 17 trysil7 2013-12-31 23:10:40 UTC
(In reply to trysil7 from comment #16)
> (In reply to Rainer Bielefeld from comment #14)
> > *** Bug 123923 has been marked as a duplicate of this bug. ***
> 
> PLEASE SEE WORKAROUND COMMENT IN COMMENT # 13 FROM LGUSAAS!
> 
> THIS WORKS! THANKS TO YOU AND ALL WHO HAVE WORKED TO FIX THIS PROBLEM!
> 
> HAPPY NEW YEAR!!!!
Comment 18 Rainer Bielefeld 2014-01-15 05:29:25 UTC
*** Issue 124024 has been marked as a duplicate of this issue. ***
Comment 19 Rainer Bielefeld 2014-01-15 14:58:30 UTC
*** Issue 124029 has been marked as a duplicate of this issue. ***
Comment 20 Rainer Bielefeld 2014-01-18 16:25:09 UTC
*** Issue 124047 has been marked as a duplicate of this issue. ***
Comment 21 Rainer Bielefeld 2014-01-26 08:55:02 UTC
*** Issue 124113 has been marked as a duplicate of this issue. ***
Comment 22 Rainer Bielefeld 2014-01-31 08:05:54 UTC
*** Issue 124152 has been marked as a duplicate of this issue. ***
Comment 23 Rainer Bielefeld 2014-02-02 20:08:38 UTC
*** Issue 124169 has been marked as a duplicate of this issue. ***
Comment 24 Scott Skinner 2014-02-02 23:33:48 UTC
I am also now unable to create a new document.
Comment 25 neo442 2014-02-02 23:51:05 UTC
if fixing this bug is important to you, you ought to vote for priority at the top. I know i can't get to any of my files till it's fixed.
Comment 26 neo442 2014-02-04 13:13:30 UTC
try comment 13- this works! Thanks Igusaas
Comment 27 Rainer Bielefeld 2014-02-08 19:07:16 UTC
*** Issue 124208 has been marked as a duplicate of this issue. ***
Comment 28 Rainer Bielefeld 2014-02-10 21:52:51 UTC
*** Issue 124215 has been marked as a duplicate of this issue. ***
Comment 29 Rainer Bielefeld 2014-02-21 06:12:10 UTC
*** Issue 124274 has been marked as a duplicate of this issue. ***
Comment 30 hdu@apache.org 2014-02-24 09:50:27 UTC
Duplicate to the just fixed bug 119006

*** This issue has been marked as a duplicate of issue 119006 ***
Comment 31 jgc 2014-02-24 13:45:25 UTC
Still having lots of problems opening .docx files.  Am unable to download attachments MS-WORD files in eMails.  I keep having to go into library and eliminate OpenOffice preferences
Comment 32 Rainer Bielefeld 2014-02-26 10:27:07 UTC
*** Issue 124317 has been marked as a duplicate of this issue. ***
Comment 33 Rainer Bielefeld 2014-03-03 16:17:12 UTC
*** Issue 124352 has been marked as a duplicate of this issue. ***
Comment 34 trysil7 2014-03-03 21:46:21 UTC
Do I understand that you have decided Bug 123681 (Unresponsive warning window, program can not export to rescue data, only force quit will close, etc.) HAS BEEN FIXED? Then why do I need to continually resort to the "workaround" (see—Comment #13 — lgusaas 2013-12-30 15:57:22 UTC.) I have produced so many documents in AOO that it will take many hours/days to transfer them to another program! 

• If this problem has really been fixed will you please send me information on how to access it? Thanks — Trysil7@aol.com
Comment 35 hdu@apache.org 2014-03-04 07:44:10 UTC
Yes, it has been fixed and the fix will be available in the AOO 4.1 release. It will also be available in the imminent AOO 4.1 beta and in intermediate snapshots.
Comment 36 trysil7 2014-03-06 23:49:10 UTC
(In reply to hdu@apache.org from comment #35)
> Yes, it has been fixed and the fix will be available in the AOO 4.1 release.
> It will also be available in the imminent AOO 4.1 beta and in intermediate
> snapshots.


PLEASE, when will AOO 4.1 be released? I am having so much trouble dealing with "not being able to reliably access my files!"
Comment 37 hdu@apache.org 2014-03-10 08:21:22 UTC
(In reply to trysil7 from comment #36)
> PLEASE, when will AOO 4.1 be released? I am having so much trouble dealing
> with "not being able to reliably access my files!"

The AOO community just released AOO 4.1 Beta. The final version of AOO 4.1 will be released when the the community decides so.