Issue 122988 - Extension odt2daisy: Crashes on Save as Daisy XML
Extension odt2daisy: Crashes on Save as Daisy XML
Status: CLOSED NOT_AN_ISSUE
Product: Writer
Classification: Application
Component: save-export
4.0.0
PC Windows 7
: P3 normal (vote)
: ---
Assigned To: AOO issues mailing list
http://extensions.services.openoffice...
: crash, regression
Depends on: 121544
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 23:14 UTC by Angella Anderson
Modified: 2013-08-13 09:31 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Angella Anderson 2013-08-08 23:14:18 UTC
OO crashes when saving to Daisyxml.. Program says it will recover file and goes through the recovery process and does recover the odt file, but no xml.  Cannot get an xml file, which is crucial to run through the Pipeline to produce the files that we need for our students with disabilites.  We are at a University producing textbooks for students.  We are trying to produce foreign language books with language switches and this is the only workflow that will produce this.

Please help!
Thanks,
Angie
Comment 1 Edwin Sharp 2013-08-09 06:46:07 UTC
Install extension Export as DAISY / Audiobook (odt2daisy) 2.1.0
File- Export as DAISY XML...
Crash.

Rev. 1503704 Win 7
Comment 2 Rainer Bielefeld 2013-08-09 11:31:24 UTC
This might be a problem of the Extension and not of AOo, so currently this can't block anything at AOO.

I checked AOO extensions repository: Currently there is no compatibility promised with AOO ... . So back to UNCONFIRMED for now, until we know more about plans whether that extension is planned to be updated for AOO 4.

@Angella, Edwin:
In Extension related Bugs please always contribute information what Version of the extension from what download source you tried.

Edwin:
Can you please send a hint to Extension's owner, leave a comment in Extension?
Comment 3 Rainer Bielefeld 2013-08-09 11:32:29 UTC
Well, I will submit a Bug, more info soon.
Comment 4 Rainer Bielefeld 2013-08-09 11:45:12 UTC
I think that's <http://sourceforge.net/p/odt2daisy/bugs/10/>, so I close this one for now. But I will follow in that Bug on SF, and please feel free to reopen this Bug if you think it should be available as a communication platform of if you find evidence that the reason for the crash is within AOO (I don't think so).
Comment 5 hdu@apache.org 2013-08-09 11:53:26 UTC
Revision 1425608 of bug 121544 changed XMessageBoxFactory's createMessageBox() method's signature so the ODT2Daisy extension no longer finds it. The second parameter is now MessageBoxType instead of awt::Rectangle. The exception thrown is:

[jni_uno bridge error] UNO calling Java method dispatch: non-UNO exception occurred: java.lang.NoSuchMethodError: com.sun.star.awt.XMessageBoxFactory.createMessageBox(Lcom/sun/star/awt/XWindowPeer;Lcom/sun/star/awt/Rectangle;Ljava/lang/String;ILjava/lang/String;Ljava/lang/String;)Lcom/sun/star/awt/XMessageBox;

Other than that problem Odt2DaisyAddOn 2.1.2 as a java extension would work on all platforms if its description.xml file would remove the "platform value" line that currently limits it to 32bit Windows ("windows_x86").
Comment 6 Edwin Sharp 2013-08-09 12:01:33 UTC
Vincent Spiewak

http://odt2daisy.sourceforge.net/about/
Comment 7 Angella Anderson 2013-08-09 14:14:32 UTC
Hello,

I removed Ver 4.0 from my computer and reinstalled ver 3.4 and it fixed the problem.  So the problem seems to be a compatibility problem with Ver 4.0.
Comment 8 Edwin Sharp 2013-08-09 14:16:45 UTC
Thank you for this information!
Comment 9 Ariel Constenla-Haile 2013-08-13 05:03:43 UTC
This isn't a bug.
The extension code would not even compile if the developer build it with the 4.0 SDK.
Comment 10 Ariel Constenla-Haile 2013-08-13 05:07:01 UTC
(In reply to Angella Anderson from comment #7)
> So the problem seems to be a compatibility problem with Ver 4.0.

Yes. You should contact the extension authors and ask them to update their extension for OpenOffice (and related products, as the code has been committed elsewhere http://cgit.freedesktop.org/libreoffice/core/commit/?id=805c6101b3427cc98b53f1c48f22f705206c384d )

Closing
Comment 11 Christophe Strobbe 2013-08-13 09:31:41 UTC
Thanks for reporting this. It looks like an issue in odt2daisy (https://sourceforge.net/p/odt2daisy/bugs/11/).